From: John Fastabend <john.fastabend@gmail.com> Date: 2020-01-27 00:14:23
A couple updates to cleanup some of the XDP comments and rcu usage.
It would be best if patch 1/3 goes into current bpf-next with the
associated patch in the fixes tag so we don't have out of sync
comments in the code. Just noting because its close to time to close
{bpf|net}-next branches.
v2->v3: Jesper noticed I can't spell, so fixed spelling. If we
are fixing comments its best to have correct spelling.
v1->v2: Added 2/3 patch for virtio_net to use rcu_access_pointer
and avoid read_lock.
John Fastabend (3):
bpf: xdp, update devmap comments to reflect napi/rcu usage
bpf: xdp, virtio_net use access ptr macro for xdp enable check
bpf: xdp, remove no longer required rcu_read_{un}lock()
drivers/net/veth.c | 6 +++++-
drivers/net/virtio_net.c | 2 +-
kernel/bpf/devmap.c | 26 ++++++++++++++------------
3 files changed, 20 insertions(+), 14 deletions(-)
--
2.7.4
From: John Fastabend <john.fastabend@gmail.com> Date: 2020-01-27 00:14:32
Now that we rely on synchronize_rcu and call_rcu waiting to
exit perempt-disable regions (NAPI) lets update the comments
to reflect this.
Fixes: 0536b85239b84 ("xdp: Simplify devmap cleanup")
Acked-by: Björn Töpel <redacted>
Acked-by: Song Liu <redacted>
Signed-off-by: John Fastabend <john.fastabend@gmail.com>
---
kernel/bpf/devmap.c | 21 +++++++++++----------
1 file changed, 11 insertions(+), 10 deletions(-)
@@ -193,10 +193,12 @@ static void dev_map_free(struct bpf_map *map)/* At this point bpf_prog->aux->refcnt == 0 and this map->refcnt == 0,*sotheprograms(canbemorethanonethatusedthismap)were-*disconnectedfromevents.Waitforoutstandingcriticalsectionsin-*theseprogramstocomplete.Thercucriticalsectiononlyguarantees-*nofurtherreadsagainstnetdev_map.Itdoes__not__ensurepending-*flushoperations(ifany)arecomplete.+*disconnectedfromevents.Thefollowingsynchronize_rcu()guarantees+*bothrcureadcriticalsectionscompleteandwaitsfor+*preempt-disableregions(NAPIbeingtherelevantcontexthere)sowe+*arecertaintherewillbenofurtherreadsagainstthenetdev_mapand+*allflushoperationsarecomplete.Flushoperationscanonlybedone+*fromNAPIcontextforthisreason.*/spin_lock(&dev_map_lock);
@@ -498,12 +500,11 @@ static int dev_map_delete_elem(struct bpf_map *map, void *key)return-EINVAL;/* Use call_rcu() here to ensure any rcu critical sections have-*completed,butthisdoesnotguaranteeaflushhashappened-*yet.Becausedriversidercu_read_lock/unlockonlyprotectsthe-*runningXDPprogram.However,forpendingflushoperationsthe-*devandctxarestoredinanotherpercpumap.Andadditionally,-*thedriverteardownensuresallsoftirqsarecompletebefore-*removingthenetdeviceinthecaseofdev_putequalszero.+*completedaswellasanyflushoperationsbecausecall_rcu+*willwaitforpreempt-disableregiontocomplete,NAPIinthis+*context.Andadditionally,thedriverteardownensuresall+*softirqsarecompletebeforeremovingthenetdeviceinthe+*caseofdev_putequalszero.*/old_dev=xchg(&dtab->netdev_map[k],NULL);if(old_dev)
From: John Fastabend <john.fastabend@gmail.com> Date: 2020-01-27 00:14:42
virtio_net currently relies on rcu critical section to access the xdp
program in its xdp_xmit handler. However, the pointer to the xdp program
is only used to do a NULL pointer comparison to determine if xdp is
enabled or not.
Use rcu_access_pointer() instead of rcu_dereference() to reflect this.
Then later when we drop rcu_read critical section virtio_net will not
need in special handling.
Acked-by: Jesper Dangaard Brouer <redacted>
Signed-off-by: John Fastabend <john.fastabend@gmail.com>
---
drivers/net/virtio_net.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
@@ -501,7 +501,7 @@ static int virtnet_xdp_xmit(struct net_device *dev,/* Only allow ndo_xdp_xmit if XDP is loaded on dev, as this*indicateXDPresourceshavebeensuccessfullyallocated.*/-xdp_prog=rcu_dereference(rq->xdp_prog);+xdp_prog=rcu_access_pointer(rq->xdp_prog);if(!xdp_prog)return-ENXIO;
From: John Fastabend <john.fastabend@gmail.com> Date: 2020-01-27 00:14:52
Now that we depend on rcu_call() and synchronize_rcu() to also wait
for preempt_disabled region to complete the rcu read critical section
in __dev_map_flush() is no longer required. Except in a few special
cases in drivers that need it for other reasons.
These originally ensured the map reference was safe while a map was
also being free'd. And additionally that bpf program updates via
ndo_bpf did not happen while flush updates were in flight. But flush
by new rules can only be called from preempt-disabled NAPI context.
The synchronize_rcu from the map free path and the rcu_call from the
delete path will ensure the reference there is safe. So lets remove
the rcu_read_lock and rcu_read_unlock pair to avoid any confusion
around how this is being protected.
If the rcu_read_lock was required it would mean errors in the above
logic and the original patch would also be wrong.
Now that we have done above we put the rcu_read_lock in the driver
code where it is needed in a driver dependent way. I think this
helps readability of the code so we know where and why we are
taking read locks. Most drivers will not need rcu_read_locks here
and further XDP drivers already have rcu_read_locks in their code
paths for reading xdp programs on RX side so this makes it symmetric
where we don't have half of rcu critical sections define in driver
and the other half in devmap.
Acked-by: Jesper Dangaard Brouer <redacted>
Signed-off-by: John Fastabend <john.fastabend@gmail.com>
---
drivers/net/veth.c | 6 +++++-
kernel/bpf/devmap.c | 5 +++--
2 files changed, 8 insertions(+), 3 deletions(-)
@@ -372,16 +372,17 @@ static int bq_xmit_all(struct xdp_bulk_queue *bq, u32 flags)*fromNET_RX_SOFTIRQ.Eitherwaythepollroutinemustcompletebeforethe*netdevicecanbetorndown.Ondevmapteardownweensuretheflushlist*isemptybeforecompletingtoensureallflushoperationshavecompleted.+*Whendriversupdatethebpfprogramtheymayneedtoensureanyflushops+*arealsocomplete.Usingsynchronize_rcuorcall_rcuwillsufficeforthis+*becausebothwaitfornapicontexttoexit.*/void__dev_map_flush(void){structlist_head*flush_list=this_cpu_ptr(&dev_map_flush_list);structxdp_bulk_queue*bq,*tmp;-rcu_read_lock();list_for_each_entry_safe(bq,tmp,flush_list,flush_node)bq_xmit_all(bq,XDP_XMIT_FLUSH);-rcu_read_unlock();}/* rcu_read_lock (from syscall and BPF contexts) ensures that if a delete and/or
From: Daniel Borkmann <daniel@iogearbox.net> Date: 2020-01-27 10:58:44
On 1/27/20 1:13 AM, John Fastabend wrote:
A couple updates to cleanup some of the XDP comments and rcu usage.
It would be best if patch 1/3 goes into current bpf-next with the
associated patch in the fixes tag so we don't have out of sync
comments in the code. Just noting because its close to time to close
{bpf|net}-next branches.
v2->v3: Jesper noticed I can't spell, so fixed spelling. If we
are fixing comments its best to have correct spelling.
v1->v2: Added 2/3 patch for virtio_net to use rcu_access_pointer
and avoid read_lock.
John Fastabend (3):
bpf: xdp, update devmap comments to reflect napi/rcu usage
bpf: xdp, virtio_net use access ptr macro for xdp enable check
bpf: xdp, remove no longer required rcu_read_{un}lock()
drivers/net/veth.c | 6 +++++-
drivers/net/virtio_net.c | 2 +-
kernel/bpf/devmap.c | 26 ++++++++++++++------------
3 files changed, 20 insertions(+), 14 deletions(-)
Series applied, thanks. I had to manually massage the patch 3/3 as it
wasn't rebased onto bpf-next.
From: Maciej Fijalkowski <maciej.fijalkowski@intel.com> Date: 2020-01-27 17:11:36
On Sun, Jan 26, 2020 at 04:14:01PM -0800, John Fastabend wrote:
virtio_net currently relies on rcu critical section to access the xdp
program in its xdp_xmit handler. However, the pointer to the xdp program
is only used to do a NULL pointer comparison to determine if xdp is
enabled or not.
Use rcu_access_pointer() instead of rcu_dereference() to reflect this.
Then later when we drop rcu_read critical section virtio_net will not
need in special handling.
Acked-by: Jesper Dangaard Brouer <redacted>
Signed-off-by: John Fastabend <john.fastabend@gmail.com>
Acked-by: Maciej Fijalkowski <maciej.fijalkowski@intel.com>