Currently, the upper half of a 4-byte STATS_TYPE_PORT statistic ends
up in bits 47:32 of the return value, instead of bits 31:16 as they
should.
Signed-off-by: Rasmus Villemoes <redacted>
---
I also noticed that it's a bit inconsistent that we return U64_MAX if
there's a read error in STATS_TYPE_PORT, while
mv88e6xxx_g1_stats_read() returns 0 in case of a read error. In
practice, register reads probably never fail so it doesn't matter.
drivers/net/dsa/mv88e6xxx/chip.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
From: Andrew Lunn <andrew@lunn.ch> Date: 2019-05-28 13:45:05
On Tue, May 28, 2019 at 01:17:10PM +0000, Rasmus Villemoes wrote:
Currently, the upper half of a 4-byte STATS_TYPE_PORT statistic ends
up in bits 47:32 of the return value, instead of bits 31:16 as they
should.
Signed-off-by: Rasmus Villemoes <redacted>
Hi Rasmus
Please include a Fixes tag, to indicate where the problem was
introduced. In this case, i think it was:
Fixes: 6e46e2d821bb ("net: dsa: mv88e6xxx: Fix u64 statistics")
And set the Subject to [PATCH net] to indicate this should be applied
to the net tree.
quoted hunk
---
I also noticed that it's a bit inconsistent that we return U64_MAX if
there's a read error in STATS_TYPE_PORT, while
mv88e6xxx_g1_stats_read() returns 0 in case of a read error. In
practice, register reads probably never fail so it doesn't matter.
drivers/net/dsa/mv88e6xxx/chip.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
What i don't like about this is how the function finishes:
}
value = (((u64)high) << 32) | low;
return value;
}
A better fix might be
- break
+ value = (((u64)high) << 16 | low;
+ return value;
Andrew
On Tue, May 28, 2019 at 01:17:10PM +0000, Rasmus Villemoes wrote:
quoted
Currently, the upper half of a 4-byte STATS_TYPE_PORT statistic ends
up in bits 47:32 of the return value, instead of bits 31:16 as they
should.
Signed-off-by: Rasmus Villemoes <redacted>
Hi Rasmus
Please include a Fixes tag, to indicate where the problem was
introduced. In this case, i think it was:
Fixes: 6e46e2d821bb ("net: dsa: mv88e6xxx: Fix u64 statistics")
And set the Subject to [PATCH net] to indicate this should be applied
to the net tree.
What i don't like about this is how the function finishes:
}
value = (((u64)high) << 32) | low;
return value;
}
A better fix might be
- break
+ value = (((u64)high) << 16 | low;
+ return value;
Why? It's odd to have the u32 "high" sometimes represent the high 32
bits, sometimes the third 16 bits. It would make it harder to support an
8-byte STATS_TYPE_PORT statistic. I think the code is much cleaner if
each case is just responsible for providing the upper/lower 32 bits,
then have the common case combine them; . It's just that in the
STATS_TYPE_BANK cases, the 32 bits are assembled from two 16 bit values
by a helper (mv88e6xxx_g1_stats_read), while it is "open-coded" in the
first case.
I'll resend my patch with the fixes tag (thanks for finding that; I had
already dug way too deep past that one) and fixed subject.
Rasmus
From: Vivien Didelot <hidden> Date: 2019-05-29 17:10:58
Hi Rasmus, Andrew,
On Wed, 29 May 2019 06:42:53 +0000, Rasmus Villemoes [off-list ref] wrote:
On 28/05/2019 15.44, Andrew Lunn wrote:
quoted
On Tue, May 28, 2019 at 01:17:10PM +0000, Rasmus Villemoes wrote:
quoted
Currently, the upper half of a 4-byte STATS_TYPE_PORT statistic ends
up in bits 47:32 of the return value, instead of bits 31:16 as they
should.
Signed-off-by: Rasmus Villemoes <redacted>
Hi Rasmus
Please include a Fixes tag, to indicate where the problem was
introduced. In this case, i think it was:
Fixes: 6e46e2d821bb ("net: dsa: mv88e6xxx: Fix u64 statistics")
And set the Subject to [PATCH net] to indicate this should be applied
to the net tree.
What i don't like about this is how the function finishes:
}
value = (((u64)high) << 32) | low;
return value;
}
A better fix might be
- break
+ value = (((u64)high) << 16 | low;
+ return value;
Why? It's odd to have the u32 "high" sometimes represent the high 32
bits, sometimes the third 16 bits. It would make it harder to support an
8-byte STATS_TYPE_PORT statistic. I think the code is much cleaner if
each case is just responsible for providing the upper/lower 32 bits,
then have the common case combine them; . It's just that in the
STATS_TYPE_BANK cases, the 32 bits are assembled from two 16 bit values
by a helper (mv88e6xxx_g1_stats_read), while it is "open-coded" in the
first case.
Here "low" and "high" are u32 and refer to the upper and lower halves
of the u64 returned value. For a 4-byte STATS_TYPE_PORT value, the
second read refers to the bits 31:16, thus belongs to (the upper half
of) the lower half of the 64-bit returned value, i.e. "low".
The current return value is correct, as well as your patch.
Thanks,
Vivien