# Re: \[PATCH net-next\] net, decnet: use struct\_size() in kzalloc()

- From: David Miller \<davem@davemloft.net\>
- Date: 2019-01-16 21:22:36 
- List: netdev
- Page: https://ratatoskr.run/netdev/2019/01/5485767
- Thread: https://ratatoskr.run/netdev/2019/01/5484594/t.md

```text
From: "Gustavo A. R. Silva" <redacted>
Date: Tue, 15 Jan 2019 13:50:06 -0600

> One of the more common cases of allocation size calculations is finding the
> size of a structure that has a zero-sized array at the end, along with memory
> for some number of elements for that array. For example:
> 
> struct foo {
>     int stuff;
>     struct boo entry[];
> };
> 
> instance = kzalloc(sizeof(struct foo) + count * sizeof(struct boo), GFP_KERNEL);
> 
> Instead of leaving these open-coded and prone to type mistakes, we can now
> use the new struct_size() helper:
> 
> instance = kzalloc(struct_size(instance, entry, count), GFP_KERNEL);
> 
> This code was detected with the help of Coccinelle.
> 
> Signed-off-by: Gustavo A. R. Silva <redacted>

Applied, thanks.
```
