[PATCH] mlxsw: spectrum_acl_bloom_filter: use struct_size() in kzalloc()

Subsystems: mellanox ethernet switch drivers, networking drivers, the rest

STALE2814d

3 messages, 2 authors, 2018-12-24 · open the first message on its own page

[PATCH] mlxsw: spectrum_acl_bloom_filter: use struct_size() in kzalloc()

From: Gustavo A. R. Silva <hidden>
Date: 2018-12-24 05:27:51

One of the more common cases of allocation size calculations is finding
the size of a structure that has a zero-sized array at the end, along
with memory for some number of elements for that array. For example:

struct foo {
    int stuff;
    void *entry[];
};

instance = kzalloc(sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);

Instead of leaving these open-coded and prone to type mistakes, we can
now use the new struct_size() helper:

instance = kzalloc(struct_size(instance, entry, count), GFP_KERNEL);

This issue was detected with the help of Coccinelle.

Signed-off-by: Gustavo A. R. Silva <redacted>
---
 .../net/ethernet/mellanox/mlxsw/spectrum_acl_bloom_filter.c   | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/net/ethernet/mellanox/mlxsw/spectrum_acl_bloom_filter.c b/drivers/net/ethernet/mellanox/mlxsw/spectrum_acl_bloom_filter.c
index 505b87846acc..f5c381dcb015 100644
--- a/drivers/net/ethernet/mellanox/mlxsw/spectrum_acl_bloom_filter.c
+++ b/drivers/net/ethernet/mellanox/mlxsw/spectrum_acl_bloom_filter.c
@@ -234,8 +234,8 @@ mlxsw_sp_acl_bf_init(struct mlxsw_sp *mlxsw_sp, unsigned int num_erp_banks)
 	 * is 2^ACL_MAX_BF_LOG
 	 */
 	bf_bank_size = 1 << MLXSW_CORE_RES_GET(mlxsw_sp->core, ACL_MAX_BF_LOG);
-	bf = kzalloc(sizeof(*bf) + bf_bank_size * num_erp_banks *
-		     sizeof(*bf->refcnt), GFP_KERNEL);
+	bf = kzalloc(struct_size(bf, refcnt, bf_bank_size * num_erp_banks),
+		     GFP_KERNEL);
 	if (!bf)
 		return ERR_PTR(-ENOMEM);
 
-- 
2.17.0

Re: [PATCH] mlxsw: spectrum_acl_bloom_filter: use struct_size() in kzalloc()

From: Ido Schimmel <hidden>
Date: 2018-12-24 07:38:45

On Sun, Dec 23, 2018 at 11:27:41PM -0600, Gustavo A. R. Silva wrote:
One of the more common cases of allocation size calculations is finding
the size of a structure that has a zero-sized array at the end, along
with memory for some number of elements for that array. For example:

struct foo {
    int stuff;
    void *entry[];
};

instance = kzalloc(sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);

Instead of leaving these open-coded and prone to type mistakes, we can
now use the new struct_size() helper:

instance = kzalloc(struct_size(instance, entry, count), GFP_KERNEL);

This issue was detected with the help of Coccinelle.

Signed-off-by: Gustavo A. R. Silva <redacted>
Reviewed-by: Ido Schimmel <redacted>

But net-next is closed (http://vger.kernel.org/~davem/net-next.html) and
this isn't a bug fix. Can you please re-submit when net-next opens
again? Alternatively, I can apply the patch to my mlxsw queue and submit
in your stead. Let me know what you prefer.

Thanks!

Re: [PATCH] mlxsw: spectrum_acl_bloom_filter: use struct_size() in kzalloc()

From: Gustavo A. R. Silva <hidden>
Date: 2018-12-24 07:47:13


On 12/24/18 1:38 AM, Ido Schimmel wrote:
On Sun, Dec 23, 2018 at 11:27:41PM -0600, Gustavo A. R. Silva wrote:
quoted
One of the more common cases of allocation size calculations is finding
the size of a structure that has a zero-sized array at the end, along
with memory for some number of elements for that array. For example:

struct foo {
     int stuff;
     void *entry[];
};

instance = kzalloc(sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);

Instead of leaving these open-coded and prone to type mistakes, we can
now use the new struct_size() helper:

instance = kzalloc(struct_size(instance, entry, count), GFP_KERNEL);

This issue was detected with the help of Coccinelle.

Signed-off-by: Gustavo A. R. Silva <redacted>
Reviewed-by: Ido Schimmel <redacted>

But net-next is closed (http://vger.kernel.org/~davem/net-next.html) and
this isn't a bug fix. Can you please re-submit when net-next opens
again? Alternatively, I can apply the patch to my mlxsw queue and submit
in your stead. Let me know what you prefer.
Oh yeah. I forgot net close net-next during the merge window. I'll
re-submit it in two weeks then. I'll add your Reviewed-by.

Happy holiday.

Thanks
--
Gustavo
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help