[PATCH net-next 1/1] net sched actions: rename act_get_notify() to tcf_get_notify()

Subsystems: networking [general], tc subsystem, the rest

STALE3354d

3 messages, 2 authors, 2017-07-05 · open the first message on its own page

[PATCH net-next 1/1] net sched actions: rename act_get_notify() to tcf_get_notify()

From: Roman Mashak <hidden>
Date: 2017-07-05 19:34:08

Make name consistent with other TC event notification routines.

Signed-off-by: Roman Mashak <redacted>
---
 net/sched/act_api.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/net/sched/act_api.c b/net/sched/act_api.c
index aed6cf2..f2e9ed3 100644
--- a/net/sched/act_api.c
+++ b/net/sched/act_api.c
@@ -835,7 +835,7 @@ static int tca_get_fill(struct sk_buff *skb, struct list_head *actions,
 }
 
 static int
-act_get_notify(struct net *net, u32 portid, struct nlmsghdr *n,
+tcf_get_notify(struct net *net, u32 portid, struct nlmsghdr *n,
 	       struct list_head *actions, int event)
 {
 	struct sk_buff *skb;
@@ -1018,7 +1018,7 @@ static int tca_action_flush(struct net *net, struct nlattr *nla,
 	}
 
 	if (event == RTM_GETACTION)
-		ret = act_get_notify(net, portid, n, &actions, event);
+		ret = tcf_get_notify(net, portid, n, &actions, event);
 	else { /* delete */
 		ret = tcf_del_notify(net, n, &actions, portid);
 		if (ret)
-- 
1.9.1

Re: [PATCH net-next 1/1] net sched actions: rename act_get_notify() to tcf_get_notify()

From: Jiri Pirko <jiri@resnulli.us>
Date: 2017-07-05 20:31:49

Wed, Jul 05, 2017 at 09:33:58PM CEST, mrv@mojatatu.com wrote:
quoted hunk
Make name consistent with other TC event notification routines.

Signed-off-by: Roman Mashak <redacted>
---
net/sched/act_api.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/net/sched/act_api.c b/net/sched/act_api.c
index aed6cf2..f2e9ed3 100644
--- a/net/sched/act_api.c
+++ b/net/sched/act_api.c
@@ -835,7 +835,7 @@ static int tca_get_fill(struct sk_buff *skb, struct list_head *actions,
}

static int
-act_get_notify(struct net *net, u32 portid, struct nlmsghdr *n,
+tcf_get_notify(struct net *net, u32 portid, struct nlmsghdr *n,
Rather call it "tcf_action_get_notify"

+ net-next is closed if I'm not mistaken

Re: [PATCH net-next 1/1] net sched actions: rename act_get_notify() to tcf_get_notify()

From: Roman Mashak <hidden>
Date: 2017-07-05 21:13:37

Jiri Pirko [off-list ref] writes:
Wed, Jul 05, 2017 at 09:33:58PM CEST, mrv@mojatatu.com wrote:
quoted
Make name consistent with other TC event notification routines.

Signed-off-by: Roman Mashak <redacted>
---
net/sched/act_api.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/net/sched/act_api.c b/net/sched/act_api.c
index aed6cf2..f2e9ed3 100644
--- a/net/sched/act_api.c
+++ b/net/sched/act_api.c
@@ -835,7 +835,7 @@ static int tca_get_fill(struct sk_buff *skb, struct list_head *actions,
}

static int
-act_get_notify(struct net *net, u32 portid, struct nlmsghdr *n,
+tcf_get_notify(struct net *net, u32 portid, struct nlmsghdr *n,
Rather call it "tcf_action_get_notify"
We already have tcf_add_notify() and tcf_del_notify() as a common style.
+ net-next is closed if I'm not mistaken
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help