[PATCH trivial 2/4] rtlwifi: rtl8821ae: Spelling s/wrtie_addr/write_addr/

Subsystems: realtek wireless driver (rtlwifi family), the rest

STALE3467d

4 messages, 3 authors, 2017-02-17 · open the first message on its own page

[PATCH trivial 2/4] rtlwifi: rtl8821ae: Spelling s/wrtie_addr/write_addr/

From: Geert Uytterhoeven <geert+renesas@glider.be>
Date: 2017-02-17 15:36:53

As per symmetry with _rtl8821ae_dbi_read(), "wrtie" is not a funky
register acronym, but a simple misspelling of "write".

Signed-off-by: Geert Uytterhoeven <geert+renesas@glider.be>
Cc: Larry Finger <redacted>
Cc: Chaoming Li <redacted>
Cc: netdev@vger.kernel.org
---
 drivers/net/wireless/realtek/rtlwifi/rtl8821ae/hw.c | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/net/wireless/realtek/rtlwifi/rtl8821ae/hw.c b/drivers/net/wireless/realtek/rtlwifi/rtl8821ae/hw.c
index 4f83eee1ff75bc81..546f085afb8f42fa 100644
--- a/drivers/net/wireless/realtek/rtlwifi/rtl8821ae/hw.c
+++ b/drivers/net/wireless/realtek/rtlwifi/rtl8821ae/hw.c
@@ -1135,13 +1135,13 @@ static u8 _rtl8821ae_dbi_read(struct rtl_priv *rtlpriv, u16 addr)
 static void _rtl8821ae_dbi_write(struct rtl_priv *rtlpriv, u16 addr, u8 data)
 {
 	u8 tmp = 0, count = 0;
-	u16 wrtie_addr, remainder = addr % 4;
+	u16 write_addr, remainder = addr % 4;
 
-	wrtie_addr = REG_DBI_WDATA + remainder;
-	rtl_write_byte(rtlpriv, wrtie_addr, data);
+	write_addr = REG_DBI_WDATA + remainder;
+	rtl_write_byte(rtlpriv, write_addr, data);
 
-	wrtie_addr = (addr & 0xfffc) | (BIT(0) << (remainder + 12));
-	rtl_write_word(rtlpriv, REG_DBI_ADDR, wrtie_addr);
+	write_addr = (addr & 0xfffc) | (BIT(0) << (remainder + 12));
+	rtl_write_word(rtlpriv, REG_DBI_ADDR, write_addr);
 
 	rtl_write_byte(rtlpriv, REG_DBI_FLAG, 0x1);
 
-- 
1.9.1

Re: [PATCH trivial 2/4] rtlwifi: rtl8821ae: Spelling s/wrtie_addr/write_addr/

From: Larry Finger <hidden>
Date: 2017-02-17 16:14:48

On 02/17/2017 09:36 AM, Geert Uytterhoeven wrote:
As per symmetry with _rtl8821ae_dbi_read(), "wrtie" is not a funky
register acronym, but a simple misspelling of "write".

Signed-off-by: Geert Uytterhoeven <geert+renesas@glider.be>
Cc: Larry Finger <redacted>
Cc: Chaoming Li <redacted>
Cc: netdev@vger.kernel.org
I'm not sure that it is possible to have a typo in a variable name. That seems 
to be within an author's prerogative. Nonetheless, the patch is OK other than it 
was sent to the wrong destination. Patches for this driver should go through 
linux-wireless@vger.kernel.org. Kalle Valo is the wireless maintainer, but it is 
not necessary to send to him directly as he usually picks up the patches from 
Patchwork.

Larry
quoted hunk
---
 drivers/net/wireless/realtek/rtlwifi/rtl8821ae/hw.c | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/net/wireless/realtek/rtlwifi/rtl8821ae/hw.c b/drivers/net/wireless/realtek/rtlwifi/rtl8821ae/hw.c
index 4f83eee1ff75bc81..546f085afb8f42fa 100644
--- a/drivers/net/wireless/realtek/rtlwifi/rtl8821ae/hw.c
+++ b/drivers/net/wireless/realtek/rtlwifi/rtl8821ae/hw.c
@@ -1135,13 +1135,13 @@ static u8 _rtl8821ae_dbi_read(struct rtl_priv *rtlpriv, u16 addr)
 static void _rtl8821ae_dbi_write(struct rtl_priv *rtlpriv, u16 addr, u8 data)
 {
 	u8 tmp = 0, count = 0;
-	u16 wrtie_addr, remainder = addr % 4;
+	u16 write_addr, remainder = addr % 4;

-	wrtie_addr = REG_DBI_WDATA + remainder;
-	rtl_write_byte(rtlpriv, wrtie_addr, data);
+	write_addr = REG_DBI_WDATA + remainder;
+	rtl_write_byte(rtlpriv, write_addr, data);

-	wrtie_addr = (addr & 0xfffc) | (BIT(0) << (remainder + 12));
-	rtl_write_word(rtlpriv, REG_DBI_ADDR, wrtie_addr);
+	write_addr = (addr & 0xfffc) | (BIT(0) << (remainder + 12));
+	rtl_write_word(rtlpriv, REG_DBI_ADDR, write_addr);

 	rtl_write_byte(rtlpriv, REG_DBI_FLAG, 0x1);

Re: [PATCH trivial 2/4] rtlwifi: rtl8821ae: Spelling s/wrtie_addr/write_addr/

From: Geert Uytterhoeven <geert@linux-m68k.org>
Date: 2017-02-17 16:20:03

Hi Larry,

On Fri, Feb 17, 2017 at 5:14 PM, Larry Finger [off-list ref] wrote:
On 02/17/2017 09:36 AM, Geert Uytterhoeven wrote:
quoted
As per symmetry with _rtl8821ae_dbi_read(), "wrtie" is not a funky
register acronym, but a simple misspelling of "write".

Signed-off-by: Geert Uytterhoeven <geert+renesas@glider.be>
Cc: Larry Finger <redacted>
Cc: Chaoming Li <redacted>
Cc: netdev@vger.kernel.org
I'm not sure that it is possible to have a typo in a variable name. That
seems to be within an author's prerogative. Nonetheless, the patch is OK
;-)
other than it was sent to the wrong destination. Patches for this driver
MAINTAINERS has your name for drivers/net/wireless/realtek/rtlwifi/.
Perhaps that line should be dropped?
should go through linux-wireless@vger.kernel.org. Kalle Valo is the wireless
maintainer, but it is not necessary to send to him directly as he usually
picks up the patches from Patchwork.
I guess Jiri (trivial) will pick it up...

Gr{oetje,eeting}s,

                        Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                -- Linus Torvalds

Re: [PATCH trivial 2/4] rtlwifi: rtl8821ae: Spelling s/wrtie_addr/write_addr/

From: Larry Finger <hidden>
Date: 2017-02-17 16:42:19

On 02/17/2017 10:19 AM, Geert Uytterhoeven wrote:
Hi Larry,

On Fri, Feb 17, 2017 at 5:14 PM, Larry Finger [off-list ref] wrote:
quoted
On 02/17/2017 09:36 AM, Geert Uytterhoeven wrote:
quoted
As per symmetry with _rtl8821ae_dbi_read(), "wrtie" is not a funky
register acronym, but a simple misspelling of "write".

Signed-off-by: Geert Uytterhoeven <geert+renesas@glider.be>
Cc: Larry Finger <redacted>
Cc: Chaoming Li <redacted>
Cc: netdev@vger.kernel.org
I'm not sure that it is possible to have a typo in a variable name. That
seems to be within an author's prerogative. Nonetheless, the patch is OK
;-)
quoted
other than it was sent to the wrong destination. Patches for this driver
MAINTAINERS has your name for drivers/net/wireless/realtek/rtlwifi/.
Perhaps that line should be dropped?
The usual hierarchy is through me to Kalle, then to DaveM, and finally to mainline.
quoted
should go through linux-wireless@vger.kernel.org. Kalle Valo is the wireless
maintainer, but it is not necessary to send to him directly as he usually
picks up the patches from Patchwork.
I guess Jiri (trivial) will pick it up...
The only potential problem would be conflicts arising from changes merging from 
two different directions. It applies to Kalle's wireless-drivers-next branch, 
and I will try to keep it in mind as additional patches are supplied to rtl8821ae.

Larry
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help