[PATCH net-next 1/1] driver: ipvlan: Use NF_IP_PRI_LAST as hook priority instead of INT_MAX
From: <hidden>
Date: 2016-11-27 10:24:51
From: Gao Feng <redacted> It is better to use NF_IP_PRI_LAST instead of INT_MAX as hook priority. The former is good at readability and easier to maintain. Signed-off-by: Gao Feng <redacted> --- drivers/net/ipvlan/ipvlan_main.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/net/ipvlan/ipvlan_main.c b/drivers/net/ipvlan/ipvlan_main.c
index ab90b22..d70d245 100644
--- a/drivers/net/ipvlan/ipvlan_main.c
+++ b/drivers/net/ipvlan/ipvlan_main.c@@ -16,13 +16,13 @@ .hook = ipvlan_nf_input, .pf = NFPROTO_IPV4, .hooknum = NF_INET_LOCAL_IN, - .priority = INT_MAX, + .priority = NF_IP_PRI_LAST, }, { .hook = ipvlan_nf_input, .pf = NFPROTO_IPV6, .hooknum = NF_INET_LOCAL_IN, - .priority = INT_MAX, + .priority = NF_IP_PRI_LAST, }, };
--
1.9.1