[PATCH 0868/1285] Replace numeric parameter like 0444 with macro

DORMANTno replies

From: Baole Ni <hidden>
Date: 2016-08-02 12:43:07
Also in: lkml
Subsystem: networking drivers, ptp hardware clock support, the rest · Maintainers: Andrew Lunn, "David S. Miller", Eric Dumazet, Jakub Kicinski, Paolo Abeni, Richard Cochran, Linus Torvalds

I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <redacted>
Signed-off-by: Baole Ni <redacted>
---
 drivers/ptp/ptp_pch.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/ptp/ptp_pch.c b/drivers/ptp/ptp_pch.c
index 3aa22ae..8bbcdb6 100644
--- a/drivers/ptp/ptp_pch.c
+++ b/drivers/ptp/ptp_pch.c
@@ -727,7 +727,7 @@ module_init(ptp_pch_init);
 module_exit(ptp_pch_exit);
 
 module_param_string(station,
-		    pch_param.station, sizeof(pch_param.station), 0444);
+		    pch_param.station, sizeof(pch_param.station), S_IRUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(station,
 	 "IEEE 1588 station address to use - colon separated hex values");
 
-- 
2.9.2
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help