[PATCH net-next] rps: flow_dissector: Add the const for the parameter of flow_keys_have_l4
From: <hidden>
Date: 2016-08-31 03:16:55
From: Gao Feng <redacted> Add the const for the parameter of flow_keys_have_l4 for the readability. Signed-off-by: Gao Feng <redacted> --- include/net/flow_dissector.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/net/flow_dissector.h b/include/net/flow_dissector.h
index f266b51..d953492 100644
--- a/include/net/flow_dissector.h
+++ b/include/net/flow_dissector.h@@ -183,7 +183,7 @@ struct flow_keys_digest { void make_flow_keys_digest(struct flow_keys_digest *digest, const struct flow_keys *flow); -static inline bool flow_keys_have_l4(struct flow_keys *keys) +static inline bool flow_keys_have_l4(const struct flow_keys *keys) { return (keys->ports.ports || keys->tags.flow_label); }
--
1.9.1