[PATCH v2 1/2] rtlwifi: Fix improve function 'rtl_addr_delay()' in core.c

Subsystems: realtek wireless driver (rtlwifi family), the rest

STALE3839d REVIEWED: 1 (0M)

1 review trailer.

4 messages, 3 authors, 2016-02-03 · open the first message on its own page

[PATCH v2 1/2] rtlwifi: Fix improve function 'rtl_addr_delay()' in core.c

From: Byeoungwook Kim <hidden>
Date: 2016-02-03 02:15:19

Conditional codes in rtl_addr_delay() were improved in readability and
performance by using switch codes.

Signed-off-by: Byeoungwook Kim <redacted>
Reviewed-by: Julian Calaby <redacted>
---
V2 split in separate patchs.
 drivers/net/wireless/realtek/rtlwifi/core.c | 20 ++++++++++++++------
 1 file changed, 14 insertions(+), 6 deletions(-)
diff --git a/drivers/net/wireless/realtek/rtlwifi/core.c b/drivers/net/wireless/realtek/rtlwifi/core.c
index 4ae421e..05f432c 100644
--- a/drivers/net/wireless/realtek/rtlwifi/core.c
+++ b/drivers/net/wireless/realtek/rtlwifi/core.c
@@ -37,18 +37,26 @@
 
 void rtl_addr_delay(u32 addr)
 {
-	if (addr == 0xfe)
+	switch (addr) {
+	case 0xfe:
 		mdelay(50);
-	else if (addr == 0xfd)
+		break;
+	case 0xfd:
 		mdelay(5);
-	else if (addr == 0xfc)
+		break;
+	case 0xfc:
 		mdelay(1);
-	else if (addr == 0xfb)
+		break;
+	case 0xfb:
 		udelay(50);
-	else if (addr == 0xfa)
+		break;
+	case 0xfa:
 		udelay(5);
-	else if (addr == 0xf9)
+		break;
+	case 0xf9:
 		udelay(1);
+		break;
+	};
 }
 EXPORT_SYMBOL(rtl_addr_delay);
 
-- 
2.5.0

[PATCH] rtlwifi: fix semicolon.cocci warnings

From: kbuild test robot <hidden>
Date: 2016-02-03 03:37:45

drivers/net/wireless/realtek/rtlwifi/core.c:59:2-3: Unneeded semicolon


 Remove unneeded semicolon.

Generated by: scripts/coccinelle/misc/semicolon.cocci

CC: Byeoungwook Kim <redacted>
Signed-off-by: Fengguang Wu <redacted>
---

 core.c |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
--- a/drivers/net/wireless/realtek/rtlwifi/core.c
+++ b/drivers/net/wireless/realtek/rtlwifi/core.c
@@ -56,7 +56,7 @@ void rtl_addr_delay(u32 addr)
 	case 0xf9:
 		udelay(1);
 		break;
-	};
+	}
 }
 EXPORT_SYMBOL(rtl_addr_delay);
 

Re: [PATCH v2 1/2] rtlwifi: Fix improve function 'rtl_addr_delay()' in core.c

From: kbuild test robot <hidden>
Date: 2016-02-03 03:38:02

Hi Byeoungwook,

[auto build test WARNING on wireless-drivers-next/master]
[also build test WARNING on v4.5-rc2 next-20160202]
[if your patch is applied to the wrong git tree, please drop us a note to help improving the system]

url:    https://github.com/0day-ci/linux/commits/Byeoungwook-Kim/rtlwifi-Fix-improve-function-rtl_addr_delay-in-core-c/20160203-101854
base:   https://git.kernel.org/pub/scm/linux/kernel/git/kvalo/wireless-drivers-next.git master


coccinelle warnings: (new ones prefixed by >>)
quoted
drivers/net/wireless/realtek/rtlwifi/core.c:59:2-3: Unneeded semicolon
Please review and possibly fold the followup patch.

---
0-DAY kernel test infrastructure                Open Source Technology Center
https://lists.01.org/pipermail/kbuild-all                   Intel Corporation

Re: [PATCH] rtlwifi: fix semicolon.cocci warnings

From: Larry Finger <hidden>
Date: 2016-02-03 06:06:54

On 02/02/2016 09:40 PM, kbuild test robot wrote:
drivers/net/wireless/realtek/rtlwifi/core.c:59:2-3: Unneeded semicolon


  Remove unneeded semicolon.

Generated by: scripts/coccinelle/misc/semicolon.cocci

CC: Byeoungwook Kim <redacted>
Signed-off-by: Fengguang Wu <redacted>
---
Acked-by: Larry Finger <redacted>

Thanks,

Larry
quoted hunk
  core.c |    2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
--- a/drivers/net/wireless/realtek/rtlwifi/core.c
+++ b/drivers/net/wireless/realtek/rtlwifi/core.c
@@ -56,7 +56,7 @@ void rtl_addr_delay(u32 addr)
  	case 0xf9:
  		udelay(1);
  		break;
-	};
+	}
  }
  EXPORT_SYMBOL(rtl_addr_delay);
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help