From: SF Markus Elfring <hidden> Date: 2016-01-02 17:50:28
From: Markus Elfring <redacted>
Date: Sat, 2 Jan 2016 18:46:45 +0100
A few update suggestions were taken into account
from static source code analysis.
Markus Elfring (5):
Delete an unnecessary assignment in connect_rings()
Delete an unnecessary goto statement in connect_rings()
Replace a variable initialisation by an assignment in read_xenbus_vif_flags()
Replace a variable initialisation by an assignment in xen_register_watchers()
Delete an unnecessary variable initialisation in xen_register_watchers()
drivers/net/xen-netback/xenbus.c | 17 ++++++++---------
1 file changed, 8 insertions(+), 9 deletions(-)
--
2.6.3
From: SF Markus Elfring <hidden> Date: 2016-01-02 17:54:54
From: Markus Elfring <redacted>
Date: Sat, 2 Jan 2016 17:32:40 +0100
Remove the assignment for a local variable because its value is not
changed compared to the one from a previous function call.
Signed-off-by: Markus Elfring <redacted>
---
drivers/net/xen-netback/xenbus.c | 1 -
1 file changed, 1 deletion(-)
From: SF Markus Elfring <hidden> Date: 2016-01-02 17:55:40
From: Markus Elfring <redacted>
Date: Sat, 2 Jan 2016 17:50:21 +0100
One goto statement referred to a source code position directly behind it.
Thus omit such an unnecessary jump.
Signed-off-by: Markus Elfring <redacted>
---
drivers/net/xen-netback/xenbus.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
From: SF Markus Elfring <hidden> Date: 2016-01-02 17:57:27
From: Markus Elfring <redacted>
Date: Sat, 2 Jan 2016 18:01:57 +0100
Replace an explicit initialisation for one local variable at the beginning
by an assignment.
Signed-off-by: Markus Elfring <redacted>
---
drivers/net/xen-netback/xenbus.c | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
From: SF Markus Elfring <hidden> Date: 2016-01-02 17:58:17
From: Markus Elfring <redacted>
Date: Sat, 2 Jan 2016 18:23:16 +0100
Replace an explicit initialisation for one local variable at the beginning
by an assignment.
Signed-off-by: Markus Elfring <redacted>
---
drivers/net/xen-netback/xenbus.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
From: SF Markus Elfring <hidden> Date: 2016-01-02 18:00:34
From: Markus Elfring <redacted>
Date: Sat, 2 Jan 2016 18:28:26 +0100
Omit explicit initialisation at the beginning for one local variable
that is redefined before its first use.
Signed-off-by: Markus Elfring <redacted>
---
drivers/net/xen-netback/xenbus.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
From: Joe Perches <joe@perches.com> Date: 2016-01-03 01:34:26
On Sat, 2016-01-02 at 18:50 +0100, SF Markus Elfring wrote:
A few update suggestions were taken into account
from static source code analysis.
While static analysis can be useful, I don't think these
specific conversions are generally useful.
Perhaps it would be more useful to convert the string
duplication or snprintf logic to kstrdup/kasprintf
This:
if (num_queues == 1) {
xspath = kzalloc(strlen(dev->otherend) + 1, GFP_KERNEL);
if (!xspath) {
xenbus_dev_fatal(dev, -ENOMEM,
"reading ring references");
return -ENOMEM;
}
strcpy(xspath, dev->otherend);
} else {
xspathsize = strlen(dev->otherend) + xenstore_path_ext_size;
xspath = kzalloc(xspathsize, GFP_KERNEL);
if (!xspath) {
xenbus_dev_fatal(dev, -ENOMEM,
"reading ring references");
return -ENOMEM;
}
snprintf(xspath, xspathsize, "%s/queue-%u", dev->otherend,
queue->id);
}
could be simplified to something like:
if (num_queues == 1)
xspath = kstrdup(dev->otherend, GFP_KERNEL);
else
xspath = kasprintf(GFP_KERNEL, "%s/queue-%u",
dev->otherend, queue->id);
if (!xspath)
etc...