when linux start up, we get the log below:
"Hi-HNS_MDIO 803c0000.mdio: no syscon hisilicon,peri-c-subctrl
mdio_bus mdio@803c0000: mdio sys ctl reg has not maped "
the source code about the subctrl is dealled with syscon, but dts doesn't.
it cause such fault. so this patch adds the syscon info on dts files to
fixes it.
Signed-off-by: yankejian <redacted>
---
arch/arm64/boot/dts/hisilicon/hip05.dtsi | 4 ++++
arch/arm64/boot/dts/hisilicon/hip05_hns.dtsi | 4 ++--
2 files changed, 6 insertions(+), 2 deletions(-)
This patch adds documentation for the devicetree bindings used by the
DT files of Hisilicon Hip05-D02 development board.
Signed-off-by: yankejian <redacted>
---
.../devicetree/bindings/arm/hisilicon/hisilicon.txt | 16 ++++++++++++++++
1 file changed, 16 insertions(+)
Error: arch/arm64/boot/dts/hisilicon/hip05-d02.dts:38.1-6 Label or path eth2 not found
Error: arch/arm64/boot/dts/hisilicon/hip05-d02.dts:42.1-6 Label or path eth3 not found
Error: arch/arm64/boot/dts/hisilicon/hip05-d02.dts:46.1-6 Label or path eth6 not found
Error: arch/arm64/boot/dts/hisilicon/hip05-d02.dts:50.1-6 Label or path eth7 not found
FATAL ERROR: Syntax error parsing input tree
---
0-DAY kernel test infrastructure Open Source Technology Center
https://lists.01.org/pipermail/kbuild-all Intel Corporation
On Saturday 05 December 2015 15:56:58 yankejian wrote:
+Required properties:
+- compatible : "hisilicon,peri-c-subctrl", "syscon";
+- reg : Register address and size
+
+The HiP05 PERISUB system controller is shared by peripheral controllers in
+HiP05 Soc to implement some basic configurations. the peripheral
+ controllers include mdio, ddr, iic, uart, timer and so on.
+
+Example:
+ /* for HiP05 PCIe-SAS system */
+ pcie_sas: system_controller@0xb0000000 {
+ compatible = "hisilicon,pcie-sas-subctrl", "syscon";
+ reg = <0xb0000000 0x10000>;
+ };
The compatible string in the example does not match the required properties.
Arnd
--
To unsubscribe from this list: send the line "unsubscribe devicetree" in
the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
I don't see the subctrl_vbase property documented in the binding. Please
modify the binding as well.
Also, please use the normal naming conventions using '-' instead of '_'
inside of property names.
Arnd
--
To unsubscribe from this list: send the line "unsubscribe devicetree" in
the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
I don't see the subctrl_vbase property documented in the binding. Please
modify the binding as well.
Also, please use the normal naming conventions using '-' instead of '_'
inside of property names.
Arnd
.
Hi, Arnd
Thanks for your suggestions. i will fixes it later.