From: Kamala R <redacted>
The behaviour of blackhole and prohibit routes has been corrected by setting
the input and output function pointers of the dst variable appropriately. For
blackhole routes, they are set to dst_discard and to ip6_pkt_prohibit and
ip6_pkt_prohbit_out respectively for prohibit routes.
Changes from v1: Logic is the same. Changes made for readability and so it
looks pleasing.
Signed-off-by: Kamala R <redacted>
---
net/ipv6/route.c | 11 +++++++----
1 file changed, 7 insertions(+), 4 deletions(-)
From: Hannes Frederic Sowa <hidden> Date: 2013-11-28 18:50:29
On Fri, Nov 22, 2013 at 01:51:28PM +0530, Kamala R wrote:
From: Kamala R <redacted>
The behaviour of blackhole and prohibit routes has been corrected by setting
the input and output function pointers of the dst variable appropriately. For
blackhole routes, they are set to dst_discard and to ip6_pkt_prohibit and
ip6_pkt_prohbit_out respectively for prohibit routes.
Changes from v1: Logic is the same. Changes made for readability and so it
looks pleasing.
David, fyi a third version of this patch has been posted.