[PATCH] rename configure.in to configure.ac

Subsystems: the rest

STALE4913d

2 messages, 2 authors, 2013-03-20 · open the first message on its own page

[PATCH] rename configure.in to configure.ac

From: <hidden>
Date: 2013-03-15 15:29:56

From: Yegor Yefremov <redacted>

Automake 1.14 will likely drop support for the long-deprecated
'configure.in' name for the Autoconf input file.

Signed-off-by: Yegor Yefremov <redacted>
---
 configure.ac |   27 +++++++++++++++++++++++++++
 configure.in |   27 ---------------------------
 2 files changed, 27 insertions(+), 27 deletions(-)
 create mode 100644 configure.ac
 delete mode 100644 configure.in
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..5e3f89b
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,27 @@
+dnl Process this file with autoconf to produce a configure script.
+AC_INIT(bridge-utils, 1.5)
+AC_CONFIG_HEADERS(libbridge/config.h)
+
+AC_ARG_WITH( linux-headers, [  --with-linux-headers     Location of the linux headers to use], 
+    KERNEL_HEADERS=$withval, KERNEL_HEADERS="/usr/src/linux/include")
+
+dnl Checks for programs.
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_RANLIB
+
+dnl Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS(sys/ioctl.h sys/time.h)
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_HEADER_TIME
+
+dnl Checks for library functions.
+AC_CHECK_FUNCS(gethostname socket strdup uname)
+AC_CHECK_FUNCS(if_nametoindex if_indextoname)
+
+AC_SUBST(KERNEL_HEADERS)
+
+AC_OUTPUT(doc/Makefile libbridge/Makefile brctl/Makefile Makefile bridge-utils.spec)
diff --git a/configure.in b/configure.in
deleted file mode 100644
index 5e3f89b..0000000
--- a/configure.in
+++ /dev/null
@@ -1,27 +0,0 @@
-dnl Process this file with autoconf to produce a configure script.
-AC_INIT(bridge-utils, 1.5)
-AC_CONFIG_HEADERS(libbridge/config.h)
-
-AC_ARG_WITH( linux-headers, [  --with-linux-headers     Location of the linux headers to use], 
-    KERNEL_HEADERS=$withval, KERNEL_HEADERS="/usr/src/linux/include")
-
-dnl Checks for programs.
-AC_PROG_CC
-AC_PROG_INSTALL
-AC_PROG_RANLIB
-
-dnl Checks for header files.
-AC_HEADER_STDC
-AC_CHECK_HEADERS(sys/ioctl.h sys/time.h)
-
-dnl Checks for typedefs, structures, and compiler characteristics.
-AC_C_CONST
-AC_HEADER_TIME
-
-dnl Checks for library functions.
-AC_CHECK_FUNCS(gethostname socket strdup uname)
-AC_CHECK_FUNCS(if_nametoindex if_indextoname)
-
-AC_SUBST(KERNEL_HEADERS)
-
-AC_OUTPUT(doc/Makefile libbridge/Makefile brctl/Makefile Makefile bridge-utils.spec)
-- 
1.7.7

Re: [PATCH] rename configure.in to configure.ac

From: Stephen Hemminger <stephen@networkplumber.org>
Date: 2013-03-20 15:29:09

On Fri, 15 Mar 2013 16:05:46 +0100
yegorslists@googlemail.com wrote:
From: Yegor Yefremov <redacted>

Automake 1.14 will likely drop support for the long-deprecated
'configure.in' name for the Autoconf input file.

Signed-off-by: Yegor Yefremov <redacted>
Ok, applied this and cleaned up some other debris in make stuff.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help