Re: [dm-devel] [PATCH v8 01/16] hashtable: introduce a small and naive hashtable
From: George Spelvin <hidden>
Date: 2012-10-31 09:10:25
Also in:
dm-devel, linux-mm, linux-nfs, lkml
From: George Spelvin <hidden>
Date: 2012-10-31 09:10:25
Also in:
dm-devel, linux-mm, linux-nfs, lkml
Tejun Heo wrote:
quoted
+#define hash_min(val, bits) \ +({ \ + sizeof(val) <= 4 ? \ + hash_32(val, bits) : \ + hash_long(val, bits); \ +})
Also, you probably want () around at least @val. In general, it's a good idea to add () around any macro argument to avoid nasty surprises.
Er... not in this case, you don't. If a macro argument is passed verbatim as an argument to a function, it doesn't need additional parens. That's because the one guarantee you have about a macro argument is that it can't contain any (unquoted) commas, and there's nothing lower precedence than the comma. So it's safe to delimit a macro argument with *either* parens *or* a comma. So you can go ahead and write: #define hash_min(val, bits) \ (sizeof(val) <= 4 ? hash_32(val, bits) : hash_long(val, bits)) ... which is easier to read, anyway. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@kvack.org. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>