[PATCH 3.6.0- 3/3] wireless/ath5k: use module_platform_driver macro

DORMANTno replies

From: Srinivas KANDAGATLA <hidden>
Date: 2012-10-10 18:30:50
Subsystem: atheros ath generic utilities, atheros ath5k wireless driver, the rest · Maintainers: Jeff Johnson, Jiri Slaby, Nick Kossifidis, Luis Chamberlain, Linus Torvalds

From: Srinivas Kandagatla <redacted>

This patch removes some code duplication by using
module_platform_driver.

Signed-off-by: Srinivas Kandagatla <redacted>
---
 drivers/net/wireless/ath/ath5k/ahb.c |   16 +---------------
 1 files changed, 1 insertions(+), 15 deletions(-)
diff --git a/drivers/net/wireless/ath/ath5k/ahb.c b/drivers/net/wireless/ath/ath5k/ahb.c
index aec33cc..3f9036f 100644
--- a/drivers/net/wireless/ath/ath5k/ahb.c
+++ b/drivers/net/wireless/ath/ath5k/ahb.c
@@ -235,18 +235,4 @@ static struct platform_driver ath_ahb_driver = {
 		.owner	= THIS_MODULE,
 	},
 };
-
-static int __init
-ath5k_ahb_init(void)
-{
-	return platform_driver_register(&ath_ahb_driver);
-}
-
-static void __exit
-ath5k_ahb_exit(void)
-{
-	platform_driver_unregister(&ath_ahb_driver);
-}
-
-module_init(ath5k_ahb_init);
-module_exit(ath5k_ahb_exit);
+module_platform_driver(ath_ahb_driver);
-- 
1.7.0.4
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help