[PATCH 11/14] usb/net: rndis: move and namespace PnP defines
From: Linus Walleij <hidden>
Date: 2012-04-08 08:48:31
Subsystem:
the rest · Maintainer:
Linus Torvalds
This moves the PnP OID definitions to the RNDIS_* namespace and puts them in the next falling slot in the list. Oh, the comment above the PnP defines was referring to some obsolete or out-of-tree driver so removed it, and removed my own comments telling where each header segment came from as well, we have moved everything around by this point anyway. Signed-off-by: Linus Walleij <redacted> --- include/linux/rndis.h | 27 ++++++++++++--------------- 1 files changed, 12 insertions(+), 15 deletions(-)
diff --git a/include/linux/rndis.h b/include/linux/rndis.h
index 90ec269..09449c4 100644
--- a/include/linux/rndis.h
+++ b/include/linux/rndis.h@@ -1,4 +1,7 @@ -/* From include/linux/usb/rndis_host.h */ +/* + * Remote Network Driver Interface Specification (RNDIS) + * definitions of the magic numbers used by this protocol + */ #define RNDIS_MSG_COMPLETION 0x80000000
@@ -136,8 +139,6 @@ #define RNDIS_PACKET_TYPE_FUNCTIONAL 0x00004000 #define RNDIS_PACKET_TYPE_MAC_FRAME 0x00008000 -/* From drivers/usb/gadget/ndis.h */ - /* NDIS_PNP_CAPABILITIES.Flags constants */ #define NDIS_DEVICE_WAKE_UP_ENABLE 0x00000001 #define NDIS_DEVICE_WAKE_ON_PATTERN_MATCH_ENABLE 0x00000002
@@ -182,8 +183,6 @@ #define NDIS_MAC_OPTION_8021P_PRIORITY 0x00000040 #define NDIS_MAC_OPTION_RESERVED 0x80000000 -/* From drivers/usb/gadget/rndis.h */ - /* Remote NDIS Versions */ #define RNDIS_MAJOR_VERSION 0x00000001 #define RNDIS_MINOR_VERSION 0x00000000
@@ -210,16 +209,6 @@ #define RNDIS_DF_CONNECTION_ORIENTED 0x00000002U #define RNDIS_DF_RAW_DATA 0x00000004U -/* from drivers/net/sk98lin/h/skgepnmi.h */ -#define OID_PNP_CAPABILITIES 0xFD010100 -#define OID_PNP_SET_POWER 0xFD010101 -#define OID_PNP_QUERY_POWER 0xFD010102 -#define OID_PNP_ADD_WAKE_UP_PATTERN 0xFD010103 -#define OID_PNP_REMOVE_WAKE_UP_PATTERN 0xFD010104 -#define OID_PNP_ENABLE_WAKE_UP 0xFD010106 - -/* From drivers/net/hyperv/hyperv_net.h */