[PATCH RESEND] FEC: Rename dev to ndev, fix compile error

Subsystems: networking drivers, the rest

STALE5300d

3 messages, 2 authors, 2012-02-07 · open the first message on its own page

[PATCH RESEND] FEC: Rename dev to ndev, fix compile error

From: Marek Vasut <hidden>
Date: 2012-02-07 22:44:03

The following commit introduced a typo, this commit fixes it.

commit 21a4e46995fa1a76281ac0281ff837f706231a37
Author: Pradeep A Dalvi [off-list ref]
Date:   Sun Feb 5 02:50:10 2012 +0000

    netdev: ethernet dev_alloc_skb to netdev_alloc_skb

    Replaced deprecating dev_alloc_skb with netdev_alloc_skb in drivers/net/ethernet
      - Removed extra skb->dev = dev after netdev_alloc_skb

Signed-off-by: Marek Vasut <redacted>
Cc: Pradeep A Dalvi <redacted>
Cc: David S. Miller <davem@davemloft.net>
---
 drivers/net/ethernet/freescale/fec.c |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

RESEND: Typo in list address
diff --git a/drivers/net/ethernet/freescale/fec.c b/drivers/net/ethernet/freescale/fec.c
index f976619..0ee2ca7 100644
--- a/drivers/net/ethernet/freescale/fec.c
+++ b/drivers/net/ethernet/freescale/fec.c
@@ -711,7 +711,7 @@ fec_enet_rx(struct net_device *ndev)
 		 * include that when passing upstream as it messes up
 		 * bridging applications.
 		 */
-		skb = netdev_alloc_skb(dev, pkt_len - 4 + NET_IP_ALIGN);
+		skb = netdev_alloc_skb(ndev, pkt_len - 4 + NET_IP_ALIGN);
 
 		if (unlikely(!skb)) {
 			printk("%s: Memory squeeze, dropping packet.\n",
@@ -1210,7 +1210,7 @@ static int fec_enet_alloc_buffers(struct net_device *ndev)
 
 	bdp = fep->rx_bd_base;
 	for (i = 0; i < RX_RING_SIZE; i++) {
-		skb = netdev_alloc_skb(dev, FEC_ENET_RX_FRSIZE);
+		skb = netdev_alloc_skb(ndev, FEC_ENET_RX_FRSIZE);
 		if (!skb) {
 			fec_enet_free_buffers(ndev);
 			return -ENOMEM;
-- 
1.7.8.3

[PATCH RESEND] FEC: Rename dev to ndev, fix compile error

From: festevam@gmail.com (Fabio Estevam)
Date: 2012-02-07 23:31:56

Hi Marek,

On Tue, Feb 7, 2012 at 8:44 PM, Marek Vasut [off-list ref] wrote:
The following commit introduced a typo, this commit fixes it.

commit 21a4e46995fa1a76281ac0281ff837f706231a37
Author: Pradeep A Dalvi [off-list ref]
Date:   Sun Feb 5 02:50:10 2012 +0000

   netdev: ethernet dev_alloc_skb to netdev_alloc_skb

   Replaced deprecating dev_alloc_skb with netdev_alloc_skb in drivers/net/ethernet
     - Removed extra skb->dev = dev after netdev_alloc_skb

Signed-off-by: Marek Vasut <redacted>
Cc: Pradeep A Dalvi <redacted>
Cc: David S. Miller <davem@davemloft.net>
I have already sent a fix for this issue and David has applied it.

Regards,

Fabio Estevam

[PATCH RESEND] FEC: Rename dev to ndev, fix compile error

From: Marek Vasut <hidden>
Date: 2012-02-07 23:37:37

Hi Marek,

On Tue, Feb 7, 2012 at 8:44 PM, Marek Vasut [off-list ref] wrote:
quoted
The following commit introduced a typo, this commit fixes it.

commit 21a4e46995fa1a76281ac0281ff837f706231a37
Author: Pradeep A Dalvi [off-list ref]
Date:   Sun Feb 5 02:50:10 2012 +0000

   netdev: ethernet dev_alloc_skb to netdev_alloc_skb

   Replaced deprecating dev_alloc_skb with netdev_alloc_skb in
drivers/net/ethernet - Removed extra skb->dev = dev after
netdev_alloc_skb

Signed-off-by: Marek Vasut <redacted>
Cc: Pradeep A Dalvi <redacted>
Cc: David S. Miller <davem@davemloft.net>
I have already sent a fix for this issue and David has applied it.

Regards,

Fabio Estevam
It wasn't in next ... all right, drop this patch.

M
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help