[PATCH] FEC: Rename dev to ndev, fix compile error

Subsystems: networking drivers, the rest

STALE5307d

3 messages, 2 authors, 2012-02-08 · open the first message on its own page

[PATCH] FEC: Rename dev to ndev, fix compile error

From: Marek Vasut <hidden>
Date: 2012-02-07 22:42:38

The following commit introduced a typo, this commit fixes it.

commit 21a4e46995fa1a76281ac0281ff837f706231a37
Author: Pradeep A Dalvi [off-list ref]
Date:   Sun Feb 5 02:50:10 2012 +0000

    netdev: ethernet dev_alloc_skb to netdev_alloc_skb

    Replaced deprecating dev_alloc_skb with netdev_alloc_skb in drivers/net/ethernet
      - Removed extra skb->dev = dev after netdev_alloc_skb

Signed-off-by: Marek Vasut <redacted>
Cc: Pradeep A Dalvi <redacted>
Cc: David S. Miller <davem@davemloft.net>
---
 drivers/net/ethernet/freescale/fec.c |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/net/ethernet/freescale/fec.c b/drivers/net/ethernet/freescale/fec.c
index f976619..0ee2ca7 100644
--- a/drivers/net/ethernet/freescale/fec.c
+++ b/drivers/net/ethernet/freescale/fec.c
@@ -711,7 +711,7 @@ fec_enet_rx(struct net_device *ndev)
 		 * include that when passing upstream as it messes up
 		 * bridging applications.
 		 */
-		skb = netdev_alloc_skb(dev, pkt_len - 4 + NET_IP_ALIGN);
+		skb = netdev_alloc_skb(ndev, pkt_len - 4 + NET_IP_ALIGN);
 
 		if (unlikely(!skb)) {
 			printk("%s: Memory squeeze, dropping packet.\n",
@@ -1210,7 +1210,7 @@ static int fec_enet_alloc_buffers(struct net_device *ndev)
 
 	bdp = fep->rx_bd_base;
 	for (i = 0; i < RX_RING_SIZE; i++) {
-		skb = netdev_alloc_skb(dev, FEC_ENET_RX_FRSIZE);
+		skb = netdev_alloc_skb(ndev, FEC_ENET_RX_FRSIZE);
 		if (!skb) {
 			fec_enet_free_buffers(ndev);
 			return -ENOMEM;
-- 
1.7.8.3

Re: [PATCH] FEC: Rename dev to ndev, fix compile error

From: David Miller <davem@davemloft.net>
Date: 2012-02-08 00:04:37

From: Marek Vasut <redacted>
Date: Tue,  7 Feb 2012 23:42:28 +0100
The following commit introduced a typo, this commit fixes it.

commit 21a4e46995fa1a76281ac0281ff837f706231a37
Author: Pradeep A Dalvi [off-list ref]
Date:   Sun Feb 5 02:50:10 2012 +0000

    netdev: ethernet dev_alloc_skb to netdev_alloc_skb

    Replaced deprecating dev_alloc_skb with netdev_alloc_skb in drivers/net/ethernet
      - Removed extra skb->dev = dev after netdev_alloc_skb

Signed-off-by: Marek Vasut <redacted>
This is already fixed in the net-next tree.

Re: [PATCH] FEC: Rename dev to ndev, fix compile error

From: Marek Vasut <hidden>
Date: 2012-02-08 00:09:27

From: Marek Vasut <redacted>
Date: Tue,  7 Feb 2012 23:42:28 +0100
quoted
The following commit introduced a typo, this commit fixes it.

commit 21a4e46995fa1a76281ac0281ff837f706231a37
Author: Pradeep A Dalvi [off-list ref]
Date:   Sun Feb 5 02:50:10 2012 +0000

    netdev: ethernet dev_alloc_skb to netdev_alloc_skb
    
    Replaced deprecating dev_alloc_skb with netdev_alloc_skb in
    drivers/net/ethernet
    
      - Removed extra skb->dev = dev after netdev_alloc_skb

Signed-off-by: Marek Vasut <redacted>
This is already fixed in the net-next tree.
Right, it wasn't in -next so I sent it. Thanks

M
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help