From: David Miller <davem@davemloft.net> Date: 2011-08-09 15:51:13
From: stufever@gmail.com
Date: Tue, 9 Aug 2011 23:45:11 +0800
From: Wang Shaoyan <redacted>
drivers/net/gianfar_ethtool.c:765: warning: the frame size of 2048 bytes is larger than 1024 bytes
Signed-off-by: Wang Shaoyan <redacted>
Would you be so kind as to actually acknowledge in some way the person
who found all the bugs in your first version of this patch? :-/
From: Wang Shaoyan <hidden> Date: 2011-08-09 16:06:06
Thanks for remainding, I just want to cover up my careless asap:-)
2011/8/9 David Miller [off-list ref]:
From: stufever@gmail.com
Date: Tue, 9 Aug 2011 23:45:11 +0800
quoted
From: Wang Shaoyan <redacted>
drivers/net/gianfar_ethtool.c:765: warning: the frame size of 2048 bytes is larger than 1024 bytes
Signed-off-by: Wang Shaoyan <redacted>
Would you be so kind as to actually acknowledge in some way the person
who found all the bugs in your first version of this patch? :-/
@@ -686,10 +686,26 @@ static int gfar_ethflow_to_filer_table(struct gfar_private *priv, u64 ethflow, u { unsigned int last_rule_idx = priv->cur_filer_idx; unsigned int cmp_rqfpr;- unsigned int local_rqfpr[MAX_FILER_IDX + 1];- unsigned int local_rqfcr[MAX_FILER_IDX + 1];+ unsigned int *local_rqfpr;+ unsigned int *local_rqfcr; int i = 0x0, k = 0x0; int j = MAX_FILER_IDX, l = 0x0;+ int ret = 1;++ local_rqfpr = kmalloc(sizeof(unsigned int) * (MAX_FILER_IDX + 1),+ GFP_KERNEL);+ if (!local_rqfpr) {+ pr_err("Out of memory\n");+ ret = 0;+ got err;+ }+ local_rqfcr = kmalloc(sizeof(unsigned int) * (MAX_FILER_IDX + 1),+ GFP_KERNEL);+ if (!local_rqfcr) {+ pr_err("Out of memory\n");+ ret = 0;+ goto err1;+ }
Perhaps it'd be clearer to use:
local_rqfpr = kmalloc(...)
local_rqfcr = kmalloc(...)
if (!local_rqfpr || !local_rqfcr) {
pr_err(...)
ret = -ENOMEM;
goto err;
}
[...]
err:
kfree(local_rqfpr);
kfree(local_rqfcr);
return ret;
Is the "local_" prefix useful?
It seems like visual noise to me.
From: Wang Shaoyan <hidden> Date: 2011-08-09 16:37:56
I thought kfree should not call, when kmalloc is failed. Now I think
is fine, thanks, it is much clearer
Perhaps it'd be clearer to use:
local_rqfpr = kmalloc(...)
local_rqfcr = kmalloc(...)
if (!local_rqfpr || !local_rqfcr) {
pr_err(...)
ret = -ENOMEM;
goto err;
}
[...]
err:
kfree(local_rqfpr);
kfree(local_rqfcr);
return ret;
Is the "local_" prefix useful?
It seems like visual noise to me.
They are some temporary variable, we better to left them