Oh, it seems it has indeed been that way for a very long time, so I was
mistaken. It still seems a little odd to me. Ulrich can say definitively
whether the kind of concern I mentioned really matters one way or the other
for glibc.
Thanks,
Roland
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
Roland McGrath wrote:
Oh, it seems it has indeed been that way for a very long time, so I was
mistaken. It still seems a little odd to me. Ulrich can say definitively
whether the kind of concern I mentioned really matters one way or the other
for glibc.
glibc cannot survive (at least NPTL) if somebody uses funny CLONE_*
flags to separate various pieces of information, e.g., file descriptors.
So, all the information in each thread's /proc/self should be identical.
When the information is not the same, the current semantics seems to be
more useful. So I guess, no change is the way to go here.
- --
➧ Ulrich Drepper ➧ Red Hat, Inc. ➧ 444 Castro St ➧ Mountain View, CA ❖
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org
iD8DBQFHQ25/2ijCOnn/RHQRAmhhAJsHRF7FqO8DWwZ97gHxIO/i4Z1AAQCffCGa
Q2J8kjthKbbNQf1USWMAw3Y=
=xl/a
-----END PGP SIGNATURE-----
* Ulrich Drepper [off-list ref] wrote:
quoted
Oh, it seems it has indeed been that way for a very long time, so I
was mistaken. It still seems a little odd to me. Ulrich can say
definitively whether the kind of concern I mentioned really matters
one way or the other for glibc.
glibc cannot survive (at least NPTL) if somebody uses funny CLONE_*
flags to separate various pieces of information, e.g., file
descriptors.
So, all the information in each thread's /proc/self should be
identical.
When the information is not the same, the current semantics seems to
be more useful. So I guess, no change is the way to go here.
can you see any danger to providing a /proc/self_task/ link? (or can you
think of a better name/API/approach)
Ingo