# \[PATCH 7/10\] ps3: use ethX as the name of irq

- From: Masakazu Mokuno \<hidden\>
- Date: 2007-07-20 08:33:04 
- List: netdev
- Page: https://ratatoskr.run/netdev/2007/07/10780948

```text
Use net_device name for registration of irq as many network drivers do.

Signed-off-by: Masakazu Mokuno <redacted>
---
 drivers/net/ps3_gelic_net.c |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

--- a/drivers/net/ps3_gelic_net.c
+++ b/drivers/net/ps3_gelic_net.c
@@ -1073,7 +1073,7 @@ static int gelic_net_open_device(struct 
 	}
 
 	result = request_irq(card->netdev->irq, gelic_net_interrupt,
-			     IRQF_DISABLED, "gelic network", card->netdev);
+			     IRQF_DISABLED, card->netdev->name, card->netdev);
 
 	if (result) {
 		dev_info(ctodev(card), "%s:%d: request_irq failed (%d)\n",

--
Masakazu MOKUNO

```
