Hi Dave,
I am splitting this patch to two, to differentiate between readability
changes (plus a bug fix) and optimization changes.
Please review.
Thanks,
- KK
----------------------------------------------------------------------
I am sorry to miss out during Jamal's original effort to make qdisc_restart
more readable, but I feel some more minor changes could help in that effort.
Plus there were some useful comments in the original code which I updated
(hopefully correctly) and put back - it does seem useful for a new reader.
Ran a 50 process netperf4 TCP & UDP on 2 cpu SMP system without issues.
Please provide your comments/feedback (cc'ing the original reviewers also,
as per Jamal's mail from May 25th).
Thanks,
- KK