[git patch] since the definition of dst_discard_in and dst_discard_out are the same,,they should merged into one

Subsystems: networking [general], the rest

STALE7041d

3 messages, 2 authors, 2007-05-31 · open the first message on its own page

[git patch] since the definition of dst_discard_in and dst_discard_out are the same,,they should merged into one

From: Rankle_ <hidden>
Date: 2007-05-31 07:27:18

 From 30d6996860f7e5589d1bce10404bbcfd6592c9de Mon Sep 17 00:00:00 2001
From: Denis Cheng <redacted>
Date: Thu, 31 May 2007 15:21:58 +0800
Subject: [PATCH] since the definition of dst_discard_in and 
dst_discard_out are the same,
they should merged into one

Signed-off-by: Denis Cheng <redacted>
diff --git a/net/core/dst.c b/net/core/dst.c
index 764bccb..c6a0587 100644
--- a/net/core/dst.c
+++ b/net/core/dst.c
@@ -111,13 +111,7 @@ out:
     spin_unlock(&dst_lock);
 }
 
-static int dst_discard_in(struct sk_buff *skb)
-{
-    kfree_skb(skb);
-    return 0;
-}
-
-static int dst_discard_out(struct sk_buff *skb)
+static int dst_discard(struct sk_buff *skb)
 {
     kfree_skb(skb);
     return 0;
@@ -138,8 +132,7 @@ void * dst_alloc(struct dst_ops * ops)
     dst->ops = ops;
     dst->lastuse = jiffies;
     dst->path = dst;
-    dst->input = dst_discard_in;
-    dst->output = dst_discard_out;
+    dst->input = dst->output = dst_discard;
 #if RT_CACHE_DEBUG >= 2
     atomic_inc(&dst_total);
 #endif
@@ -153,8 +146,7 @@ static void ___dst_free(struct dst_entry * dst)
        protocol module is unloaded.
      */
     if (dst->dev == NULL || !(dst->dev->flags&IFF_UP)) {
-        dst->input = dst_discard_in;
-        dst->output = dst_discard_out;
+        dst->input = dst->output = dst_discard;
     }
     dst->obsolete = 2;
 }
@@ -242,8 +234,7 @@ static inline void dst_ifdown(struct dst_entry *dst, 
struct net_device *dev,
         return;
 
     if (!unregister) {
-        dst->input = dst_discard_in;
-        dst->output = dst_discard_out;
+        dst->input = dst->output = dst_discard;
     } else {
         dst->dev = &loopback_dev;
         dev_hold(&loopback_dev);

Re: [git patch] since the definition of dst_discard_in and dst_discard_out are the same,,they should merged into one

From: David Miller <davem@davemloft.net>
Date: 2007-05-31 08:37:23

From: Rankle_ <redacted>
Date: Thu, 31 May 2007 15:26:54 +0800
 From 30d6996860f7e5589d1bce10404bbcfd6592c9de Mon Sep 17 00:00:00 2001
From: Denis Cheng <redacted>
Date: Thu, 31 May 2007 15:21:58 +0800
Subject: [PATCH] since the definition of dst_discard_in and 
dst_discard_out are the same,
they should merged into one

Signed-off-by: Denis Cheng <redacted>
Your email client has changed all of the tab characters into spaces,
corrupting the patch.

Please configure your email client to not perform any text formatting.

Please test this, by emailing the patch to yourself and trying to
apply it, before resending.

Thank you.

Re: [git patch] since the definition of dst_discard_in and dst_discard_out are the same,,they should merged into one

From: rae l <hidden>
Date: 2007-05-31 09:27:19

On 5/31/07, David Miller [off-list ref] wrote:
Your email client has changed all of the tab characters into spaces,
corrupting the patch.

Please configure your email client to not perform any text formatting.

Please test this, by emailing the patch to yourself and trying to
apply it, before resending.

Thank you.
Oh, as this, I'll try. A lot of thanks.

-- 
Denis Cheng
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help