Minor nits.
On Tue, 17 Jan 2006 15:24:37 -0800
"Sean Hefty" [off-list ref] wrote:
The following patch extends matching connection requests to listens in the
Infiniband CM to include private data.
Signed-off-by: Sean Hefty <redacted>
---
+static void cm_mask_compare_data(u8 *dst, u8 *src, u8 *mask)
static void cm_mask_compare_data(u8 *dst, const u8 *src, u8 *mask)
but I would rename it to cm_mask_copy since it doesn't really do a compare.
+{
+ int i;
+
+ for (i = 0; i < IB_CM_PRIVATE_DATA_COMPARE_SIZE; i++)
+ dst[i] = src[i] & mask[i];
+}
+
+static int cm_compare_data(struct ib_cm_private_data_compare *src_data,
+ struct ib_cm_private_data_compare *dst_data)
static int cm_compare_data(const struct ib_cm_private_data_compare *src,
cosnt struct ib_cm_private_data_compare *dst)
Your data type names are getting too long ^^^^^^^^^^^^^^^^^^^^^^^^
<flamebait>
Also should infiniband exports be EXPORT_SYMBOL_GPL, to make
it clear that binary drivers for this are not allowed??
</flamebait>
--
Stephen Hemminger [off-list ref]
OSDL http://developer.osdl.org/~shemminger
quoted
+static void cm_mask_compare_data(u8 *dst, u8 *src, u8 *mask)
static void cm_mask_compare_data(u8 *dst, const u8 *src, u8 *mask)
but I would rename it to cm_mask_copy since it doesn't really do a compare.
I'll change this. The function is masking the "data to use in the comparison",
but I can see the confusion.
quoted
+static int cm_compare_data(struct ib_cm_private_data_compare *src_data,
+ struct ib_cm_private_data_compare *dst_data)
static int cm_compare_data(const struct ib_cm_private_data_compare *src,
cosnt struct ib_cm_private_data_compare *dst)
Your data type names are getting too long ^^^^^^^^^^^^^^^^^^^^^^^^
I'll fix.
Thanks for the comments.
- Sean
<flamebait>
Also should infiniband exports be EXPORT_SYMBOL_GPL, to make
it clear that binary drivers for this are not allowed??
</flamebait>
the dual license text needs a bit of clarification I suspect to make
explicit that the "or BSD" part only applies when used entirely outside
the linux kernel. (that already is the case, just it's not explicit.
Making that explicit would be good).
On Wed, 2006-01-18 at 08:08 +0100, Arjan van de Ven wrote:
the dual license text needs a bit of clarification I suspect to make
explicit that the "or BSD" part only applies when used entirely outside
the linux kernel. (that already is the case, just it's not explicit.
Making that explicit would be good).
One appropriate way to do that would be to mark all IB-related exported
symbols as EXPORT_SYMBOL_GPL.
<b