[PATCH][2.5] net/core/dev.c readability cleanups

STALE8894d

5 messages, 2 authors, 2002-06-11 · open the first message on its own page

[PATCH][2.5] net/core/dev.c readability cleanups

From: Thomas 'Dent' Mirlacher <hidden>
Date: 2002-06-09 16:16:18

hi,

the following patch does:
	o improve readability (by adding _deliver_to_proto, which encapsulates
		the call for deliver_to_old ones)
	o clean up types for cpu (cpu should be unsigned int)
	o nicer use of smp_processor_id() (just call it once, at the beginning
		of a function)
	o add functions (_queue_unthrottle, _queue_throttle)
	o changes the "optimized" version of netif_rx back to the
		"nomalized" version. (the "normalized" is readable at the
		first glimpse, plus gcc3 (didn't check it with 2.9*), 
		produces the optimized output anyways)	

please apply,

	tm

-- 
in some way i do, and in some way i don't.

Re: [PATCH][2.5] net/core/dev.c readability cleanups

From: David S. Miller <hidden>
Date: 2002-06-11 12:25:39

I don't find this more readable at all.  SUPPORT_2_2 is simply crap,
it isn't 2.2.x anything, it simply means protocols that aren't %100
SMP safe.  Also "uint" doesn't belong in here and doesn't increase
readability at all.

Talk to Arnaldo de Melo if you want to do janitorial work in this
area, when he sends me cleanups I don't barf.

Re: [PATCH][2.5] net/core/dev.c readability cleanups

From: Thomas 'Dent' Mirlacher <hidden>
Date: 2002-06-11 12:38:23

On Tue, 11 Jun 2002, David S. Miller wrote:
I don't find this more readable at all. 
the special case for deliver_to_old_ones was cluttering the core, imho
abstracting it by deliver_to proto improves readability of netif_receive_skb
significantly.
SUPPORT_2_2 is simply crap,
it isn't 2.2.x anything, it simply means protocols that aren't %100
SMP safe.
ok, but nevertheless, they should be cleaned up within the 2.5 timeframe.
they are not only not 100% SMP safe, they also don't know what to do with
skb fragments.
Also "uint" doesn't belong in here and doesn't increase readability at all.
good. so it should be "unsigned int"
Talk to Arnaldo de Melo if you want to do janitorial work in this
area, when he sends me cleanups I don't barf.
sure,
i don't take this as barfing, just like some "honest" opinion.


	tm

-- 
in some way i do, and in some way i don't.

Re: [PATCH][2.5] net/core/dev.c readability cleanups

From: David S. Miller <hidden>
Date: 2002-06-11 13:54:50

   From: "Thomas 'Dent' Mirlacher" [off-list ref]
   Date: Tue, 11 Jun 2002 14:38:23 +0200 (MET DST)

   i don't take this as barfing, just like some "honest" opinion.

Your patch made me barf, that is my opinion.  Whether you want to take
it or not, that is my honest opinion.  To claim that I was dishonest
is absurd, how can you know what is inside of my mind?

Re: [PATCH][2.5] net/core/dev.c readability cleanups

From: Thomas 'Dent' Mirlacher <hidden>
Date: 2002-06-11 16:09:55

dave,
   i don't take this as barfing, just like some "honest" opinion.

Your patch made me barf, that is my opinion.  Whether you want to take
it or not, that is my honest opinion.  To claim that I was dishonest
is absurd, how can you know what is inside of my mind?
i'm sorry about the lines i've written above, i didn't mean to upset
you at all (is was a lack of finding the right word, and using quotes
is obviously a bad choice for expressing that)

i fully respect your opinion as a person and as the maintainer who's
responsible to keep the code clean

what i really wanted to express was: i don't take your barfing as an
offense, but rather as your opinion and a valueable input on how a patch
should look like (but instead i offended you, which was not intended at all)

hope i clarified the misunderstanding (/misphrasing), 

	tm

-- 
in some way i do, and in some way i don't.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help