sparse checker · Maintained
Maintainers
- M Chris Li <sparse@chrisli.org>
Paths
- F
include/linux/compiler.h
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on llvm (capped at 30), ordered by date desc.
-
STALE109d
[PATCH] compiler: Simplify generic RELOC_HIDE()
2026-03-19 · Marco Elver <elver@google.com> -
STALE142d
Re: [PATCH v3 2/3] arm64: Optimize __READ_ONCE() with CONFIG_LTO=y
2026-02-02 · Peter Zijlstra <peterz@infradead.org> -
STALE165d
[PATCH v5 26/36] compiler: Let data_race() imply disabled context analysis
2025-12-19 · Marco Elver <elver@google.com> -
STALE138d
REVIEWED: 16 (13M) [RFC PATCH v4 1/4] compiler.h: Introduce ptr_eq() to preserve address dependency
2025-12-18 · Mathieu Desnoyers <mathieu.desnoyers@efficios.com> -
STALE204d
[PATCH v4 25/35] compiler: Let data_race() imply disabled context analysis
2025-11-20 · Marco Elver <elver@google.com> -
STALE277d
Re: [PATCH v2 09/12] x86/msr: Use the alternatives mechanism for WRMSR
2025-09-30 · Peter Zijlstra <peterz@infradead.org> -
STALE239d
[PATCH v3 25/35] compiler: Let data_race() imply disabled capability analysis
2025-09-18 · Marco Elver <elver@google.com> -
STALE309d
REVIEWED: 1 (0M) [PATCH v2 8/9] kcfi: Rename CONFIG_CFI_CLANG to CONFIG_CFI
2025-09-04 · Kees Cook <kees@kernel.org> -
STALE271d
[PATCH 5/5] kcfi: Rename CONFIG_CFI_CLANG to CONFIG_CFI
2025-08-25 · Kees Cook <kees@kernel.org> -
DORMANTno replies
Re: [PATCH] kunit/fortify: Add back "volatile" for sizeof() constants
2025-07-02 · Nathan Chancellor <nathan@kernel.org> -
STALE339d
[PATCH v2 25/34] compiler: Let data_race() imply disabled capability analysis
2025-03-04 · Marco Elver <elver@google.com> -
STALE512d
Re: [PATCH] compiler.h: Specify correct attribute for .rodata..c_jump_table
2025-02-14 · Tiezhu Yang <yangtiezhu@loongson.cn> -
STALE520d
[PATCH v2 2/3] compiler.h: Introduce __must_be_byte_array()
2025-02-06 · Kees Cook <kees@kernel.org> -
STALE520d
REVIEWED: 6 (6M) [PATCH v2 1/3] compiler.h: Move C string helpers into C-only kernel section
2025-02-06 · Kees Cook <kees@kernel.org> -
STALE519d
[PATCH 2/3] compiler.h: Introduce __must_be_char_array()
2025-02-06 · Kees Cook <kees@kernel.org> -
STALE519d
[PATCH 1/3] compiler.h: Move C string helpers into C-only kernel section
2025-02-06 · Kees Cook <kees@kernel.org> -
STALE579d
[PATCH 10/10] compiler.h: remove __is_constexpr()
2024-12-02 · Vincent Mailhol via B4 Relay <devnull+mailhol.vincent.wanadoo.fr@kernel.org> -
STALE579d
[PATCH 01/10] compiler.h: add statically_false()
2024-12-02 · Vincent Mailhol via B4 Relay <devnull+mailhol.vincent.wanadoo.fr@kernel.org> -
STALE579d
[PATCH 03/10] compiler.h: add is_const_true() and is_const_false()
2024-12-02 · Vincent Mailhol via B4 Relay <devnull+mailhol.vincent.wanadoo.fr@kernel.org> -
STALE579d
[PATCH 02/10] compiler.h: add is_const() as a replacement of __is_constexpr()
2024-12-02 · Vincent Mailhol via B4 Relay <devnull+mailhol.vincent.wanadoo.fr@kernel.org> -
STALE634d
REVIEWED: 16 (13M) [RFC PATCH v3 1/4] compiler.h: Introduce ptr_eq() to preserve address dependency
2024-10-08 · Mathieu Desnoyers <mathieu.desnoyers@efficios.com> -
STALE642d
REVIEWED: 16 (13M) [RFC PATCH v2 1/4] compiler.h: Introduce ptr_eq() to preserve address dependency
2024-10-04 · Mathieu Desnoyers <mathieu.desnoyers@efficios.com> -
STALE642d
REVIEWED: 14 (13M) [RFC PATCH 1/4] compiler.h: Introduce ptr_eq() to preserve address dependency
2024-10-02 · Mathieu Desnoyers <mathieu.desnoyers@efficios.com> -
STALE650d
REVIEWED: 9 (8M) [PATCH v1 1/2] compiler.h: Introduce ptr_eq() to preserve address dependency
2024-09-29 · Mathieu Desnoyers <mathieu.desnoyers@efficios.com> -
STALE569d
[RFC PATCH 22/28] asm-generic: Treat PIC .data.rel.ro sections as .rodata
2024-09-25 · Ard Biesheuvel <hidden> -
STALE688d
LANDED [PATCH] string: Check for "nonstring" attribute on strscpy() arguments
2024-08-05 · Kees Cook <kees@kernel.org> -
DORMANTno replies
[PATCH] compiler.h: unify __UNIQUE_ID
2023-08-31 · Nick Desaulniers <ndesaulniers@google.com> -
STALE1093d
[PATCH v4 18/21] compiler.h: RFC - s/__LINE__/__COUNTER__/ in __UNIQUE_ID fallback
2023-07-13 · Jim Cromie <jim.cromie@gmail.com> -
STALE1347d
LANDED [PATCH v5] overflow: Introduce overflows_type() and castable_to_type()
2022-10-24 · Gwan-gyeong Mun <hidden> -
STALE1347d
[PATCH v4] overflow: Introduce overflows_type() and castable_to_type()
2022-10-21 · Gwan-gyeong Mun <hidden>