Reviews by ryabinin.a.a@gmail.com
· lkml
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the lkml archive.
81 attestations . (8 Acked-by, 1 Reported-by, 57 Reviewed-by, 15 Suggested-by)
-
COLD20d
REVIEWED: 4 (2M) [PATCH v3 4/8] riscv: remove unreachable invalid range check in kasan_init()
2026-06-30 · Reviewed-by -
COLD20d
REVIEWED: 2 (2M) [PATCH v3 1/8] arm64: mm: remove unreachable invalid range check in kasan_init_shadow()
2026-06-30 · Reviewed-by -
COLD20d
REVIEWED: 2 (2M) [PATCH v3 2/8] LoongArch: remove unreachable invalid range check in kasan_init()
2026-06-30 · Reviewed-by -
COLD21d
REVIEWED: 4 (2M) [PATCH v2 4/8] riscv: remove unreachable invalid range check in kasan_init()
2026-06-29 · Reviewed-by -
COLD21d
REVIEWED: 2 (2M) [PATCH v2 1/8] arm64: mm: remove unreachable invalid range check in kasan_init_shadow()
2026-06-29 · Reviewed-by -
COLD21d
REVIEWED: 2 (2M) [PATCH v2 2/8] LoongArch: remove unreachable invalid range check in kasan_init()
2026-06-29 · Reviewed-by -
COLD56d
REVIEWED: 6 (6M) [PATCH v12 09/15] x86/kasan: Initialize KASAN raw shadow memory
2026-03-30 · Reviewed-by -
COLD56d
REVIEWED: 2 (2M) [PATCH v12 04/15] x86/kasan: Add arch specific kasan functions
2026-03-30 · Reviewed-by -
COLD56d
REVIEWED: 10 (10M) [PATCH v12 03/15] kasan: Fix inline mode for x86 tag-based mode
2026-03-30 · Reviewed-by -
COLD56d
REVIEWED: 6 (6M) [PATCH v12 02/15] kasan: arm64: x86: Make special tags arch specific
2026-03-30 · Reviewed-by -
DORMANTno replies
REVIEWED: 2 (2M) Re: [PATCH v2] kasan: update outdated comment
2026-03-12 · Reviewed-by -
STALE131d
[PATCH v2] kasan: update outdated comment
2026-03-12 · Suggested-by -
STALE132d
REVIEWED: 6 (6M) [PATCH v11 09/15] x86/kasan: Initialize KASAN raw shadow memory
2026-03-10 · Reviewed-by -
STALE132d
REVIEWED: 2 (2M) [PATCH v11 04/15] x86/kasan: Add arch specific kasan functions
2026-03-10 · Reviewed-by -
STALE132d
REVIEWED: 10 (10M) [PATCH v11 03/15] kasan: Fix inline mode for x86 tag-based mode
2026-03-10 · Reviewed-by -
STALE132d
REVIEWED: 6 (6M) [PATCH v11 02/15] kasan: arm64: x86: Make special tags arch specific
2026-03-10 · Reviewed-by -
DORMANTno replies
REVIEWED: 2 (2M) Re: [PATCH] ubsan: turn off kmsan inside of ubsan instrumentation
2026-03-06 · Acked-by -
STALE133d
[PATCH 6.19 739/844] mm/slab: use unsigned long for orig_size to ensure proper metadata align
2026-02-28 · Suggested-by -
STALE137d
REVIEWED: 6 (6M) [PATCH v10 08/13] x86/kasan: Initialize KASAN raw shadow memory
2026-02-04 · Reviewed-by -
STALE137d
REVIEWED: 2 (2M) [PATCH v10 04/13] x86/kasan: Add arch specific kasan functions
2026-02-04 · Reviewed-by -
STALE137d
REVIEWED: 10 (10M) [PATCH v10 03/13] kasan: Fix inline mode for x86 tag-based mode
2026-02-04 · Reviewed-by -
STALE137d
REVIEWED: 6 (6M) [PATCH v10 02/13] kasan: arm64: x86: Make special tags arch specific
2026-02-04 · Reviewed-by -
STALE179d
REVIEWED: 2 (2M) Re: [PATCH 1/1] kasan: remove unnecessary sync argument from start_report()
2026-01-22 · Acked-by -
STALE146d
REVIEWED: 6 (6M) [PATCH v9 08/13] x86/kasan: Initialize KASAN raw shadow memory
2026-01-20 · Reviewed-by -
STALE146d
REVIEWED: 2 (2M) [PATCH v9 04/13] x86/kasan: Add arch specific kasan functions
2026-01-20 · Reviewed-by -
STALE146d
REVIEWED: 10 (10M) [PATCH v9 03/13] kasan: Fix inline mode for x86 tag-based mode
2026-01-20 · Reviewed-by -
STALE146d
REVIEWED: 6 (6M) [PATCH v9 02/13] kasan: arm64: x86: Make special tags arch specific
2026-01-20 · Reviewed-by -
STALE180d
REVIEWED: 2 (2M) Re: [PATCH v8 08/14] x86/kasan: KASAN raw shadow memory PTE init
2026-01-16 · Reviewed-by -
STALE180d
REVIEWED: 2 (2M) Re: [PATCH v8 04/14] x86/kasan: Add arch specific kasan functions
2026-01-16 · Reviewed-by -
STALE180d
REVIEWED: 2 (2M) Re: [PATCH v8 03/14] kasan: Fix inline mode for x86 tag-based mode
2026-01-16 · Reviewed-by -
STALE180d
REVIEWED: 2 (2M) Re: [PATCH v8 02/14] kasan: arm64: x86: Make special tags arch specific
2026-01-16 · Reviewed-by -
STALE189d
[PATCH V6 1/9] mm/slab: use unsigned long for orig_size to ensure proper metadata align
2026-01-13 · Suggested-by -
STALE190d
[PATCH V5 1/8] mm/slab: use unsigned long for orig_size to ensure proper metadata align
2026-01-05 · Suggested-by -
STALE203d
[PATCH V4 1/8] mm/slab: use unsigned long for orig_size to ensure proper metadata align
2025-12-22 · Suggested-by -
DORMANTno replies
REVIEWED: 9 (9M) [tip: x86/core] x86/dumpstack: Prevent KASAN false positive warnings in __show_regs()
2025-10-29 · Reviewed-by -
STALE265d
REVIEWED: 9 (9M) [PATCH -next v4] x86/dumpstack: Prevent KASAN false positive warnings in __show_regs
2025-10-23 · Reviewed-by -
STALE286d
REVIEWED: 3 (2M) [PATCH v4 06/10] mm/kasan: Support non-blocking GFP in kasan_populate_vmalloc()
2025-10-07 · Reviewed-by -
STALE287d
REVIEWED: 3 (2M) [PATCH v3 06/10] mm/kasan: Support non-blocking GFP in kasan_populate_vmalloc()
2025-10-01 · Reviewed-by -
DORMANTno replies
REVIEWED: 2 (2M) Re: [PATCH v2 07/10] mm/kasan: Support non-blocking GFP in kasan_populate_vmalloc()
2025-09-18 · Reviewed-by -
STALE301d
REVIEWED: 2 (2M) Re: [PATCH v8 2/2] kasan: apply write-only mode in kasan kunit testcases
2025-09-18 · Reviewed-by -
STALE301d
REVIEWED: 2 (2M) Re: [PATCH v8 1/2] kasan/hw-tags: introduce kasan.write_only option
2025-09-18 · Reviewed-by -
DORMANTno replies
REVIEWED: 2 (2M) Re: [PATCH] mm/vmalloc, mm/kasan: respect gfp mask in kasan_populate_vmalloc()
2025-09-05 · Reviewed-by -
STALE302d
REVIEWED: 2 (2M) Re: [PATCH -next v3] x86/dumpstack: Prevent KASAN false positive warnings in __show_regs
2025-09-05 · Reviewed-by -
STALE325d
REVIEWED: 2 (2M) Re: [PATCH -next v2] x86: Prevent KASAN false positive warnings in __show_regs
2025-08-29 · Reviewed-by -
DORMANTno replies
REVIEWED: 2 (2M) Re: [PATCH] kasan: use vmalloc_dump_obj() for vmalloc error reports
2025-07-18 · Acked-by -
STALE370d
REVIEWED: 2 (2M) Re: [PATCH v2] kasan: remove kasan_find_vm_area() to prevent possible deadlock
2025-07-04 · Reviewed-by -
STALE430d
[PATCH v9 1/1] kasan: Avoid sleepable page allocation from atomic context
2025-05-15 · Suggested-by -
STALE432d
REVIEWED: 1 (0M) [PATCH v8 1/1] kasan: Avoid sleepable page allocation from atomic context
2025-05-13 · Suggested-by -
STALE434d
[PATCH v7 1/1] kasan: Avoid sleepable page allocation from atomic context
2025-05-12 · Suggested-by -
STALE435d
[PATCH v6 1/1] kasan: Avoid sleepable page allocation from atomic context
2025-05-08 · Suggested-by -
STALE439d
[PATCH v5 1/1] kasan: Avoid sleepable page allocation from atomic context
2025-05-07 · Suggested-by -
STALE441d
[PATCH v4 1/1] kasan: Avoid sleepable page allocation from atomic context
2025-05-06 · Suggested-by -
STALE441d
[PATCH v3 1/1] kasan: Avoid sleepable page allocation from atomic context
2025-04-29 · Suggested-by -
DORMANTno replies
REVIEWED: 2 (2M) Re: [PATCH mm-unstable] mm/kasan: use SLAB_NO_MERGE flag instead of an empty constructor
2025-03-20 · Acked-by -
STALE519d
REVIEWED: 2 (2M) Re: [PATCH v2] kasan: Don't call find_vm_area() in RT kernel
2025-02-12 · Acked-by -
STALE813d
REVIEWED: 10 (9M) [PATCH v2] arm: kasan: clear stale stack poison
2024-04-10 · Acked-by -
STALE840d
REVIEWED: 2 (2M) Re: [PATCH] arm: kasan: clear stale stack poison
2024-04-02 · Acked-by -
DORMANTno replies
REVIEWED: 2 (2M) [tip: x86/mm] x86/mm: Recompute physical address for every page of per-CPU CEA mapping
2022-12-17 · Reviewed-by -
STALE1311d
REVIEWED: 2 (2M) [tip: x86/mm] x86/kasan: Add helpers to align shadow addresses up and down
2022-12-17 · Reviewed-by -
STALE1311d
REVIEWED: 2 (2M) [tip: x86/mm] x86/mm: Populate KASAN shadow for entire per-CPU range of CPU entry area
2022-12-17 · Suggested-by -
STALE1311d
REVIEWED: 2 (2M) [tip: x86/mm] x86/mm: Populate KASAN shadow for entire per-CPU range of CPU entry area
2022-12-17 · Reviewed-by -
STALE1311d
REVIEWED: 2 (2M) [tip: x86/mm] x86/kasan: Rename local CPU_ENTRY_AREA variables to shorten names
2022-12-17 · Reviewed-by -
STALE1311d
REVIEWED: 2 (2M) [tip: x86/mm] x86/mm: Recompute physical address for every page of per-CPU CEA mapping
2022-11-15 · Reviewed-by -
STALE1311d
REVIEWED: 2 (2M) [tip: x86/mm] x86/mm: Populate KASAN shadow for entire per-CPU range of CPU entry area
2022-11-15 · Suggested-by -
STALE1311d
REVIEWED: 2 (2M) [tip: x86/mm] x86/mm: Populate KASAN shadow for entire per-CPU range of CPU entry area
2022-11-15 · Reviewed-by -
STALE1311d
REVIEWED: 2 (2M) [tip: x86/mm] x86/kasan: Rename local CPU_ENTRY_AREA variables to shorten names
2022-11-15 · Reviewed-by -
STALE1311d
REVIEWED: 2 (2M) [tip: x86/mm] x86/kasan: Add helpers to align shadow addresses up and down
2022-11-15 · Reviewed-by -
STALE1311d
REVIEWED: 2 (2M) Re: [PATCH v2 4/5] x86/kasan: Add helpers to align shadow addresses up and down
2022-11-14 · Reviewed-by -
STALE1311d
REVIEWED: 2 (2M) Re: [PATCH v2 3/5] x86/kasan: Rename local CPU_ENTRY_AREA variables to shorten names
2022-11-14 · Reviewed-by -
STALE1311d
REVIEWED: 2 (2M) Re: [PATCH v2 2/5] x86/mm: Populate KASAN shadow for entire per-CPU range of CPU entry area
2022-11-14 · Reviewed-by -
STALE1311d
REVIEWED: 2 (2M) Re: [PATCH v2 1/5] x86/mm: Recompute physical address for every page of per-CPU CEA mapping
2022-11-14 · Reviewed-by -
STALE1311d
[PATCH v2 2/5] x86/mm: Populate KASAN shadow for entire per-CPU range of CPU entry area
2022-11-10 · Suggested-by -
STALE1871d
REVIEWED: 2 (2M) Re: [PATCH] kasan: fix doc warning in init.c
2021-06-03 · Acked-by -
DORMANTno replies
[tip:perf/urgent] perf/core: Fix Undefined behaviour in rb_alloc()
2016-03-21 · Reported-by -
DORMANTno replies
REVIEWED: 2 (2M) Re: [PATCH V2 2/4] mm/kasan: MODULE_VADDR is not available on all archs
2015-09-08 · Reviewed-by -
STALE3969d
REVIEWED: 2 (2M) [PATCH V2 3/4] mm/kasan: Don't use kasan shadow pointer in generic functions
2015-09-07 · Reviewed-by -
STALE3969d
REVIEWED: 2 (2M) [PATCH V2 4/4] mm/kasan: Prevent deadlock in kasan reporting
2015-09-07 · Reviewed-by -
STALE3969d
REVIEWED: 2 (2M) [PATCH V2 1/4] mm/kasan: Rename kasan_enabled to kasan_report_enabled
2015-09-07 · Reviewed-by -
DORMANTno replies
REVIEWED: 2 (2M) Re: [PATCH 4/4] kasan: Prevent deadlock in kasan reporting
2015-09-03 · Reviewed-by -
STALE3974d
REVIEWED: 2 (2M) [PATCH 1/4] kasan: Rename kasan_enabled to kasan_report_enabled
2015-09-03 · Reviewed-by -
STALE2937d
REVIEWED: 2 (2M) Re: [PATCH V2 03/10] kasan: Rename kasan_enabled to kasan_report_enabled
2015-08-26 · Reviewed-by