Reviews by kees@kernel.org
· lkml
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the lkml archive.
100 attestations · capped at 100 most-recent. (3 Acked-by, 4 Co-developed-by, 81 Reviewed-by, 7 Suggested-by, 5 Tested-by)
-
DORMANTno replies
REVIEWED: 21 (21M) [tip: x86/cleanups] x86/cfi: Add __init_or_module annotations for fineibt
2026-06-28 · Reviewed-by -
DORMANTno replies
REVIEWED: 14 (14M) Re: [PATCH v1] ACPICA: Unbreak tools build after switching over to strscpy_pad()
2026-06-23 · Reviewed-by -
COOLING6d
REVIEWED: 14 (14M) Re: [PATCH v1 1/2] overflow: Allow to sum a few arguments at once
2026-06-20 · Acked-by -
COOLING14d
REVIEWED: 26 (26M) [PATCH net-next v2 2/2] net: skb: isolate skb data area allocations into a separate bucket
2026-06-11 · Reviewed-by -
COOLING14d
REVIEWED: 25 (25M) [PATCH net-next v2 1/2] mm/slab: add a node-track-caller variant for kmem buckets allocation
2026-06-11 · Reviewed-by -
DORMANTno replies
REVIEWED: 15 (14M) [PATCH v3] media: atomisp: gmin: Use str_on_off() helper
2026-06-11 · Reviewed-by -
DORMANTno replies
REVIEWED: 14 (14M) [PATCH v2] cred: prevent slab cache merging for cred_jar
2026-06-11 · Reviewed-by -
COLD18d
REVIEWED: 14 (14M) Re: [PATCH] media: atomisp: gmin: Use str_on_off() helper
2026-06-10 · Reviewed-by -
COLD18d
REVIEWED: 14 (14M) Re: [PATCH] cred: prevent slab cache merging for cred_jar
2026-06-10 · Reviewed-by -
DORMANTno replies
REVIEWED: 14 (14M) Re: [PATCH v4 1/2] kunit: tool: Parse and print the reason tests are skipped
2026-06-10 · Reviewed-by -
WARM1d
REVIEWED: 14 (14M) Re: [PATCH] x86/cfi: add __init_or_module annotations for fineibt
2026-06-10 · Reviewed-by -
DORMANTno replies
REVIEWED: 14 (14M) Re: [PATCH 2/2] net: skb: isolate skb data area allocations into a separate bucket
2026-06-05 · Reviewed-by -
COLD24d
REVIEWED: 14 (14M) Re: [PATCH 1/2] mm/slab: add a node-track-caller variant for kmem buckets allocation
2026-06-05 · Reviewed-by -
COLD19d
REVIEWED: 15 (14M) [PATCH v4 2/2] kconfig: Remove the architecture specific config for Propeller
2026-06-04 · Reviewed-by -
COLD19d
REVIEWED: 15 (14M) [PATCH v4 1/2] kconfig: Remove the architecture specific config for AutoFDO
2026-06-04 · Reviewed-by -
COLD24d
REVIEWED: 14 (14M) Re: [PATCH] [v2] RDMA/hfi1, rdmavt: open-code rvt_set_ibdev_name()
2026-06-02 · Reviewed-by -
COLD27d
REVIEWED: 14 (14M) Re: [PATCH] block/partitions/acorn: use min in {riscix,linux}_partition
2026-06-02 · Reviewed-by -
COOLING11d
REVIEWED: 14 (14M) Re: [PATCH] Documentation: Fix syntax of kmalloc_objs example in coding style doc
2026-06-01 · Reviewed-by -
COLD25d
REVIEWED: 15 (14M) [PATCH v3 2/2] kconfig: Remove the architecture specific config for Propeller
2026-05-27 · Reviewed-by -
COLD25d
REVIEWED: 15 (14M) [PATCH v3 1/2] kconfig: Remove the architecture specific config for AutoFDO
2026-05-27 · Reviewed-by -
WARM3d
REVIEWED: 16 (16M) [PATCH v13 1/4] bug/kunit: Core support for suppressing warning backtraces
2026-05-15 · Reviewed-by -
COLD45d
REVIEWED: 16 (16M) [PATCH v12 1/4] bug/kunit: Core support for suppressing warning backtraces
2026-05-15 · Reviewed-by -
COLD41d
REVIEWED: 14 (14M) Re: [PATCH v2 2/3] scripts: checkpatch.pl: add warning for strlcat()
2026-05-14 · Reviewed-by -
COLD45d
IN LINUX-NEXT: 16 (16M) [PATCH v11 1/4] bug/kunit: Core support for suppressing warning backtraces
2026-05-14 · Reviewed-by -
COLD46d
REVIEWED: 16 (16M) [PATCH v10 1/4] bug/kunit: Core support for suppressing warning backtraces
2026-05-13 · Reviewed-by -
COLD45d
REVIEWED: 14 (14M) Re: [PATCH] docs: kernel-doc: python: strip __counted_by_ptr macro
2026-05-11 · Reviewed-by -
COLD35d
REVIEWED: 14 (14M) Re: [PATCH v2] params: bound array element output to the caller's page buffer
2026-05-11 · Reviewed-by -
COLD48d
REVIEWED: 16 (16M) [PATCH v9 1/4] bug/kunit: Core support for suppressing warning backtraces
2026-05-08 · Reviewed-by -
COLD47d
REVIEWED: 14 (14M) [PATCH v8 1/4] bug/kunit: Core support for suppressing warning backtraces
2026-05-04 · Reviewed-by -
STALE63d
LANDED: 14 (14M) [PATCH v2] selftests: harness: Restore order of test functions
2026-04-22 · Reviewed-by -
DORMANTno replies
REVIEWED: 14 (14M) Re: [PATCH] selftests: harness: Restore order of test functions
2026-04-20 · Reviewed-by -
STALE66d
REVIEWED: 14 (14M) [PATCH v7 1/5] bug/kunit: Core support for suppressing warning backtraces
2026-04-20 · Reviewed-by -
COOLING10d
REVIEWED: 15 (14M) [PATCH v2] signalfd: don't dequeue the forced fatal signals
2026-04-06 · Reviewed-by -
COOLING10d
REVIEWED: 14 (14M) Re: [PATCH] signalfd: don't dequeue the forced fatal signals
2026-04-06 · Reviewed-by -
STALE87d
REVIEWED: 14 (14M) Re: [PATCH v2 2/3] Documentation: explain how to find maintainers addresses for security reports
2026-04-03 · Reviewed-by -
STALE83d
REVIEWED: 14 (14M) Re: [PATCH] MIPS: Increase default mmap randomization bits for 64-bit
2026-03-31 · Reviewed-by -
STALE80d
[PATCH 2/5] hardening: Introduce Overflow Behavior Types support
2026-03-31 · Co-developed-by -
STALE80d
[PATCH 3/5] compiler_attributes: Add overflow_behavior macros __ob_trap and __ob_wrap
2026-03-31 · Co-developed-by -
STALE83d
REVIEWED: 14 (14M) Re: [PATCH v2] kbuild: expand inlining hints with -fdiagnostics-show-inlining-chain
2026-03-31 · Reviewed-by -
STALE75d
REVIEWED: 16 (14M) [PATCH 4/4] selftests/exec: add test for HWCAP inheritance
2026-03-23 · Reviewed-by -
STALE95d
REVIEWED: 20 (20M) [PATCH v2] rust: allow Clang-native `RANDSTRUCT` configs
2026-03-23 · Reviewed-by -
STALE101d
REVIEWED: 14 (14M) Re: [PATCH v1 1/1] ACPI: processor: idle: Replace strlcat() with better alternative
2026-03-20 · Reviewed-by -
STALE91d
REVIEWED: 14 (14M) Re: [PATCH RESEND] m68k: emu: Replace unbounded sprintf in nfhd_init_one
2026-03-20 · Reviewed-by -
DORMANTno replies
REVIEWED: 14 (14M) Re: [PATCH] KVM: arm64: vgic: Annotate struct vgic_dist with __counted_by_ptr
2026-03-20 · Reviewed-by -
STALE98d
REVIEWED: 14 (14M) Re: [PATCHv3] thunderbolt: use kzalloc_flex
2026-03-20 · Reviewed-by -
STALE100d
REVIEWED: 14 (14M) Re: [PATCH] media: em28xx: kzalloc + kcalloc to kzalloc_flex
2026-03-20 · Reviewed-by -
STALE94d
REVIEWED: 14 (14M) Re: [PATCH 2/2] crypto: stm32 - use list_first_entry_or_null to simplify cryp_find_dev
2026-03-20 · Reviewed-by -
STALE97d
REVIEWED: 14 (14M) Re: [PATCH 1/3] [RESEND] RDMA/hfi1: use a struct group to avoid warning
2026-03-20 · Reviewed-by -
STALE96d
REVIEWED: 14 (14M) Re: [PATCH] net: sfc: avoid format string warning
2026-03-20 · Reviewed-by -
STALE97d
REVIEWED: 14 (14M) Re: [PATCH] clk: qoriq: avoid formwat string warning
2026-03-20 · Reviewed-by -
DORMANTno replies
REVIEWED: 14 (14M) Re: [PATCH] drm/amd/ras: work around write overflow attribute warning
2026-03-18 · Reviewed-by -
STALE102d
REVIEWED: 14 (14M) Re: [PATCH 00/15] exec: Remove AT_VECTOR_SIZE_ARCH from UAPI
2026-03-18 · Reviewed-by -
STALE103d
REVIEWED: 14 (14M) [PATCH v6 1/5] bug/kunit: Core support for suppressing warning backtraces
2026-03-17 · Reviewed-by -
DORMANTno replies
REVIEWED: 14 (14M) [PATCH RESEND] most: usb: Use kzalloc_objs for endpoint address array
2026-03-09 · Reviewed-by -
STALE87d
REVIEWED: 14 (14M) Re: [PATCH] KVM: x86: Fix C++ user API for structures with variable length arrays
2026-02-26 · Reviewed-by -
DORMANTno replies
REVIEWED: 14 (14M) Re: [PATCH] most: usb: Use kzalloc_objs for endpoint address array
2026-02-25 · Reviewed-by -
STALE122d
REVIEWED: 14 (14M) [PATCH v2] btrfs: replace kcalloc() calls to kzalloc_objs()
2026-02-24 · Reviewed-by -
STALE124d
REVIEWED: 14 (14M) Re: [PATCH] btrfs: replace kcalloc() calls to kzalloc_objs()
2026-02-24 · Reviewed-by -
STALE109d
REVIEWED: 14 (14M) Re: [PATCH 2/2] kbuild: Use '-fms-anonymous-structs' if it is available
2026-02-23 · Reviewed-by -
DORMANTno replies
REVIEWED: 14 (14M) Re: [PATCH v1] xz: fix arm fdt compile error for kmalloc replacement
2026-02-22 · Reviewed-by -
STALE98d
REVIEWED: 16 (14M) [PATCH 4/4] selftests/exec: add test for HWCAP inheritance
2026-02-17 · Reviewed-by -
STALE124d
[PATCH v2] mtd: Avoid boot crash in RedBoot partition table parser
2026-02-16 · Suggested-by -
DORMANTno replies
REVIEWED: 14 (14M) Re: [PATCH 4/4] selftests/exec: add test for HWCAP inheritance
2026-02-12 · Reviewed-by -
STALE145d
REVIEWED: 14 (14M) [PATCH v14 01/13] x86/um: nommu: elf loader for fdpic
2026-02-04 · Acked-by -
STALE145d
REVIEWED: 14 (14M) Re: [PATCH] fs/tests: exec: drop duplicate bprm_stack_limits test vectors
2026-02-04 · Reviewed-by -
STALE87d
REVIEWED: 14 (14M) Re: [PATCH v7 5/8] lib/string_kunit: extend benchmarks to strnlen() and chr searches
2026-01-30 · Reviewed-by -
STALE87d
REVIEWED: 14 (14M) Re: [PATCH v7 4/8] lib/string_kunit: add performance benchmark for strlen()
2026-01-30 · Reviewed-by -
STALE87d
REVIEWED: 14 (14M) Re: [PATCH v7 3/8] lib/string_kunit: add correctness test for strrchr()
2026-01-30 · Reviewed-by -
STALE87d
REVIEWED: 14 (14M) Re: [PATCH v7 2/8] lib/string_kunit: add correctness test for strnlen()
2026-01-30 · Reviewed-by -
STALE87d
REVIEWED: 14 (14M) Re: [PATCH v7 1/8] lib/string_kunit: add correctness test for strlen()
2026-01-30 · Reviewed-by -
STALE87d
[PATCH v7 1/8] lib/string_kunit: add correctness test for strlen()
2026-01-30 · Suggested-by -
STALE87d
[PATCH v7 2/8] lib/string_kunit: add correctness test for strnlen()
2026-01-30 · Suggested-by -
STALE87d
[PATCH v7 3/8] lib/string_kunit: add correctness test for strrchr()
2026-01-30 · Suggested-by -
STALE150d
[PATCH v6 3/8] lib/string_kunit: add correctness test for strrchr()
2026-01-29 · Suggested-by -
STALE150d
[PATCH v6 2/8] lib/string_kunit: add correctness test for strnlen()
2026-01-29 · Suggested-by -
STALE150d
[PATCH v6 1/8] lib/string_kunit: add correctness test for strlen()
2026-01-29 · Suggested-by -
STALE153d
REVIEWED: 38 (38M) [PATCH] Documentation: Project continuity
2026-01-24 · Reviewed-by -
STALE140d
REVIEWED: 14 (14M) Re: [PATCH next 01/14] overflow: Reduce expansion of __type_max()
2026-01-21 · Reviewed-by -
STALE157d
REVIEWED: 78 (75M) [PATCH] [v6] Documentation: Provide guidelines for tool-generated content
2026-01-19 · Reviewed-by -
STALE150d
REVIEWED: 14 (14M) [PATCH v2 2/2] kallsyms: Get rid of kallsyms relative base
2026-01-16 · Reviewed-by -
STALE139d
[PATCH v4 1/2] Compiler Attributes: Add __counted_by_ptr macro
2026-01-16 · Co-developed-by -
DORMANTno replies
REVIEWED: 14 (14M) Re: [PATCH] kallsyms: Get rid of kallsyms relative base
2026-01-16 · Reviewed-by -
STALE139d
[PATCH 1/2] Compiler Attributes: Add __counted_by_ptr macro
2026-01-14 · Co-developed-by -
STALE161d
REVIEWED: 73 (71M) [PATCH] [v5] Documentation: Provide guidelines for tool-generated content
2026-01-13 · Reviewed-by -
STALE168d
REVIEWED: 64 (63M) [PATCH] [v3] Documentation: Provide guidelines for tool-generated content
2026-01-06 · Reviewed-by -
STALE193d
REVIEWED: 38 (38M) [PATCH v23 7/8] selftests/clone3: Allow tests to flag if -E2BIG is a valid error code
2025-12-18 · Reviewed-by -
STALE193d
REVIEWED: 38 (38M) [PATCH v23 7/8] selftests/clone3: Allow tests to flag if -E2BIG is a valid error code
2025-12-18 · Tested-by -
STALE193d
REVIEWED: 38 (38M) [PATCH v23 6/8] selftests/clone3: Factor more of main loop into test_clone3()
2025-12-18 · Reviewed-by -
STALE193d
REVIEWED: 38 (38M) [PATCH v23 6/8] selftests/clone3: Factor more of main loop into test_clone3()
2025-12-18 · Tested-by -
STALE193d
REVIEWED: 38 (38M) [PATCH v23 5/8] selftests/clone3: Remove redundant flushes of output streams
2025-12-18 · Reviewed-by -
STALE193d
REVIEWED: 38 (38M) [PATCH v23 5/8] selftests/clone3: Remove redundant flushes of output streams
2025-12-18 · Tested-by -
STALE193d
REVIEWED: 39 (39M) [PATCH v23 3/8] selftests: Provide helper header for shadow stack testing
2025-12-18 · Reviewed-by -
STALE193d
REVIEWED: 39 (39M) [PATCH v23 3/8] selftests: Provide helper header for shadow stack testing
2025-12-18 · Tested-by -
STALE193d
REVIEWED: 40 (38M) [PATCH v23 2/8] Documentation: userspace-api: Add shadow stack API documentation
2025-12-18 · Reviewed-by -
STALE193d
REVIEWED: 40 (38M) [PATCH v23 2/8] Documentation: userspace-api: Add shadow stack API documentation
2025-12-18 · Tested-by -
STALE194d
REVIEWED: 14 (14M) Re: [PATCH] sysctl: Add missing kernel-doc for proc_dointvec_conv
2025-12-16 · Reviewed-by -
STALE201d
REVIEWED: 14 (14M) Re: [PATCH v2 09/13] selftests/seccomp: Fix build warning
2025-12-05 · Reviewed-by -
STALE201d
REVIEWED: 14 (14M) Re: [PATCH] efi: pstore: Support late setup with TEE-backed efivars ops
2025-12-04 · Acked-by -
DORMANTno replies
REVIEWED: 14 (14M) [for-next][PATCH 13/13] overflow: Introduce struct_offset() to get offset of member
2025-11-28 · Reviewed-by -
STALE213d
REVIEWED: 14 (14M) Re: [PATCH] overflow: Introduce struct_offset() to get offset of member
2025-11-27 · Reviewed-by