Reviews by pmladek@suse.com
· live-patching
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the live-patching archive.
100 attestations · capped at 100 most-recent. (6 Acked-by, 59 Reviewed-by, 15 Suggested-by, 20 Tested-by)
-
COLD25d
REVIEWED: 4 (4M) Re: [PATCH] kbuild: unset sub_make_done before calling kselftest build system
2026-07-03 · Acked-by -
DORMANTno replies
REVIEWED: 4 (4M) Re: [PATCH] livepatch/klp-build: Fix wrong index in error cleanup loop
2026-07-02 · Reviewed-by -
COLD28d
REVIEWED: 4 (4M) Re: [PATCH v2 0/2] perf symbols: skip livepatch symbols
2026-07-02 · Acked-by -
COLD30d
REVIEWED: 4 (4M) Re: [PATCH] selftests: livepatch: unset sub_make_done in case top level Makefile be overwritten
2026-07-01 · Acked-by -
COLD25d
REVIEWED: 8 (8M) Re: [PATCH v2] livepatch: Fix NULL pointer dereference in klp_find_func()
2026-06-30 · Reviewed-by -
COLD25d
REVIEWED: 8 (8M) Re: [PATCH v2] livepatch: Fix NULL pointer dereference in klp_find_func()
2026-06-30 · Tested-by -
COLD25d
REVIEWED: 1 (1M) [PATCH v2] livepatch: Fix NULL pointer dereference in klp_find_func()
2026-06-28 · Suggested-by -
COLD25d
[PATCH] livepatch: Fix NULL pointer dereference in klp_find_func()
2026-06-23 · Suggested-by -
COLD38d
[PATCH v3 3/7] livepatch: Support scoped atomic replace using replace_set
2026-06-07 · Suggested-by -
COLD53d
REVIEWED: 4 (4M) Re: [PATCH v2] selftests/livepatch: fix resource leak in test_klp_syscall init error path
2026-06-04 · Reviewed-by -
STALE64d
[PATCH v2 2/4] livepatch: Support scoped atomic replace using replace_set
2026-05-29 · Suggested-by -
COLD59d
REVIEWED: 4 (4M) Re: [PATCH] selftests: livepatch: set LC_ALL=C to fix locale-dependent test failure
2026-05-28 · Acked-by -
STALE87d
REVIEWED: 4 (4M) Re: [PATCH v5 0/6] kselftests: livepatch: Adapt tests to be executed on 4.12 kernels
2026-05-06 · Reviewed-by -
STALE148d
REVIEWED: 8 (8M) Re: [PATCH 1/2] selftests: livepatch: test-ftrace: livepatch a traced function
2026-03-06 · Reviewed-by -
STALE148d
REVIEWED: 8 (8M) Re: [PATCH 1/2] selftests: livepatch: test-ftrace: livepatch a traced function
2026-03-06 · Tested-by -
DORMANTno replies
REVIEWED: 15 (15M) [PATCH AUTOSEL 6.18-5.10] livepatch: Match old_sympos 0 and 1 in klp_find_func()
2025-12-05 · Reviewed-by -
DORMANTno replies
REVIEWED: 15 (15M) [PATCH AUTOSEL 6.18-5.10] livepatch: Match old_sympos 0 and 1 in klp_find_func()
2025-12-05 · Tested-by -
DORMANTno replies
REVIEWED: 8 (8M) Re: [PATCH v2] livepatch: Match old_sympos 0 and 1 in klp_find_func()
2025-10-15 · Reviewed-by -
DORMANTno replies
REVIEWED: 8 (8M) Re: [PATCH v2] livepatch: Match old_sympos 0 and 1 in klp_find_func()
2025-10-15 · Tested-by -
STALE290d
REVIEWED: 8 (8M) Re: [PATCH] selftests: livepatch: use canonical ftrace path
2025-10-13 · Reviewed-by -
STALE290d
REVIEWED: 8 (8M) Re: [PATCH] selftests: livepatch: use canonical ftrace path
2025-10-13 · Tested-by -
STALE205d
REVIEWED: 4 (4M) Re: [PATCH v4 00/63] objtool,livepatch: klp-build livepatch module generation
2025-10-10 · Acked-by -
STALE444d
REVIEWED: 8 (8M) Re: [PATCH v2] sched,livepatch: Untangle cond_resched() and live-patching
2025-05-14 · Reviewed-by -
STALE444d
REVIEWED: 8 (8M) Re: [PATCH v2] sched,livepatch: Untangle cond_resched() and live-patching
2025-05-14 · Tested-by -
STALE438d
REVIEWED: 4 (4M) Re: [PATCH v3 0/2] arm64: livepatch: Enable livepatch without sframe
2025-04-10 · Reviewed-by -
STALE494d
REVIEWED: 8 (8M) Re: [PATCH v3 0/2] selftests: livepatch: test if ftrace can trace a livepatched function
2025-03-25 · Reviewed-by -
STALE494d
REVIEWED: 8 (8M) Re: [PATCH v3 0/2] selftests: livepatch: test if ftrace can trace a livepatched function
2025-03-25 · Tested-by -
STALE463d
REVIEWED: 4 (4M) Re: [PATCH 03/10] samples/livepatch: add module descriptions
2025-03-25 · Reviewed-by -
STALE515d
REVIEWED: 4 (4M) Re: [PATCH v3 1/2] livepatch: Add comment to clarify klp_add_nops()
2025-02-27 · Reviewed-by -
STALE515d
LANDED [PATCH v3 1/2] livepatch: Add comment to clarify klp_add_nops()
2025-02-27 · Suggested-by -
STALE521d
[PATCH v2 1/2] livepatch: Add comment to clarify klp_add_nops()
2025-02-23 · Suggested-by -
STALE551d
REVIEWED: 8 (8M) Re: [PATCH v2] selftests: livepatch: handle PRINTK_CALLER in check_result()
2025-01-20 · Reviewed-by -
STALE551d
REVIEWED: 8 (8M) Re: [PATCH v2] selftests: livepatch: handle PRINTK_CALLER in check_result()
2025-01-20 · Tested-by -
DORMANTno replies
REVIEWED: 8 (8M) Re: [PATCH] module: Fix writing of livepatch relocations in ROX text
2025-01-09 · Reviewed-by -
DORMANTno replies
REVIEWED: 8 (8M) Re: [PATCH] module: Fix writing of livepatch relocations in ROX text
2025-01-09 · Tested-by -
STALE271d
LANDED: 21 (21M) [PATCH v3 06/28] module: Use RCU in find_module_all().
2025-01-08 · Reviewed-by -
STALE571d
REVIEWED: 4 (4M) Re: [PATCH v2 06/28] module: Use RCU in find_module_all().
2025-01-02 · Reviewed-by -
STALE600d
REVIEWED: 8 (8M) Re: [PATCH V3] selftests: livepatch: add test cases of stack_order sysfs interface
2024-12-02 · Reviewed-by -
STALE600d
REVIEWED: 8 (8M) Re: [PATCH V3] selftests: livepatch: add test cases of stack_order sysfs interface
2024-12-02 · Tested-by -
STALE600d
REVIEWED: 4 (4M) Re: [PATCH livepatch/master v1 2/2] selftests/livepatch: Replace hardcoded module name with variable in test-callbacks.sh
2024-11-26 · Reviewed-by -
STALE600d
LANDED [PATCH V3] selftests: livepatch: add test cases of stack_order sysfs interface
2024-10-24 · Suggested-by -
STALE646d
REVIEWED: 8 (8M) Re: [PATCH V2] selftests: livepatch: add test cases of stack_order sysfs interface
2024-10-24 · Reviewed-by -
STALE646d
REVIEWED: 8 (8M) Re: [PATCH V2] selftests: livepatch: add test cases of stack_order sysfs interface
2024-10-24 · Tested-by -
STALE646d
REVIEWED: 16 (16M) Re: [PATCH V5 1/1] livepatch: Add stack_order sysfs attribute
2024-10-24 · Reviewed-by -
STALE646d
REVIEWED: 16 (16M) Re: [PATCH V5 1/1] livepatch: Add stack_order sysfs attribute
2024-10-24 · Tested-by -
STALE646d
[PATCH V2] selftests: livepatch: add test cases of stack_order sysfs interface
2024-10-24 · Suggested-by -
STALE646d
[PATCH V5 1/1] livepatch: Add stack_order sysfs attribute
2024-10-24 · Suggested-by -
STALE647d
REVIEWED: 8 (8M) Re: [PATCH] selftests: livepatch: add test cases of stack_order sysfs interface
2024-10-23 · Reviewed-by -
STALE647d
REVIEWED: 8 (8M) Re: [PATCH] selftests: livepatch: add test cases of stack_order sysfs interface
2024-10-23 · Tested-by -
STALE648d
REVIEWED: 8 (8M) Re: [PATCH v5 0/3] selftests: livepatch: test livepatching a kprobed function
2024-10-22 · Reviewed-by -
STALE648d
REVIEWED: 8 (8M) Re: [PATCH v5 0/3] selftests: livepatch: test livepatching a kprobed function
2024-10-22 · Tested-by -
STALE600d
REVIEWED: 8 (8M) Re: [PATCH V5 1/1] livepatch: Add stack_order sysfs attribute
2024-10-11 · Reviewed-by -
STALE600d
REVIEWED: 8 (8M) Re: [PATCH V5 1/1] livepatch: Add stack_order sysfs attribute
2024-10-11 · Tested-by -
STALE600d
LANDED [PATCH V5 1/1] livepatch: Add stack_order sysfs attribute
2024-10-08 · Suggested-by -
DORMANTno replies
[PATCH V4 1/1] livepatch: Add stack_order sysfs attribute
2024-10-08 · Suggested-by -
STALE663d
[PATCH V4 1/1] livepatch: Add stack_order sysfs attribute
2024-10-07 · Suggested-by -
STALE664d
[PATCH V3 1/1] livepatch: Add "stack_order" sysfs attribute
2024-09-29 · Suggested-by -
STALE671d
[PATCH] livepatch: introduce 'stack_order' sysfs interface to klp_patch
2024-09-25 · Suggested-by -
STALE673d
REVIEWED: 8 (8M) Re: [PATCH v3 0/3] selftests: livepatch: test livepatching a kprobed function
2024-09-24 · Reviewed-by -
STALE673d
REVIEWED: 8 (8M) Re: [PATCH v3 0/3] selftests: livepatch: test livepatching a kprobed function
2024-09-24 · Tested-by -
STALE675d
[PATCH 1/2] livepatch: introduce 'order' sysfs interface to klp_patch
2024-09-20 · Suggested-by -
STALE689d
REVIEWED: 4 (4M) Re: [PATCH] Documentation: livepatch: Correct release locks antonym
2024-09-04 · Reviewed-by -
STALE297d
REVIEWED: 5 (4M) [PATCH v3 5/6] documentation: Update on livepatch elf format
2024-08-27 · Reviewed-by -
STALE297d
REVIEWED: 8 (8M) [PATCH v3 6/6] selftests: livepatch: Test livepatching function using an external symbol
2024-08-27 · Reviewed-by -
STALE297d
REVIEWED: 8 (8M) [PATCH v3 6/6] selftests: livepatch: Test livepatching function using an external symbol
2024-08-27 · Tested-by -
STALE297d
REVIEWED: 4 (4M) [PATCH v3 4/6] livepatch: Add sample livepatch module
2024-08-27 · Reviewed-by -
STALE297d
REVIEWED: 5 (4M) [PATCH v3 3/6] kbuild/modpost: integrate klp-convert
2024-08-27 · Reviewed-by -
STALE297d
REVIEWED: 5 (4M) [PATCH v3 1/6] livepatch: Create and include UAPI headers
2024-08-27 · Reviewed-by -
STALE705d
REVIEWED: 4 (4M) Re: [PATCH] selftests/livepatch: wait for atomic replace to occur
2024-08-23 · Reviewed-by -
STALE701d
REVIEWED: 4 (4M) Re: [PATCH v3 0/2] Fix kallsyms with CONFIG_LTO_CLANG
2024-08-14 · Acked-by -
STALE759d
LANDED: 4 (4M) [PATCH v3 3/3] livepatch: Replace snprintf() with sysfs_emit()
2024-06-25 · Reviewed-by -
STALE759d
LANDED: 6 (4M) [PATCH v3 2/3] selftests/livepatch: Add selftests for "replace" sysfs attribute
2024-06-25 · Reviewed-by -
STALE759d
LANDED: 4 (4M) [PATCH v3 1/3] livepatch: Add "replace" sysfs attribute
2024-06-25 · Reviewed-by -
STALE764d
REVIEWED: 4 (4M) Re: [PATCH v2 3/3] livepatch: Replace snprintf() with sysfs_emit()
2024-06-24 · Reviewed-by -
STALE764d
REVIEWED: 4 (4M) Re: [PATCH v2 2/3] selftests/livepatch: Add selftests for "replace" sysfs attribute
2024-06-24 · Reviewed-by -
STALE764d
REVIEWED: 4 (4M) Re: [PATCH v2 1/3] livepatch: Add "replace" sysfs attribute
2024-06-24 · Reviewed-by -
STALE774d
REVIEWED: 4 (4M) Re: [PATCH v3] selftests: livepatch: Test atomic replace against multiple modules
2024-06-18 · Reviewed-by -
STALE778d
REVIEWED: 4 (4M) Re: [PATCH] tools/testing/selftests/livepatch: define max test-syscall processes
2024-05-31 · Reviewed-by -
STALE789d
REVIEWED: 4 (4M) Re: [PATCH v2] selftests: livepatch: Test atomic replace against multiple modules
2024-05-28 · Reviewed-by -
STALE786d
REVIEWED: 8 (8M) Re: [PATCH v2 6/6] selftests: livepatch: Test livepatching function using an external symbol
2024-05-22 · Reviewed-by -
STALE786d
REVIEWED: 8 (8M) Re: [PATCH v2 6/6] selftests: livepatch: Test livepatching function using an external symbol
2024-05-22 · Tested-by -
STALE786d
REVIEWED: 5 (4M) [PATCH v2 5/6] documentation: Update on livepatch elf format
2024-05-16 · Reviewed-by -
STALE786d
REVIEWED: 4 (4M) [PATCH v2 4/6] livepatch: Add sample livepatch module
2024-05-16 · Reviewed-by -
STALE786d
REVIEWED: 5 (4M) [PATCH v2 3/6] kbuild/modpost: integrate klp-convert
2024-05-16 · Reviewed-by -
STALE786d
REVIEWED: 5 (4M) [PATCH v2 1/6] livepatch: Create and include UAPI headers
2024-05-16 · Reviewed-by -
STALE814d
REVIEWED: 8 (8M) Re: [PATCH 1/1] livepatch: Rename KLP_* to KLP_TRANSITION_*
2024-05-07 · Reviewed-by -
STALE814d
REVIEWED: 8 (8M) Re: [PATCH 1/1] livepatch: Rename KLP_* to KLP_TRANSITION_*
2024-05-07 · Tested-by -
STALE922d
REVIEWED: 5 (5M) [PATCH v6 3/3] selftests: livepatch: Test livepatching a heavily called syscall
2024-01-12 · Reviewed-by -
STALE922d
REVIEWED: 5 (5M) [PATCH v6 2/3] livepatch: Move tests from lib/livepatch to selftests/livepatch
2024-01-12 · Reviewed-by -
STALE922d
REVIEWED: 5 (5M) [PATCH v6 1/3] kselftests: lib.mk: Add TEST_GEN_MODS_DIR variable
2024-01-12 · Reviewed-by -
DORMANTno replies
REVIEWED: 4 (4M) Re: [PATCH v5 3/3] selftests: livepatch: Test livepatching a heavily called syscall
2024-01-11 · Reviewed-by -
STALE933d
REVIEWED: 4 (4M) Re: [PATCH v5 2/3] livepatch: Move tests from lib/livepatch to selftests/livepatch
2024-01-11 · Reviewed-by -
STALE933d
REVIEWED: 4 (4M) Re: [PATCH v5 1/3] kselftests: lib.mk: Add TEST_GEN_MODS_DIR variable
2024-01-11 · Reviewed-by -
STALE842d
REVIEWED: 4 (4M) Re: [PATCH v1 5/5] documentation: Update on livepatch elf format
2024-01-05 · Reviewed-by -
STALE842d
REVIEWED: 4 (4M) Re: [PATCH v1 4/5] livepatch: Add sample livepatch module
2024-01-05 · Reviewed-by -
STALE842d
REVIEWED: 4 (4M) Re: [PATCH v1 3/5] kbuild/modpost: integrate klp-convert
2024-01-05 · Reviewed-by -
STALE842d
REVIEWED: 4 (4M) Re: [PATCH v1 1/5] livepatch: Create and include UAPI headers
2024-01-05 · Reviewed-by -
STALE1021d
REVIEWED: 4 (4M) Re: [PATCH] powerpc/stacktrace: Fix arch_stack_walk_reliable()
2023-09-22 · Reviewed-by -
STALE1046d
REVIEWED: 4 (4M) Re: [PATCH] livepatch: Fix missing newline character in klp_resolve_symbols()
2023-09-20 · Reviewed-by -
DORMANTno replies
REVIEWED: 4 (4M) Re: [PATCH LINUX v5 2/2] xen: add support for initializing xenstore later as HVM domain
2023-07-21 · Tested-by