Reviews by jpoimboe@kernel.org
· live-patching
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the live-patching archive.
28 attestations . (16 Acked-by, 1 Reviewed-by, 11 Suggested-by)
-
STALE128d
REVIEWED: 7 (7M) Re: [PATCH kbuild v2] kbuild: Reduce the number of compiler-generated suffixes for clang thin-lto build
2026-03-10 · Acked-by -
STALE167d
REVIEWED: 7 (7M) Re: [PATCH v3 0/2] Improve handling of the __klp_{objects,funcs} sections in modules
2026-01-23 · Acked-by -
DORMANTno replies
REVIEWED: 15 (15M) [PATCH AUTOSEL 6.18-5.10] livepatch: Match old_sympos 0 and 1 in klp_find_func()
2025-12-05 · Acked-by -
STALE280d
REVIEWED: 7 (7M) Re: [PATCH v2] livepatch: Match old_sympos 0 and 1 in klp_find_func()
2025-10-14 · Acked-by -
STALE434d
REVIEWED: 7 (7M) Re: [PATCH v2] sched,livepatch: Untangle cond_resched() and live-patching
2025-05-13 · Acked-by -
STALE428d
REVIEWED: 7 (7M) Re: [PATCH v3 1/2] arm64: Implement arch_stack_walk_reliable
2025-03-21 · Reviewed-by -
STALE505d
[PATCH v3 2/2] livepatch: Replace tasklist_lock with RCU
2025-02-27 · Suggested-by -
STALE505d
LANDED [PATCH v3 1/2] livepatch: Add comment to clarify klp_add_nops()
2025-02-27 · Suggested-by -
STALE511d
[PATCH v2 1/2] livepatch: Add comment to clarify klp_add_nops()
2025-02-23 · Suggested-by -
STALE519d
[PATCH 1/3] livepatch: Add comment to clarify klp_add_nops()
2025-02-11 · Suggested-by -
STALE636d
REVIEWED: 16 (16M) Re: [PATCH V5 1/1] livepatch: Add stack_order sysfs attribute
2024-10-24 · Acked-by -
STALE636d
[PATCH V5 1/1] livepatch: Add stack_order sysfs attribute
2024-10-24 · Suggested-by -
STALE590d
REVIEWED: 7 (7M) Re: [PATCH V5 1/1] livepatch: Add stack_order sysfs attribute
2024-10-08 · Acked-by -
STALE590d
LANDED [PATCH V5 1/1] livepatch: Add stack_order sysfs attribute
2024-10-08 · Suggested-by -
DORMANTno replies
[PATCH V4 1/1] livepatch: Add stack_order sysfs attribute
2024-10-08 · Suggested-by -
DORMANTno replies
REVIEWED: 7 (7M) Re: [PATCH V4 1/1] livepatch: Add stack_order sysfs attribute
2024-10-07 · Acked-by -
STALE653d
[PATCH V4 1/1] livepatch: Add stack_order sysfs attribute
2024-10-07 · Suggested-by -
STALE654d
[PATCH V3 1/1] livepatch: Add "stack_order" sysfs attribute
2024-09-29 · Suggested-by -
STALE661d
[PATCH] livepatch: introduce 'stack_order' sysfs interface to klp_patch
2024-09-25 · Suggested-by -
STALE666d
[PATCH 1/2] livepatch: introduce 'order' sysfs interface to klp_patch
2024-09-20 · Suggested-by -
STALE804d
REVIEWED: 7 (7M) Re: [PATCH 1/1] livepatch: Rename KLP_* to KLP_TRANSITION_*
2024-05-08 · Acked-by -
STALE1133d
REVIEWED: 7 (7M) Re: [PATCH] livepatch: match symbols exactly in klp_find_object_symbol()
2023-06-05 · Acked-by -
STALE1139d
REVIEWED: 7 (7M) Re: [PATCH] ftrace: Allow inline functions not inlined to be traced
2023-05-31 · Acked-by -
STALE1265d
REVIEWED: 7 (7M) Re: [PATCH v11 2/2] livepatch,x86: Clear relocation targets on a module removal
2023-01-25 · Acked-by -
STALE1265d
REVIEWED: 7 (7M) Re: [PATCH v11 1/2] x86/module: remove unused code in __apply_relocate_add
2023-01-25 · Acked-by -
STALE1420d
LANDED: 11 (11M) [PATCH v5] livepatch: fix race between fork and KLP transition
2022-08-08 · Acked-by -
STALE1448d
REVIEWED: 11 (11M) [PATCH v4] livepatch: fix race between fork and KLP transition
2022-07-27 · Acked-by -
STALE1448d
REVIEWED: 7 (7M) Re: [PATCH v3] livepatch: fix race between fork and klp_reverse_transition
2022-07-27 · Acked-by