uprobes · Maintained
Maintainers
- M Masami Hiramatsu <mhiramat@kernel.org>
- M Oleg Nesterov <oleg@redhat.com>
- M Peter Zijlstra <peterz@infradead.org>
Paths
- F
arch/*/include/asm/uprobes.h - F
arch/*/kernel/probes/uprobes.c - F
arch/*/kernel/uprobes.c - F
include/linux/uprobes.h - F
kernel/events/uprobes.c
Last 30 days
Recent patches
Most-recent 17 patches in this subsystem on linuxppc-dev, ordered by date desc.
-
STALE305d
LANDED: 1 (0M) [PATCH v2 2/4] copy_process: pass clone_flags as u64 across calltree
2025-09-01 · Simon Schuster via B4 Relay <devnull+schuster.simon.siemens-energy.com@kernel.org> -
STALE396d
[PATCH v3 02/14] mm: Filter zone device pages returned from folio_walk_start()
2025-06-19 · Alistair Popple <apopple@nvidia.com> -
STALE396d
[PATCH v2 02/14] mm: Filter zone device pages returned from folio_walk_start()
2025-06-16 · Alistair Popple <apopple@nvidia.com> -
STALE768d
[PATCH 4/4] mm: replace set_pte_at_notify() with just set_pte_at()
2024-04-05 · Paolo Bonzini <pbonzini@redhat.com> -
STALE1090d
REVIEWED: 6 (6M) [PATCH v4 4/5] mmu_notifiers: Don't invalidate secondary TLBs as part of mmu_notifier_invalidate_range_end()
2023-07-25 · Alistair Popple <apopple@nvidia.com> -
STALE1094d
[PATCH v3 4/5] mmu_notifiers: Don't invalidate secondary TLBs as part of mmu_notifier_invalidate_range_end()
2023-07-20 · Alistair Popple <apopple@nvidia.com> -
STALE1091d
[PATCH v2 4/5] mmu_notifiers: Don't invalidate secondary TLBs as part of mmu_notifier_invalidate_range_end()
2023-07-19 · Alistair Popple <apopple@nvidia.com> -
STALE1097d
[PATCH 4/4] mmu_notifiers: Don't invalidate secondary TLBs as part of mmu_notifier_invalidate_range_end()
2023-07-18 · Alistair Popple <apopple@nvidia.com> -
DORMANTno replies
[RFC PATCH v2 3/3] mmu_notifiers: Don't invalidate secondary TLBs as part of mmu_notifier_invalidate_range_end()
2023-07-07 · Alistair Popple <apopple@nvidia.com> -
STALE1329d
[PATCH mm-unstable v1 20/20] mm: rename FOLL_FORCE to FOLL_PTRACE
2022-11-16 · David Hildenbrand <hidden> -
STALE2007d
[PATCH] powerpc/uprobes: Don't allow probe on suffix of prefixed instruction
2021-01-19 · Ravi Bangoria <hidden> -
STALE2245d
REVIEWED: 2 (2M) [PATCH 19/29] mm: rename flush_icache_user_range to flush_icache_user_page
2020-05-15 · Christoph Hellwig <hch@lst.de> -
STALE2259d
[PATCH 21/31] mm: rename flush_icache_user_range to flush_icache_user_page
2020-05-10 · Christoph Hellwig <hch@lst.de> -
STALE3232d
[PATCH] uprobe: Warn if unable to install breakpoint
2017-08-31 · Naveen N. Rao <hidden> -
STALE3413d
[RFC PATCH 04/13] mm: Add mm_struct argument to 'get_unmapped_area' and 'vm_unmapped_area'
2017-03-13 · Till Smejkal <hidden> -
STALE3554d
[PATCH 07/10] mm: replace get_user_pages_remote() write/force parameters with gup_flags
2016-10-13 · Lorenzo Stoakes <hidden> -
STALE4014d
[PATCH V4 4/6] mm: mlock: Introduce VM_LOCKONFAULT and add mlock flags to enable it
2015-07-21 · Eric B Munson <hidden>