dma buffer sharing framework · Maintained
Maintainers
- M Sumit Semwal <sumit.semwal@linaro.org>
- M Christian König <christian.koenig@amd.com>
Paths
- F
Documentation/driver-api/dma-buf.rst - F
Documentation/userspace-api/dma-buf-alloc-exchange.rst - F
drivers/dma-buf/ - F
include/linux/*fence.h - F
include/linux/dma-buf.h - F
include/linux/dma-buf/ - F
include/linux/dma-resv.h - F
rust/helpers/dma-resv.c
Last 30 days
Recent patches
Most-recent 14 patches in this subsystem on linuxppc-dev, ordered by date desc.
-
COOLING13d
Re: [PATCH v7 16/22] dma-direct: make dma_direct_map_phys() honor DMA_ATTR_CC_SHARED
2026-07-08 · Aneesh Kumar K.V <aneesh.kumar@kernel.org> -
COLD49d
[PATCH] dma-buf: move system_cc_shared heap under separate Kconfig
2026-06-10 · Sumit Semwal <sumit.semwal@linaro.org> -
STALE93d
Re: [PATCH V13 2/7] dma-resv: Fix undefined symbol when CONFIG_DMA_SHARED_BUFFER is disabled
2026-04-24 · Mukesh Kumar Chaurasiya <hidden> -
STALE93d
[PATCH V13 2/7] dma-resv: Fix undefined symbol when CONFIG_DMA_SHARED_BUFFER is disabled
2026-04-24 · Mukesh Kumar Chaurasiya (IBM) <hidden> -
STALE777d
LANDED [PATCH] tracing/treewide: Remove second parameter of __assign_str()
2024-05-16 · Steven Rostedt <rostedt@goodmis.org> -
STALE867d
[FYI][PATCH] tracing/treewide: Remove second parameter of __assign_str()
2024-02-23 · Steven Rostedt <rostedt@goodmis.org> -
STALE1350d
REVIEWED: 19 (19M) [PATCH v3 3/3] treewide: use get_random_u32_inclusive() when possible
2022-11-17 · "Jason A. Donenfeld" <Jason@zx2c4.com> -
STALE1350d
REVIEWED: 19 (19M) [PATCH v3 1/3] treewide: use get_random_u32_below() instead of deprecated function
2022-11-17 · "Jason A. Donenfeld" <Jason@zx2c4.com> -
STALE1350d
REVIEWED: 19 (19M) [PATCH v2 3/3] treewide: use get_random_u32_between() when possible
2022-11-14 · "Jason A. Donenfeld" <Jason@zx2c4.com> -
STALE1350d
REVIEWED: 19 (19M) [PATCH v2 1/3] treewide: use get_random_u32_below() instead of deprecated function
2022-11-14 · "Jason A. Donenfeld" <Jason@zx2c4.com> -
STALE1352d
[PATCH v1 5/5] treewide: use get_random_u32_between() when possible
2022-10-22 · "Jason A. Donenfeld" <Jason@zx2c4.com> -
STALE1352d
[PATCH v1 1/5] treewide: use get_random_u32_below() instead of deprecated function
2022-10-22 · "Jason A. Donenfeld" <Jason@zx2c4.com> -
STALE1273d
[PATCH 1/9] fs: rename alloc_anon_inode to alloc_anon_inode_sb
2021-03-09 · Christoph Hellwig <hch@lst.de> -
STALE2830d
[PATCH v2 05/17] compat_ioctl: move more drivers to generic_compat_ioctl_ptrarg
2018-09-12 · Arnd Bergmann <arnd@arndb.de>