[PATCH] powerpc/64: Drop unnecessary 'rc' variable

Subsystems: linux for powerpc (32-bit and 64-bit), the rest

STALE341d

3 messages, 3 authors, 2025-08-28 · open the first message on its own page

[PATCH] powerpc/64: Drop unnecessary 'rc' variable

From: Xichao Zhao <hidden>
Date: 2025-08-01 03:59:23

Simplify the code to enhance readability and maintain a consistent 
coding style.


Signed-off-by: Xichao Zhao <redacted>
---
 arch/powerpc/kernel/setup_64.c | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/arch/powerpc/kernel/setup_64.c b/arch/powerpc/kernel/setup_64.c
index 7284c8021eeb..8fd7cbf3bd04 100644
--- a/arch/powerpc/kernel/setup_64.c
+++ b/arch/powerpc/kernel/setup_64.c
@@ -141,10 +141,7 @@ void __init check_smt_enabled(void)
 			smt_enabled_at_boot = 0;
 		else {
 			int smt;
-			int rc;
-
-			rc = kstrtoint(smt_enabled_cmdline, 10, &smt);
-			if (!rc)
+			if (!kstrtoint(smt_enabled_cmdline, 10, &smt))
 				smt_enabled_at_boot =
 					min(threads_per_core, smt);
 		}
-- 
2.34.1

Re: [PATCH] powerpc/64: Drop unnecessary 'rc' variable

From: Gautam Menghani <hidden>
Date: 2025-08-04 09:56:10

On Fri, Aug 01, 2025 at 11:59:08AM +0800, Xichao Zhao wrote:
quoted hunk
Simplify the code to enhance readability and maintain a consistent 
coding style.


Signed-off-by: Xichao Zhao <redacted>
---
 arch/powerpc/kernel/setup_64.c | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/arch/powerpc/kernel/setup_64.c b/arch/powerpc/kernel/setup_64.c
index 7284c8021eeb..8fd7cbf3bd04 100644
--- a/arch/powerpc/kernel/setup_64.c
+++ b/arch/powerpc/kernel/setup_64.c
@@ -141,10 +141,7 @@ void __init check_smt_enabled(void)
 			smt_enabled_at_boot = 0;
 		else {
 			int smt;
-			int rc;
-
-			rc = kstrtoint(smt_enabled_cmdline, 10, &smt);
-			if (!rc)
+			if (!kstrtoint(smt_enabled_cmdline, 10, &smt))
 				smt_enabled_at_boot =
 					min(threads_per_core, smt);
 		}

Thanks for the cleanup

Acked-by: Gautam Menghani <redacted>

Thanks,
Gautam

Re: [PATCH] powerpc/64: Drop unnecessary 'rc' variable

From: Madhavan Srinivasan <maddy@linux.ibm.com>
Date: 2025-08-28 06:33:29

On Fri, 01 Aug 2025 11:59:08 +0800, Xichao Zhao wrote:
Simplify the code to enhance readability and maintain a consistent
coding style.
Applied to powerpc/fixes.

[1/1] powerpc/64: Drop unnecessary 'rc' variable
      https://git.kernel.org/powerpc/c/8b5d86a63bc9510e094a15d7268c60bd4347b95c

Thanks
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help