[PATCH] powerpc/kvm: fix repeated words in comments Delete the redundant word 'that'.

Subsystems: kernel virtual machine for powerpc (kvm/powerpc), linux for powerpc (32-bit and 64-bit), the rest

STALE1504d

4 messages, 3 authors, 2022-07-25 · open the first message on its own page

[PATCH] powerpc/kvm: fix repeated words in comments Delete the redundant word 'that'.

From: wangjianli <hidden>
Date: 2022-07-24 06:29:46

Signed-off-by: wangjianli <redacted>
---
 arch/powerpc/kvm/book3s_64_mmu_hv.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/powerpc/kvm/book3s_64_mmu_hv.c b/arch/powerpc/kvm/book3s_64_mmu_hv.c
index 514fd45c1994..73c6db20cd8a 100644
--- a/arch/powerpc/kvm/book3s_64_mmu_hv.c
+++ b/arch/powerpc/kvm/book3s_64_mmu_hv.c
@@ -1601,7 +1601,7 @@ long kvm_vm_ioctl_resize_hpt_commit(struct kvm *kvm,
  * is valid, it is written to the HPT as if an H_ENTER with the
  * exact flag set was done.  When the invalid count is non-zero
  * in the header written to the stream, the kernel will make
- * sure that that many HPTEs are invalid, and invalidate them
+ * sure that many HPTEs are invalid, and invalidate them
  * if not.
  */
 
-- 
2.36.1

Re: [PATCH] powerpc/kvm: fix repeated words in comments Delete the redundant word 'that'.

From: Michael Ellerman <mpe@ellerman.id.au>
Date: 2022-07-25 06:51:31

wangjianli [off-list ref] writes:
quoted hunk
Signed-off-by: wangjianli <redacted>
---
 arch/powerpc/kvm/book3s_64_mmu_hv.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/powerpc/kvm/book3s_64_mmu_hv.c b/arch/powerpc/kvm/book3s_64_mmu_hv.c
index 514fd45c1994..73c6db20cd8a 100644
--- a/arch/powerpc/kvm/book3s_64_mmu_hv.c
+++ b/arch/powerpc/kvm/book3s_64_mmu_hv.c
@@ -1601,7 +1601,7 @@ long kvm_vm_ioctl_resize_hpt_commit(struct kvm *kvm,
  * is valid, it is written to the HPT as if an H_ENTER with the
  * exact flag set was done.  When the invalid count is non-zero
  * in the header written to the stream, the kernel will make
- * sure that that many HPTEs are invalid, and invalidate them
+ * sure that many HPTEs are invalid, and invalidate them
  * if not.
The existing wording is correct:

 "the kernel will make sure that ... that many HPTEs are invalid"

cheers

Re: [PATCH] powerpc/kvm: fix repeated words in comments Delete the redundant word 'that'.

From: Julia Lawall <julia.lawall@inria.fr>
Date: 2022-07-25 07:14:51


On Mon, 25 Jul 2022, Michael Ellerman wrote:
wangjianli [off-list ref] writes:
quoted
Signed-off-by: wangjianli <redacted>
---
 arch/powerpc/kvm/book3s_64_mmu_hv.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/powerpc/kvm/book3s_64_mmu_hv.c b/arch/powerpc/kvm/book3s_64_mmu_hv.c
index 514fd45c1994..73c6db20cd8a 100644
--- a/arch/powerpc/kvm/book3s_64_mmu_hv.c
+++ b/arch/powerpc/kvm/book3s_64_mmu_hv.c
@@ -1601,7 +1601,7 @@ long kvm_vm_ioctl_resize_hpt_commit(struct kvm *kvm,
  * is valid, it is written to the HPT as if an H_ENTER with the
  * exact flag set was done.  When the invalid count is non-zero
  * in the header written to the stream, the kernel will make
- * sure that that many HPTEs are invalid, and invalidate them
+ * sure that many HPTEs are invalid, and invalidate them
  * if not.
The existing wording is correct:

 "the kernel will make sure that ... that many HPTEs are invalid"
Maybe it would be better as "that the number of invalid HPTEs is the same
as the invalid count"?

julia

Re: [PATCH] powerpc/kvm: fix repeated words in comments Delete the redundant word 'that'.

From: Michael Ellerman <mpe@ellerman.id.au>
Date: 2022-07-25 10:35:53

Julia Lawall [off-list ref] writes:
On Mon, 25 Jul 2022, Michael Ellerman wrote:
quoted
wangjianli [off-list ref] writes:
quoted
diff --git a/arch/powerpc/kvm/book3s_64_mmu_hv.c b/arch/powerpc/kvm/book3s_64_mmu_hv.c
index 514fd45c1994..73c6db20cd8a 100644
--- a/arch/powerpc/kvm/book3s_64_mmu_hv.c
+++ b/arch/powerpc/kvm/book3s_64_mmu_hv.c
@@ -1601,7 +1601,7 @@ long kvm_vm_ioctl_resize_hpt_commit(struct kvm *kvm,
  * is valid, it is written to the HPT as if an H_ENTER with the
  * exact flag set was done.  When the invalid count is non-zero
  * in the header written to the stream, the kernel will make
- * sure that that many HPTEs are invalid, and invalidate them
+ * sure that many HPTEs are invalid, and invalidate them
  * if not.
The existing wording is correct:

 "the kernel will make sure that ... that many HPTEs are invalid"
Maybe it would be better as "that the number of invalid HPTEs is the same
as the invalid count"?
That doesn't read quite right, I think because if the number of invalid
HPTEs doesn't match the invalid count, the code will invalidate HPTEs so
that the number matches.

So maybe:

  When the invalid count is non-zero in the header written to the stream,
  the kernel will make sure that number of HPTEs are invalid, or
  invalidate them if not.

cheers
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help