From: Wan Jiabing <hidden> Date: 2021-10-20 09:46:52
Fix following coccicheck warning:
./drivers/pci/hotplug/pnv_php.c:161:2-13: ERROR: probable double put.
Device node iterators put the previous value of the index variable, so
an explicit put causes a double put.
Signed-off-by: Wan Jiabing <redacted>
---
drivers/pci/hotplug/pnv_php.c | 1 -
1 file changed, 1 deletion(-)
Fix following coccicheck warning:
./drivers/pci/hotplug/pnv_php.c:161:2-13: ERROR: probable double put.
Device node iterators put the previous value of the index variable, so
an explicit put causes a double put.
I suppose Coccinelle doesn't take into account that this code is
detaching and freeing the nodes.
The code might be improved by comments explaining how the bare
of_node_put() corresponds to a "get" somewhere else in the driver, and
how it doesn't render the ongoing traversal unsafe. It looks suspicious
on first review, but I believe it's intentional and probably correct as
written.
Fix following coccicheck warning:
./drivers/pci/hotplug/pnv_php.c:161:2-13: ERROR: probable double put.
Device node iterators put the previous value of the index variable, so
an explicit put causes a double put.
Signed-off-by: Wan Jiabing <redacted>
NACK
This is a false positive from coccicheck. This is a case were a node is being
dynamically removed and the long reference needs to be dropped. Otherwise, the
reference count doesn't go to zero and trigger cleanup. This would result in us
ending up in a leaked device node.
-Tyrel
Fix following coccicheck warning:
./drivers/pci/hotplug/pnv_php.c:161:2-13: ERROR: probable double put.
Device node iterators put the previous value of the index variable, so
an explicit put causes a double put.
I suppose Coccinelle doesn't take into account that this code is
detaching and freeing the nodes.
The code might be improved by comments explaining how the bare
of_node_put() corresponds to a "get" somewhere else in the driver, and
how it doesn't render the ongoing traversal unsafe. It looks suspicious
on first review, but I believe it's intentional and probably correct as
written.
This is a common usage pattern which if we put a comment about the pattern here
we need to do it every where. I suppose a better solution is to wrap this put in
a more descriptive function name like of_node_long_put() or something of the
sort the makes it obvious we are dropping a long held global scope reference.
-Tyrel