[PATCH v2] lib/zlib_inflate/inffast: Check config in C to avoid unused function warning

Subsystems: library code, the rest

STALE1814d

3 messages, 2 authors, 2021-09-20 · open the first message on its own page

[PATCH v2] lib/zlib_inflate/inffast: Check config in C to avoid unused function warning

From: Paul Menzel <hidden>
Date: 2021-09-20 07:47:27

Building Linux for ppc64le with Ubuntu clang version 12.0.0-3ubuntu1~21.04.1
shows the warning below.

    arch/powerpc/boot/inffast.c:20:1: warning: unused function 'get_unaligned16' [-Wunused-function]
    get_unaligned16(const unsigned short *p)
    ^
    1 warning generated.

Fix it, by moving the check from the preprocessor to C, so the compiler
sees the use.

Signed-off-by: Paul Menzel <redacted>
---
 lib/zlib_inflate/inffast.c | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)
diff --git a/lib/zlib_inflate/inffast.c b/lib/zlib_inflate/inffast.c
index f19c4fbe1be7..fb87a3120f0f 100644
--- a/lib/zlib_inflate/inffast.c
+++ b/lib/zlib_inflate/inffast.c
@@ -254,11 +254,8 @@ void inflate_fast(z_streamp strm, unsigned start)
 			sfrom = (unsigned short *)(from);
 			loops = len >> 1;
 			do
-#ifdef CONFIG_HAVE_EFFICIENT_UNALIGNED_ACCESS
-			    *sout++ = *sfrom++;
-#else
-			    *sout++ = get_unaligned16(sfrom++);
-#endif
+			    *sout++ = IS_ENABLED(CONFIG_HAVE_EFFICIENT_UNALIGNED_ACCESS) ?
+				*sfrom++ : get_unaligned16(sfrom++);
 			while (--loops);
 			out = (unsigned char *)sout;
 			from = (unsigned char *)sfrom;
-- 
2.33.0

Re: [PATCH v2] lib/zlib_inflate/inffast: Check config in C to avoid unused function warning

From: Christophe Leroy <hidden>
Date: 2021-09-20 08:36:59


Le 20/09/2021 à 09:46, Paul Menzel a écrit :
quoted hunk
Building Linux for ppc64le with Ubuntu clang version 12.0.0-3ubuntu1~21.04.1
shows the warning below.

     arch/powerpc/boot/inffast.c:20:1: warning: unused function 'get_unaligned16' [-Wunused-function]
     get_unaligned16(const unsigned short *p)
     ^
     1 warning generated.

Fix it, by moving the check from the preprocessor to C, so the compiler
sees the use.

Signed-off-by: Paul Menzel <redacted>
---
  lib/zlib_inflate/inffast.c | 7 ++-----
  1 file changed, 2 insertions(+), 5 deletions(-)
diff --git a/lib/zlib_inflate/inffast.c b/lib/zlib_inflate/inffast.c
index f19c4fbe1be7..fb87a3120f0f 100644
--- a/lib/zlib_inflate/inffast.c
+++ b/lib/zlib_inflate/inffast.c
@@ -254,11 +254,8 @@ void inflate_fast(z_streamp strm, unsigned start)
  			sfrom = (unsigned short *)(from);
  			loops = len >> 1;
  			do
-#ifdef CONFIG_HAVE_EFFICIENT_UNALIGNED_ACCESS
-			    *sout++ = *sfrom++;
-#else
-			    *sout++ = get_unaligned16(sfrom++);
-#endif
+			    *sout++ = IS_ENABLED(CONFIG_HAVE_EFFICIENT_UNALIGNED_ACCESS) ?
+				*sfrom++ : get_unaligned16(sfrom++);
I think it would be more readable as

do {
         if (IS_ENABLED(CONFIG_HAVE_EFFICIENT_UNALIGNED_ACCESS))
                 *sout++ = *sfrom++;
         else
                 *sout++ = get_unaligned16(sfrom++);
} while (--loops);


  			while (--loops);
  			out = (unsigned char *)sout;
  			from = (unsigned char *)sfrom;

Re: [PATCH v2] lib/zlib_inflate/inffast: Check config in C to avoid unused function warning

From: Paul Menzel <hidden>
Date: 2021-09-20 08:47:33

Dear Christophe,


Thank you for the review.

Am 20.09.21 um 10:36 schrieb Christophe Leroy:

Le 20/09/2021 à 09:46, Paul Menzel a écrit :
quoted
Building Linux for ppc64le with Ubuntu clang version 12.0.0-3ubuntu1~21.04.1
shows the warning below.

     arch/powerpc/boot/inffast.c:20:1: warning: unused function 'get_unaligned16' [-Wunused-function]
     get_unaligned16(const unsigned short *p)
     ^
     1 warning generated.

Fix it, by moving the check from the preprocessor to C, so the compiler
sees the use.

Signed-off-by: Paul Menzel <redacted>
---
  lib/zlib_inflate/inffast.c | 7 ++-----
  1 file changed, 2 insertions(+), 5 deletions(-)
diff --git a/lib/zlib_inflate/inffast.c b/lib/zlib_inflate/inffast.c
index f19c4fbe1be7..fb87a3120f0f 100644
--- a/lib/zlib_inflate/inffast.c
+++ b/lib/zlib_inflate/inffast.c
@@ -254,11 +254,8 @@ void inflate_fast(z_streamp strm, unsigned start)
              sfrom = (unsigned short *)(from);
              loops = len >> 1;
              do
-#ifdef CONFIG_HAVE_EFFICIENT_UNALIGNED_ACCESS
-                *sout++ = *sfrom++;
-#else
-                *sout++ = get_unaligned16(sfrom++);
-#endif
+                *sout++ = 
IS_ENABLED(CONFIG_HAVE_EFFICIENT_UNALIGNED_ACCESS) ?
+                *sfrom++ : get_unaligned16(sfrom++);
I think it would be more readable as

do {
         if (IS_ENABLED(CONFIG_HAVE_EFFICIENT_UNALIGNED_ACCESS))
                 *sout++ = *sfrom++;
         else
                 *sout++ = get_unaligned16(sfrom++);
} while (--loops);
I prefer the ternary operator, as it’s less lines, and it’s clear, that 
only the variable assignment is affected by the condition. But as style 
is subjective, I sent v3.
quoted
              while (--loops);
              out = (unsigned char *)sout;
              from = (unsigned char *)sfrom;

Kind regards,

Paul
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help