# Re: \[PATCH v2 03/12\] x86/sev: Add an x86 version of prot\_guest\_has()

- From: Borislav Petkov \<bp@alien8.de\>
- Date: 2021-08-19 17:26:00 
- List: linuxppc-dev
- Page: https://ratatoskr.run/linuxppc-dev/2021/08/212796
- Thread: https://ratatoskr.run/linuxppc-dev/2021/08/212359/t.md

```text
On Thu, Aug 19, 2021 at 10:52:53AM +0100, Christoph Hellwig wrote:
> Which suggest that the name is not good to start with.  Maybe protected
> hardware, system or platform might be a better choice?

Yah, coming up with a proper name here hasn't been easy.
prot_guest_has() is not the first variant.

From all three things you suggest above, I guess calling it a "platform"
is the closest. As in, this is a confidential computing platform which
provides host and guest facilities etc.

So calling it

confidential_computing_platform_has()

is obviously too long.

ccp_has() clashes with the namespace of drivers/crypto/ccp/ which is
used by the technology too.

coco_platform_has() is too unserious.

So I guess

cc_platform_has()

ain't all that bad.

Unless you have a better idea, ofc.

-- 
Regards/Gruss,
    Boris.

https://people.kernel.org/tglx/notes-about-netiquette
```
