As well known, hvc backend can register its opertions to hvc backend.
the opertions contain put_chars(), get_chars() and so on.
Some hvc backend may do dma in its opertions. eg, put_chars() of
virtio-console. But in the code of hvc framework, it may pass DMA
incapable memory to put_chars() under a specific configuration, which
is explained in commit c4baad5029(virtio-console: avoid DMA from stack):
1, c[] is on stack,
hvc_console_print():
char c[N_OUTBUF] __ALIGNED__;
cons_ops[index]->put_chars(vtermnos[index], c, i);
2, ch is on stack,
static void hvc_poll_put_char(,,char ch)
{
struct tty_struct *tty = driver->ttys[0];
struct hvc_struct *hp = tty->driver_data;
int n;
do {
n = hp->ops->put_chars(hp->vtermno, &ch, 1);
} while (n <= 0);
}
Commit c4baad5029 is just the fix to avoid DMA from stack memory, which
is passed to virtio-console by hvc framework in above code. But I think
the fix is aggressive, it directly uses kmemdup() to alloc new buffer
from kmalloc area and do memcpy no matter the memory is in kmalloc area
or not. But most importantly, it should better be fixed in the hvc
framework, by changing it to never pass stack memory to the put_chars()
function in the first place. Otherwise, we still face the same issue if
a new hvc backend using dma added in the furture.
Considering lock competition of hp->outbuf, we created a new buffer
hp->hvc_con_outbuf, which is aligned at least to N_OUTBUF, and use it
in above two cases.
With the patch, we can remove the fix c4baad5029.
Signed-off-by: Xianting Tian <redacted>
Tested-by: Xianting Tian <redacted>
---
drivers/tty/hvc/hvc_console.c | 30 ++++++++++++++++++++++++++++--
drivers/tty/hvc/hvc_console.h | 2 ++
2 files changed, 30 insertions(+), 2 deletions(-)
@@ -933,6 +949,16 @@ struct hvc_struct *hvc_alloc(uint32_t vtermno, int data, hp->outbuf_size = outbuf_size; hp->outbuf = &((char *)hp)[ALIGN(sizeof(*hp), sizeof(long))];+ /*+ * hvc_con_outbuf is guaranteed to be aligned at least to the+ * size(N_OUTBUF) by kmalloc().+ */+ hp->hvc_con_outbuf = kzalloc(N_OUTBUF, GFP_KERNEL);+ if (!hp->hvc_con_outbuf)+ return ERR_PTR(-ENOMEM);
This leaks hp, right?
BTW your 2 patches are still not threaded, that is hard to follow.
int data,
hp->outbuf_size = outbuf_size;
hp->outbuf = &((char *)hp)[ALIGN(sizeof(*hp), sizeof(long))];
This deserves cleanup too. Why is "outbuf" not "char outbuf[0]
__ALIGNED__" at the end of the structure? The allocation would be easier
(using struct_size()) and this line would be gone completely.
quoted
+ /*
+ * hvc_con_outbuf is guaranteed to be aligned at least to the
+ * size(N_OUTBUF) by kmalloc().
+ */
+ hp->hvc_con_outbuf = kzalloc(N_OUTBUF, GFP_KERNEL);
+ if (!hp->hvc_con_outbuf)
+ return ERR_PTR(-ENOMEM);
This leaks hp, right?
Actually, why don't you make
char c[N_OUTBUF] __ALIGNED__;
part of struct hvc_struct directly?
BTW your 2 patches are still not threaded, that is hard to follow.
int data,
hp->outbuf_size = outbuf_size;
hp->outbuf = &((char *)hp)[ALIGN(sizeof(*hp), sizeof(long))];
+ /*
+ * hvc_con_outbuf is guaranteed to be aligned at least to the
+ * size(N_OUTBUF) by kmalloc().
+ */
+ hp->hvc_con_outbuf = kzalloc(N_OUTBUF, GFP_KERNEL);
+ if (!hp->hvc_con_outbuf)
+ return ERR_PTR(-ENOMEM);
This leaks hp, right?
BTW your 2 patches are still not threaded, that is hard to follow.
yes, thanks, I found the bug, I am preparing to do this in v4.
It is the first time I send series patches(number >1), I checked the method
for sending series patch on LKML.org, I should send '0/2' which is the
history info for series patches.
Please use 'git send-email' to send the full series all at once,
otherwise it is hard to make the emails threaded "by hand" if you do not
do so.
thanks,
greg k-h
int data,
hp->outbuf_size = outbuf_size;
hp->outbuf = &((char *)hp)[ALIGN(sizeof(*hp), sizeof(long))];
+ /*
+ * hvc_con_outbuf is guaranteed to be aligned at least to the
+ * size(N_OUTBUF) by kmalloc().
+ */
+ hp->hvc_con_outbuf = kzalloc(N_OUTBUF, GFP_KERNEL);
+ if (!hp->hvc_con_outbuf)
+ return ERR_PTR(-ENOMEM);
This leaks hp, right?
BTW your 2 patches are still not threaded, that is hard to follow.
yes, thanks, I found the bug, I am preparing to do this in v4.
It is the first time I send series patches(number >1), I checked the
method for sending series patch on LKML.org, I should send '0/2' which
is the history info for series patches.
I will add 0/2 in v4, sorry again for this:(
beside avove things, the solution in this patch is for you? thanks
int data,
hp->outbuf_size = outbuf_size;
hp->outbuf = &((char *)hp)[ALIGN(sizeof(*hp), sizeof(long))];
+ /*
+ * hvc_con_outbuf is guaranteed to be aligned at least to the
+ * size(N_OUTBUF) by kmalloc().
+ */
+ hp->hvc_con_outbuf = kzalloc(N_OUTBUF, GFP_KERNEL);
+ if (!hp->hvc_con_outbuf)
+ return ERR_PTR(-ENOMEM);
This leaks hp, right?
BTW your 2 patches are still not threaded, that is hard to follow.
yes, thanks, I found the bug, I am preparing to do this in v4.
It is the first time I send series patches(number >1), I checked the method
for sending series patch on LKML.org, I should send '0/2' which is the
history info for series patches.
Please use 'git send-email' to send the full series all at once,
otherwise it is hard to make the emails threaded "by hand" if you do not
do so.
int data,
hp->outbuf_size = outbuf_size;
hp->outbuf = &((char *)hp)[ALIGN(sizeof(*hp), sizeof(long))];
This deserves cleanup too. Why is "outbuf" not "char outbuf[0]
__ALIGNED__" at the end of the structure? The allocation would be
easier (using struct_size()) and this line would be gone completely.
I will make the cleanup in v4.
quoted
quoted
+ /*
+ * hvc_con_outbuf is guaranteed to be aligned at least to the
+ * size(N_OUTBUF) by kmalloc().
+ */
+ hp->hvc_con_outbuf = kzalloc(N_OUTBUF, GFP_KERNEL);
+ if (!hp->hvc_con_outbuf)
+ return ERR_PTR(-ENOMEM);
This leaks hp, right?
Actually, why don't you make
char c[N_OUTBUF] __ALIGNED__;
part of struct hvc_struct directly?
thanks, it a good idea, I will change it in v4.
quoted
BTW your 2 patches are still not threaded, that is hard to follow.