# \[PATCH 00/16\] Rid W=1 warnings from Char

- Subsystems: AGPGART DRIVER, CHAR and MISC DRIVERS, HARDWARE RANDOM NUMBER GENERATOR CORE, HPET: High Precision Event Timers driver, RANDOM NUMBER DRIVER, THE REST, TPM DEVICE DRIVER
- Maintainers: David Airlie, Arnd Bergmann, Greg Kroah-Hartman, Olivia Mackall, Herbert Xu, Clemens Ladisch, "Theodore Ts'o", Jason A. Donenfeld, Linus Torvalds, Peter Huewe, Jarkko Sakkinen
- Series: 16 patches touching 15 files, +61/-64
- Status: PENDING · 4 of 16 landed
- Pending, 4 of 16 landed.
- List: linuxppc-dev
- 7 messages, 3 authors
- Page: https://ratatoskr.run/linuxppc-dev/2021/05/1386044/t

## \[PATCH 00/16\] Rid W=1 warnings from Char

- From: Lee Jones \<hidden\>
- Date: 2021-05-20 12:50:13 
- Message: https://ratatoskr.run/linuxppc-dev/2021/05/1386044.md

```text
This set is part of a larger effort attempting to clean-up W=1
kernel builds, which are currently overwhelmingly riddled with
niggly little warnings.

Lee Jones (16):
  char: pcmcia: cm4000_cs: Remove unused variable 'tmp'
  char: pcmcia: cm4040_cs: Remove unused variable 'uc'
  char: random: Include header containing our prototypes
  char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues
  char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues
  char: applicom: Remove 3 unused variables 'ret' and 2 instances of
    'byte_reset_it'
  char: tpm: tpm1-cmd: Fix a couple of misnamed functions
  char: tpm: tpm_ftpm_tee: Fix a couple of kernel-doc misdemeanours
  char: agp: backend: Demote some non-conformant kernel-doc headers
  char: agp: frontend: Include header file containing our prototypes
  char: agp: via-agp: Remove unused variable 'current_size'
  char: hpet: Remove unused variable 'm'
  char: agp: generic: Place braces around optimised out function in if()
  char: agp: uninorth-agp: Remove unused variable 'size'
  char: hw_random: pseries-rng: Demote non-conformant kernel-doc header
  char: mem: Provide local prototype for non-static function

 drivers/char/agp/backend.c           |  4 +-
 drivers/char/agp/frontend.c          |  1 +
 drivers/char/agp/generic.c           |  3 +-
 drivers/char/agp/uninorth-agp.c      |  3 --
 drivers/char/agp/via-agp.c           |  3 --
 drivers/char/applicom.c              | 10 ++--
 drivers/char/hpet.c                  |  4 +-
 drivers/char/hw_random/pseries-rng.c |  2 +-
 drivers/char/mem.c                   |  2 +
 drivers/char/pcmcia/cm4000_cs.c      |  3 +-
 drivers/char/pcmcia/cm4040_cs.c      |  3 +-
 drivers/char/pcmcia/synclink_cs.c    | 74 +++++++++++++++-------------
 drivers/char/random.c                |  1 +
 drivers/char/tpm/tpm1-cmd.c          |  4 +-
 drivers/char/tpm/tpm_ftpm_tee.c      |  6 +--
 15 files changed, 60 insertions(+), 63 deletions(-)

Cc: Arnd Bergmann <arnd@arndb.de>
Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org>
Cc: Bob Picco <redacted>
Cc: Clemens Ladisch <clemens@ladisch.de>
Cc: "C. Scott Ananian" <redacted>
Cc: "cs.c" <redacted>
Cc: Dave Safford <redacted>
Cc: David Airlie <redacted>
Cc: dwmw2@infradead.org
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: Harald Welte <laforge@gnumonks.org>
Cc: Herbert Xu <herbert@gondor.apana.org.au>
Cc: Jarkko Sakkinen <jarkko@kernel.org>
Cc: "Jason A. Donenfeld" <Jason@zx2c4.com>
Cc: Jason Gunthorpe <jgg@ziepe.ca>
Cc: Jerome Glisse <redacted>
Cc: Kanoj Sarcar <redacted>
Cc: Kylene Hall <redacted>
Cc: Lee Jones <redacted>
Cc: Lijun Pan <redacted>
Cc: <redacted>
Cc: <redacted>
Cc: <redacted>
Cc: Matt Mackall <redacted>
Cc: Michael Ellerman <mpe@ellerman.id.au>
Cc: Michael Neuling <redacted>
Cc: <redacted>
Cc: Paul Mackerras <redacted>
Cc: Peter Huewe <peterhuewe@gmx.de>
Cc: Reiner Sailer <redacted>
Cc: "Theodore Ts'o" <tytso@mit.edu>
Cc: Thirupathaiah Annapureddy <redacted>
Cc: Tyrel Datwyler <tyreld@linux.ibm.com>
Cc: "Uwe Kleine-König" <redacted>
Cc: van Doorn <redacted>
-- 
2.31.1

```

## \[PATCH 15/16\] char: hw\_random: pseries-rng: Demote non-conformant kernel-doc header

- From: Lee Jones \<hidden\>
- Date: 2021-05-20 12:51:45 
- Message: https://ratatoskr.run/linuxppc-dev/2021/05/1386060.md

```text
Fixes the following W=1 kernel build warning(s):

 drivers/char/hw_random/pseries-rng.c:42: warning: Function parameter or member 'vdev' not described in 'pseries_rng_get_desired_dma'

Cc: Matt Mackall <redacted>
Cc: Herbert Xu <herbert@gondor.apana.org.au>
Cc: Michael Ellerman <mpe@ellerman.id.au>
Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org>
Cc: Paul Mackerras <redacted>
Cc: Lijun Pan <redacted>
Cc: "Uwe Kleine-König" <redacted>
Cc: Tyrel Datwyler <tyreld@linux.ibm.com>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: Michael Neuling <redacted>
Cc: <redacted>
Cc: <redacted>
Signed-off-by: Lee Jones <redacted>
---
 drivers/char/hw_random/pseries-rng.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/char/hw_random/pseries-rng.c b/drivers/char/hw_random/pseries-rng.c
index f4949b689bd5a..62bdd5af1339f 100644
--- a/drivers/char/hw_random/pseries-rng.c
+++ b/drivers/char/hw_random/pseries-rng.c
@@ -29,7 +29,7 @@ static int pseries_rng_read(struct hwrng *rng, void *data, size_t max, bool wait
 	return 8;
 }
 
-/**
+/*
  * pseries_rng_get_desired_dma - Return desired DMA allocate for CMO operations
  *
  * This is a required function for a driver to operate in a CMO environment
-- 
2.31.1

```

## Re: \[PATCH 00/16\] Rid W=1 warnings from Char

- From: Arnd Bergmann \<arnd@arndb.de\>
- Date: 2021-05-20 12:59:18 
- Message: https://ratatoskr.run/linuxppc-dev/2021/05/1386086.md

```text
On Thu, May 20, 2021 at 2:13 PM Lee Jones [ref] wrote:
>
> This set is part of a larger effort attempting to clean-up W=1
> kernel builds, which are currently overwhelmingly riddled with
> niggly little warnings.
>
> Lee Jones (16):
>   char: pcmcia: cm4000_cs: Remove unused variable 'tmp'
>   char: pcmcia: cm4040_cs: Remove unused variable 'uc'
>   char: random: Include header containing our prototypes
>   char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues
>   char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues
>   char: applicom: Remove 3 unused variables 'ret' and 2 instances of
>     'byte_reset_it'
>   char: tpm: tpm1-cmd: Fix a couple of misnamed functions
>   char: tpm: tpm_ftpm_tee: Fix a couple of kernel-doc misdemeanours
>   char: agp: backend: Demote some non-conformant kernel-doc headers
>   char: agp: frontend: Include header file containing our prototypes
>   char: agp: via-agp: Remove unused variable 'current_size'
>   char: hpet: Remove unused variable 'm'
>   char: agp: generic: Place braces around optimised out function in if()
>   char: agp: uninorth-agp: Remove unused variable 'size'
>   char: hw_random: pseries-rng: Demote non-conformant kernel-doc header
>   char: mem: Provide local prototype for non-static function

Thanks a lot!

I've looked all the patches now and commented on patches 6 and 16.
With my comments addressed

Reviewed-by: Arnd Bergmann <arnd@arndb.de>

       Arnd
```

## Re: \[PATCH 00/16\] Rid W=1 warnings from Char

- From: Lee Jones \<hidden\>
- Date: 2021-05-21 07:23:07 
- Message: https://ratatoskr.run/linuxppc-dev/2021/05/1387084.md

```text
On Thu, 20 May 2021, Arnd Bergmann wrote:

> On Thu, May 20, 2021 at 2:13 PM Lee Jones [ref] wrote:
> >
> > This set is part of a larger effort attempting to clean-up W=1
> > kernel builds, which are currently overwhelmingly riddled with
> > niggly little warnings.
> >
> > Lee Jones (16):
> >   char: pcmcia: cm4000_cs: Remove unused variable 'tmp'
> >   char: pcmcia: cm4040_cs: Remove unused variable 'uc'
> >   char: random: Include header containing our prototypes
> >   char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues
> >   char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues
> >   char: applicom: Remove 3 unused variables 'ret' and 2 instances of
> >     'byte_reset_it'
> >   char: tpm: tpm1-cmd: Fix a couple of misnamed functions
> >   char: tpm: tpm_ftpm_tee: Fix a couple of kernel-doc misdemeanours
> >   char: agp: backend: Demote some non-conformant kernel-doc headers
> >   char: agp: frontend: Include header file containing our prototypes
> >   char: agp: via-agp: Remove unused variable 'current_size'
> >   char: hpet: Remove unused variable 'm'
> >   char: agp: generic: Place braces around optimised out function in if()
> >   char: agp: uninorth-agp: Remove unused variable 'size'
> >   char: hw_random: pseries-rng: Demote non-conformant kernel-doc header
> >   char: mem: Provide local prototype for non-static function
> 
> Thanks a lot!
> 
> I've looked all the patches now and commented on patches 6 and 16.
> With my comments addressed
> 
> Reviewed-by: Arnd Bergmann <arnd@arndb.de>

Thanks Arnd.

Would it be possible for the remaining 14 patches to be taken in
please?  I will work on the 2 Arnd commented on in due course and
resubmit them independently.

TIA.

-- 
Lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog
```

## Re: \[PATCH 00/16\] Rid W=1 warnings from Char

- From: Greg Kroah-Hartman \<gregkh@linuxfoundation.org\>
- Date: 2021-05-21 07:42:35 
- Message: https://ratatoskr.run/linuxppc-dev/2021/05/1387101.md

```text
On Fri, May 21, 2021 at 08:22:36AM +0100, Lee Jones wrote:
> On Thu, 20 May 2021, Arnd Bergmann wrote:
> 
> > On Thu, May 20, 2021 at 2:13 PM Lee Jones [ref] wrote:
> > >
> > > This set is part of a larger effort attempting to clean-up W=1
> > > kernel builds, which are currently overwhelmingly riddled with
> > > niggly little warnings.
> > >
> > > Lee Jones (16):
> > >   char: pcmcia: cm4000_cs: Remove unused variable 'tmp'
> > >   char: pcmcia: cm4040_cs: Remove unused variable 'uc'
> > >   char: random: Include header containing our prototypes
> > >   char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues
> > >   char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues
> > >   char: applicom: Remove 3 unused variables 'ret' and 2 instances of
> > >     'byte_reset_it'
> > >   char: tpm: tpm1-cmd: Fix a couple of misnamed functions
> > >   char: tpm: tpm_ftpm_tee: Fix a couple of kernel-doc misdemeanours
> > >   char: agp: backend: Demote some non-conformant kernel-doc headers
> > >   char: agp: frontend: Include header file containing our prototypes
> > >   char: agp: via-agp: Remove unused variable 'current_size'
> > >   char: hpet: Remove unused variable 'm'
> > >   char: agp: generic: Place braces around optimised out function in if()
> > >   char: agp: uninorth-agp: Remove unused variable 'size'
> > >   char: hw_random: pseries-rng: Demote non-conformant kernel-doc header
> > >   char: mem: Provide local prototype for non-static function
> > 
> > Thanks a lot!
> > 
> > I've looked all the patches now and commented on patches 6 and 16.
> > With my comments addressed
> > 
> > Reviewed-by: Arnd Bergmann <arnd@arndb.de>
> 
> Thanks Arnd.
> 
> Would it be possible for the remaining 14 patches to be taken in
> please?  I will work on the 2 Arnd commented on in due course and
> resubmit them independently.

Yes, I can queue them up, thanks.

greg k-h
```

## Re: \[PATCH 00/16\] Rid W=1 warnings from Char

- From: Greg Kroah-Hartman \<gregkh@linuxfoundation.org\>
- Date: 2021-05-21 07:44:30 
- Message: https://ratatoskr.run/linuxppc-dev/2021/05/1387103.md

```text
On Fri, May 21, 2021 at 09:42:29AM +0200, Greg Kroah-Hartman wrote:
> On Fri, May 21, 2021 at 08:22:36AM +0100, Lee Jones wrote:
> > On Thu, 20 May 2021, Arnd Bergmann wrote:
> > 
> > > On Thu, May 20, 2021 at 2:13 PM Lee Jones [ref] wrote:
> > > >
> > > > This set is part of a larger effort attempting to clean-up W=1
> > > > kernel builds, which are currently overwhelmingly riddled with
> > > > niggly little warnings.
> > > >
> > > > Lee Jones (16):
> > > >   char: pcmcia: cm4000_cs: Remove unused variable 'tmp'
> > > >   char: pcmcia: cm4040_cs: Remove unused variable 'uc'
> > > >   char: random: Include header containing our prototypes
> > > >   char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues
> > > >   char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues
> > > >   char: applicom: Remove 3 unused variables 'ret' and 2 instances of
> > > >     'byte_reset_it'
> > > >   char: tpm: tpm1-cmd: Fix a couple of misnamed functions
> > > >   char: tpm: tpm_ftpm_tee: Fix a couple of kernel-doc misdemeanours
> > > >   char: agp: backend: Demote some non-conformant kernel-doc headers
> > > >   char: agp: frontend: Include header file containing our prototypes
> > > >   char: agp: via-agp: Remove unused variable 'current_size'
> > > >   char: hpet: Remove unused variable 'm'
> > > >   char: agp: generic: Place braces around optimised out function in if()
> > > >   char: agp: uninorth-agp: Remove unused variable 'size'
> > > >   char: hw_random: pseries-rng: Demote non-conformant kernel-doc header
> > > >   char: mem: Provide local prototype for non-static function
> > > 
> > > Thanks a lot!
> > > 
> > > I've looked all the patches now and commented on patches 6 and 16.
> > > With my comments addressed
> > > 
> > > Reviewed-by: Arnd Bergmann <arnd@arndb.de>
> > 
> > Thanks Arnd.
> > 
> > Would it be possible for the remaining 14 patches to be taken in
> > please?  I will work on the 2 Arnd commented on in due course and
> > resubmit them independently.
> 
> Yes, I can queue them up, thanks.

Wait, I can take the ones for code that I maintain, not for others.
drivers/char/ is "fun" in that some subdirs have active
trees/maintainers that are not me and Arnd so they go to Linus through
other ways.  I'll queue up the ones that I am "allowed" to and you will
get the emails from that.

thanks,

greg k-h
```

## Re: \[PATCH 00/16\] Rid W=1 warnings from Char

- From: Lee Jones \<hidden\>
- Date: 2021-05-21 07:56:44 
- Message: https://ratatoskr.run/linuxppc-dev/2021/05/1387115.md

```text
On Fri, 21 May 2021, Greg Kroah-Hartman wrote:

> On Fri, May 21, 2021 at 09:42:29AM +0200, Greg Kroah-Hartman wrote:
> > On Fri, May 21, 2021 at 08:22:36AM +0100, Lee Jones wrote:
> > > On Thu, 20 May 2021, Arnd Bergmann wrote:
> > > 
> > > > On Thu, May 20, 2021 at 2:13 PM Lee Jones [ref] wrote:
> > > > >
> > > > > This set is part of a larger effort attempting to clean-up W=1
> > > > > kernel builds, which are currently overwhelmingly riddled with
> > > > > niggly little warnings.
> > > > >
> > > > > Lee Jones (16):
> > > > >   char: pcmcia: cm4000_cs: Remove unused variable 'tmp'
> > > > >   char: pcmcia: cm4040_cs: Remove unused variable 'uc'
> > > > >   char: random: Include header containing our prototypes
> > > > >   char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues
> > > > >   char: pcmcia: synclink_cs: Fix a bunch of kernel-doc issues
> > > > >   char: applicom: Remove 3 unused variables 'ret' and 2 instances of
> > > > >     'byte_reset_it'
> > > > >   char: tpm: tpm1-cmd: Fix a couple of misnamed functions
> > > > >   char: tpm: tpm_ftpm_tee: Fix a couple of kernel-doc misdemeanours
> > > > >   char: agp: backend: Demote some non-conformant kernel-doc headers
> > > > >   char: agp: frontend: Include header file containing our prototypes
> > > > >   char: agp: via-agp: Remove unused variable 'current_size'
> > > > >   char: hpet: Remove unused variable 'm'
> > > > >   char: agp: generic: Place braces around optimised out function in if()
> > > > >   char: agp: uninorth-agp: Remove unused variable 'size'
> > > > >   char: hw_random: pseries-rng: Demote non-conformant kernel-doc header
> > > > >   char: mem: Provide local prototype for non-static function
> > > > 
> > > > Thanks a lot!
> > > > 
> > > > I've looked all the patches now and commented on patches 6 and 16.
> > > > With my comments addressed
> > > > 
> > > > Reviewed-by: Arnd Bergmann <arnd@arndb.de>
> > > 
> > > Thanks Arnd.
> > > 
> > > Would it be possible for the remaining 14 patches to be taken in
> > > please?  I will work on the 2 Arnd commented on in due course and
> > > resubmit them independently.
> > 
> > Yes, I can queue them up, thanks.
> 
> Wait, I can take the ones for code that I maintain, not for others.
> drivers/char/ is "fun" in that some subdirs have active
> trees/maintainers that are not me and Arnd so they go to Linus through
> other ways.  I'll queue up the ones that I am "allowed" to and you will
> get the emails from that.

Understood, thanks.

Hopefully the other maintainers will be as on the ball as you are.

-- 
Lee Jones [李琼斯]
Senior Technical Lead - Developer Services
Linaro.org │ Open source software for Arm SoCs
Follow Linaro: Facebook | Twitter | Blog
```
