[PATCH] powerpc/process: Enhance readability for trap types.

Subsystems: linux for powerpc (32-bit and 64-bit), the rest

STALE1984d

3 messages, 2 authors, 2021-03-28 · open the first message on its own page

[PATCH] powerpc/process: Enhance readability for trap types.

From: Xiongwei Song <hidden>
Date: 2021-03-28 14:42:19

From: Xiongwei Song <redacted>

Define macros to enhance the code readability on ppc trap types.

Signed-off-by: Xiongwei Song <redacted>
---
 arch/powerpc/kernel/process.c | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/arch/powerpc/kernel/process.c b/arch/powerpc/kernel/process.c
index 3231c2df9e26..3bbd3cf353a7 100644
--- a/arch/powerpc/kernel/process.c
+++ b/arch/powerpc/kernel/process.c
@@ -1451,6 +1451,10 @@ static void print_msr_bits(unsigned long val)
 #define LAST_VOLATILE	12
 #endif
 
+#define TRAP_MC  0x200 /* Machine Check */
+#define TRAP_DSI 0x300 /* DSI exception */
+#define TRAP_AM  0x600 /* Alignment exception */
+
 static void __show_regs(struct pt_regs *regs)
 {
 	int i, trap;
@@ -1465,7 +1469,7 @@ static void __show_regs(struct pt_regs *regs)
 	trap = TRAP(regs);
 	if (!trap_is_syscall(regs) && cpu_has_feature(CPU_FTR_CFAR))
 		pr_cont("CFAR: "REG" ", regs->orig_gpr3);
-	if (trap == 0x200 || trap == 0x300 || trap == 0x600) {
+	if (trap == TRAP_MC || trap == TRAP_DSI || trap == TRAP_AM) {
 		if (IS_ENABLED(CONFIG_4xx) || IS_ENABLED(CONFIG_BOOKE))
 			pr_cont("DEAR: "REG" ESR: "REG" ", regs->dar, regs->dsisr);
 		else
-- 
2.17.1

Re: [PATCH] powerpc/process: Enhance readability for trap types.

From: Christophe Leroy <hidden>
Date: 2021-03-28 15:23:12


Le 28/03/2021 à 16:35, Xiongwei Song a écrit :
From: Xiongwei Song <redacted>

Define macros to enhance the code readability on ppc trap types.
Good idea
quoted hunk
Signed-off-by: Xiongwei Song <redacted>
---
  arch/powerpc/kernel/process.c | 6 +++++-
  1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/arch/powerpc/kernel/process.c b/arch/powerpc/kernel/process.c
index 3231c2df9e26..3bbd3cf353a7 100644
--- a/arch/powerpc/kernel/process.c
+++ b/arch/powerpc/kernel/process.c
@@ -1451,6 +1451,10 @@ static void print_msr_bits(unsigned long val)
  #define LAST_VOLATILE	12
  #endif
  
+#define TRAP_MC  0x200 /* Machine Check */
I think usually we use MCE, so TRAP_MCE would be better
+#define TRAP_DSI 0x300 /* DSI exception */
+#define TRAP_AM  0x600 /* Alignment exception */
Don't know what AM means. TRAP_ALIGN would be more explicit.
+
The defines should go in a header file, for instance asm/ptrace.h in order to be re-used in other files.

You should do more. You can find other places to improve with:

git grep "trap ==" arch/powerpc/
git grep "TRAP(regs) ==" arch/powerpc/
quoted hunk
  static void __show_regs(struct pt_regs *regs)
  {
  	int i, trap;
@@ -1465,7 +1469,7 @@ static void __show_regs(struct pt_regs *regs)
  	trap = TRAP(regs);
  	if (!trap_is_syscall(regs) && cpu_has_feature(CPU_FTR_CFAR))
  		pr_cont("CFAR: "REG" ", regs->orig_gpr3);
-	if (trap == 0x200 || trap == 0x300 || trap == 0x600) {
+	if (trap == TRAP_MC || trap == TRAP_DSI || trap == TRAP_AM) {
  		if (IS_ENABLED(CONFIG_4xx) || IS_ENABLED(CONFIG_BOOKE))
  			pr_cont("DEAR: "REG" ESR: "REG" ", regs->dar, regs->dsisr);
  		else

Re: [PATCH] powerpc/process: Enhance readability for trap types.

From: Xiongwei Song <hidden>
Date: 2021-03-28 23:12:16

On Mar 28, 2021, at 11:21 PM, Christophe Leroy [off-list ref] wrote:



Le 28/03/2021 à 16:35, Xiongwei Song a écrit :
quoted
From: Xiongwei Song <redacted>
Define macros to enhance the code readability on ppc trap types.
Good idea
quoted
Signed-off-by: Xiongwei Song <redacted>
---
 arch/powerpc/kernel/process.c | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/arch/powerpc/kernel/process.c b/arch/powerpc/kernel/process.c
index 3231c2df9e26..3bbd3cf353a7 100644
--- a/arch/powerpc/kernel/process.c
+++ b/arch/powerpc/kernel/process.c
@@ -1451,6 +1451,10 @@ static void print_msr_bits(unsigned long val)
 #define LAST_VOLATILE	12
 #endif
 +#define TRAP_MC  0x200 /* Machine Check */
I think usually we use MCE, so TRAP_MCE would be better
Ok.
quoted
+#define TRAP_DSI 0x300 /* DSI exception */
+#define TRAP_AM  0x600 /* Alignment exception */
Don't know what AM means. TRAP_ALIGN would be more explicit.
No Problem.
quoted
+
The defines should go in a header file, for instance asm/ptrace.h in order to be re-used in other files.
Agree.
You should do more. You can find other places to improve with:

git grep "trap ==" arch/powerpc/
git grep "TRAP(regs) ==" arch/powerpc/
Just ran “git grep”, looks like the work is much bigger than what I imagined.
quoted
 static void __show_regs(struct pt_regs *regs)
 {
 	int i, trap;
@@ -1465,7 +1469,7 @@ static void __show_regs(struct pt_regs *regs)
 	trap = TRAP(regs);
 	if (!trap_is_syscall(regs) && cpu_has_feature(CPU_FTR_CFAR))
 		pr_cont("CFAR: "REG" ", regs->orig_gpr3);
-	if (trap == 0x200 || trap == 0x300 || trap == 0x600) {
+	if (trap == TRAP_MC || trap == TRAP_DSI || trap == TRAP_AM) {
 		if (IS_ENABLED(CONFIG_4xx) || IS_ENABLED(CONFIG_BOOKE))
 			pr_cont("DEAR: "REG" ESR: "REG" ", regs->dar, regs->dsisr);
 		else
Thanks for the response. I will send v2.

 Regards,
Xiongwei
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help