# Re: \[PATCH v10 04/12\] mm/ioremap: rename ioremap\_\*\_range to vmap\_\*\_range

- From: Christoph Hellwig \<hch@infradead.org\>
- Date: 2021-01-24 11:38:04 
- List: linuxppc-dev
- Page: https://ratatoskr.run/linuxppc-dev/2021/01/6245601
- Thread: https://ratatoskr.run/linux-mm/2021/01/6245555/t.md

```text
On Sun, Jan 24, 2021 at 06:22:22PM +1000, Nicholas Piggin wrote:
> This will be used as a generic kernel virtual mapping function, so
> re-name it in preparation.

The new name looks ok, but shouldn't it also move to vmalloc.c with
the more generic name and purpose?
```
