# Re: rename -\>make\_request\_fn and move it to the block\_device\_operations v2

- From: Jens Axboe \<axboe@kernel.dk\>
- Date: 2020-07-01 13:43:36 
- List: linuxppc-dev
- Page: https://ratatoskr.run/linuxppc-dev/2020/07/6021822
- Thread: https://ratatoskr.run/linuxppc-dev/2020/07/6021473/t.md

```text
On 7/1/20 2:59 AM, Christoph Hellwig wrote:
> Hi Jens,
> 
> this series moves the make_request_fn method into block_device_operations
> with the much more descriptive ->submit_bio name.  It then also gives
> generic_make_request a more descriptive name, and further optimize the
> path to issue to blk-mq, removing the need for the direct_make_request
> bypass.

Thanks, I'll try this again.

-- 
Jens Axboe

```
