Re: [PATCH V2 1/2] ASoC: fsl_asrc: replace the process_option table with function
From: S.j. Wang <hidden>
Date: 2019-04-17 09:04:08
Also in:
alsa-devel, lkml
Hi
On Thu, Apr 11, 2019 at 09:39:06AM +0000, S.j. Wang wrote:quoted
+/* + * Select the pre-processing and post-processing optionsBy aligning with other function comments: /** * Select the pre-processing and post-processing optionsquoted
+ * + * Fsin: input sample rate + * Fsout: output sample rateI would suggest to use inrate and outrate to keep naming consistent.quoted
+ * pre_proc: return value for pre-processing option + * post_proc: return value for post-processing option */ static int +fsl_asrc_sel_proc(int Fsin, int Fsout, int *pre_proc, int *post_proc) +{ + bool det_out_op2_cond; + bool det_out_op0_cond;By looking at the comments below. Probably better to rename them bool post_proc_cond2, post_proc_cond0;quoted
+ /* Codition for selection of post-processing */"Codition" -> "Conditions"quoted
+ det_out_op2_cond = (((Fsin * 15 > Fsout * 16) & (Fsout < 56000)) | + ((Fsin > 56000) & (Fsout < + 56000)));Combining Daniel's comments + indentation alignment: det_out_op2_cond = (Fsin * 15 > Fsout * 16 && Fsout < 56000) || (Fsin > 56000 && Fsout < 56000);quoted
+ det_out_op0_cond = (Fsin * 23 < Fsout * 8); + + /* + * unsupported case: Tsout>16.125*Tsin, and Tsout>8.125*Tsin.Funny thing is that there'd be no point in checking the 16.125, if Tsout is bigger than 8.125 times of Tsin, i.e. only one condition: Tsout > 8.125 * Tsinquoted
+ * Tsout>16.125*Tsin -> Fsin * 8 > 129 * Fsout + * Tsout>8.125*Tsin -> Fsin * 8 > 65 * Fsout + * Tsout>4.125*Tsin -> Fsin * 8 > 33 * Fsout + * Tsout>1.875*Tsin -> Fsin * 8 > 15 * FsoutTook me a while to understand what it is saying.... Better to write like this: /* Does not support cases: Tsout > 8.125 * Tsin */ if (Fsin * 8 > 65 * Fsout) { pair_err("Does not support %d > 8.125 * %d\n", Fsout, Fsin); return -EINVAL; } /* Otherwise, select pre_proc between [0, 2] */ if (Fsin * 8 > 33 * Fsout)quoted
+ *pre_proc = 2; + else if (Fsin * 8 > 15 * Fsout) { + if (Fsin > 152000) + *pre_proc = 2; + else + *pre_proc = 1; + } else if (Fsin < 76000) + *pre_proc = 0; + else if (Fsin > 152000) + *pre_proc = 2; + else + *pre_proc = 1;<== Would look better by moving post_cond calculations here.quoted
+ if (det_out_op2_cond) + *post_proc = 2; + else if (det_out_op0_cond) + *post_proc = 0; + else + *post_proc = 1;And we could remove this check below:quoted
+ /* unsupported options */ + if (*pre_proc == 4 || *pre_proc == 5) + return -EINVAL;So basically we are doing: 1) Error out unsupported cases 2) Select pre_proc 3) Calculate conditions for post_proc 4) Select post_proc Thanks
Thanks for reviewing, will send v3.