# Re: \[PATCH v3 3/5\] powerpc/mm: add radix\_\_create\_section\_mapping()

- From: Anshuman Khandual \<hidden\>
- Date: 2016-12-21 07:04:09 
- List: linuxppc-dev
- Page: https://ratatoskr.run/linuxppc-dev/2016/12/9494444
- Thread: https://ratatoskr.run/linuxppc-dev/2016/12/9494347/t.md

```text
On 12/19/2016 02:34 PM, Aneesh Kumar K.V wrote:
> Reza Arbab [ref] writes:
> 
>> > Add the linear page mapping function for radix, used by memory hotplug.
>> > This is similar to vmemmap_populate().
>> >
> Ok with this patch your first patch becomes useful. Can you merge that
> with this and rename mmu_linear_psize to mmu_hotplug_psize or even use
> mmu_virtual_psize. The linear naming is confusing.

mmu_linear_psize variable was referring to the page size used to create
kernel linear mapping (the 0xc00.... range) for the newly added memory
section. Why the name should be changed ?
```
