[PATCH 0157/1285] Replace numeric parameter like 0444 with macro

Subsystems: edac-core, edac-pasemi, linux for powerpc (32-bit and 64-bit), the rest

STALE3655d

3 messages, 3 authors, 2016-08-02 · open the first message on its own page

[PATCH 0157/1285] Replace numeric parameter like 0444 with macro

From: Baole Ni <hidden>
Date: 2016-08-02 18:01:15

I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <redacted>
Signed-off-by: Baole Ni <redacted>
---
 drivers/edac/pasemi_edac.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/edac/pasemi_edac.c b/drivers/edac/pasemi_edac.c
index 9c971b5..8150e95 100644
--- a/drivers/edac/pasemi_edac.c
+++ b/drivers/edac/pasemi_edac.c
@@ -310,6 +310,6 @@ module_exit(pasemi_edac_exit);
 MODULE_LICENSE("GPL");
 MODULE_AUTHOR("Egor Martovetsky <egor@pasemi.com>");
 MODULE_DESCRIPTION("MC support for PA Semi PWRficient memory controller");
-module_param(edac_op_state, int, 0444);
+module_param(edac_op_state, int, S_IRUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(edac_op_state, "EDAC Error Reporting state: 0=Poll,1=NMI");
 
-- 
2.9.2

Re: [PATCH 0157/1285] Replace numeric parameter like 0444 with macro

From: Olof Johansson <hidden>
Date: 2016-08-02 19:00:51

On Tue, Aug 02, 2016 at 06:45:15PM +0800, Baole Ni wrote:
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.
Am I the only one who find the readability to be MUCH better for the
numeric values?


-Olof

Re: [PATCH 0157/1285] Replace numeric parameter like 0444 with macro

From: Segher Boessenkool <hidden>
Date: 2016-08-02 20:34:37

On Tue, Aug 02, 2016 at 11:54:47AM -0700, Olof Johansson wrote:
On Tue, Aug 02, 2016 at 06:45:15PM +0800, Baole Ni wrote:
quoted
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.
Am I the only one who find the readability to be MUCH better for the
numeric values?
You are not the only one.  Robustness is a non-issue here as well (except
that this patch series showed that some mail servers struggle to handle
1285 emails).


Segher
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help