[PATCH v2 2/7] dt/powerpc: Use of_get_child_by_name to get a named child.

DORMANTno replies

From: Srinivas KANDAGATLA <hidden>
Date: 2012-09-14 08:18:44
Also in: linux-devicetree
Subsystem: linux for powerpc (32-bit and 64-bit), the rest · Maintainers: Madhavan Srinivasan, Linus Torvalds

From: Srinivas Kandagatla <redacted>

As follow-up to "dt: introduce of_get_child_by_name to get child node by
name." patch, This patch removes some of the code duplication in the
driver by replacing it with of_get_child_by_name instead.

Signed-off-by: Srinivas Kandagatla <redacted>
---
 arch/powerpc/kernel/prom.c |    5 +----
 1 files changed, 1 insertions(+), 4 deletions(-)
diff --git a/arch/powerpc/kernel/prom.c b/arch/powerpc/kernel/prom.c
index f191bf0..80e5b6c 100644
--- a/arch/powerpc/kernel/prom.c
+++ b/arch/powerpc/kernel/prom.c
@@ -735,7 +735,6 @@ void __init early_init_devtree(void *params)
  */
 struct device_node *of_find_next_cache_node(struct device_node *np)
 {
-	struct device_node *child;
 	const phandle *handle;
 
 	handle = of_get_property(np, "l2-cache", NULL);
@@ -749,9 +748,7 @@ struct device_node *of_find_next_cache_node(struct device_node *np)
 	 * beneath CPU nodes.
 	 */
 	if (!strcmp(np->type, "cpu"))
-		for_each_child_of_node(np, child)
-			if (!strcmp(child->type, "cache"))
-				return child;
+		return of_get_child_by_name(np, "cache");
 
 	return NULL;
 }
-- 
1.7.0.4
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help