# Re: \[PATCH\] powerpc: Optimise the 64bit optimised \_\_clear\_user

- From: Benjamin Herrenschmidt \<benh@kernel.crashing.org\>
- Date: 2012-06-07 06:39:45 
- List: linuxppc-dev
- Page: https://ratatoskr.run/linuxppc-dev/2012/06/9469576
- Thread: https://ratatoskr.run/linuxppc-dev/2012/06/9469531/t.md

```text
On Thu, 2012-06-07 at 16:05 +1000, Michael Neuling wrote:

> One problem with this is when we construct the instructions, like using
> anything from ppc-opcode.h.  eg. using PPC_POPCNTB would need to go from:
>     PPC_POPCNTB(r3,r3) 
> to:
>     PPC_POPCNTB(3,3) 
> Which is less readable IMHO.

Yes, I know. Not much to do about this, but it might still be worth it,
how much time wasted due to mixing up or with ori in asm somewhere ?

One option would be to #define R3 (or _r3) for use in those macros so
we still have something nicer than just "3"... oh well.

Cheers,
Ben.
```
