Clearing the other TCR bits might break code that sets them (e.g. to setup
the watchdog or fixed interval timer) before start_cpu_decrementer() gets
called.
Signed-off-by: Laurentiu Tudor <redacted>
---
arch/powerpc/kernel/time.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
From: Kumar Gala <hidden> Date: 2011-09-01 06:27:33
On Aug 25, 2011, at 7:19 AM, Laurentiu Tudor wrote:
Clearing the other TCR bits might break code that sets them (e.g. to =
setup
the watchdog or fixed interval timer) before start_cpu_decrementer() =
gets
called.
Can you be more specific about the case you're concerned about. I'm not =
sure we want to leave the FIT enabled if it was previously. Watchdog I =
could possibly see leaving alone.
On Aug 25, 2011, at 7:19 AM, Laurentiu Tudor wrote:
quoted
Clearing the other TCR bits might break code that sets them (e.g. to setup
the watchdog or fixed interval timer) before start_cpu_decrementer() gets
called.
Can you be more specific about the case you're concerned about. I'm not sure we want to leave the FIT enabled if it was previously. Watchdog I could possibly see leaving alone.
My particular case was this: I was experimenting with having the
watchdog enabled during the boot process, in case something goes wrong
before the normal watchdog mechanism kicks in. That didn't work without
making this modification.
Then, thinking that having a function start_cpu_decrementer() touching
the other timers and not only the decrementer as its name implies might
not be good. So I submitted this patch to the public mailing list to let
the community decide if it's useful.
From: Kumar Gala <hidden> Date: 2011-09-01 13:56:12
On Sep 1, 2011, at 3:31 AM, Tudor Laurentiu wrote:
On 9/1/2011 9:27 AM, Kumar Gala wrote:
quoted
=20
On Aug 25, 2011, at 7:19 AM, Laurentiu Tudor wrote:
=20
quoted
Clearing the other TCR bits might break code that sets them (e.g. to =
setup
quoted
quoted
the watchdog or fixed interval timer) before start_cpu_decrementer() =
gets
quoted
quoted
called.
=20
Can you be more specific about the case you're concerned about. I'm =
not sure we want to leave the FIT enabled if it was previously. =
Watchdog I could possibly see leaving alone.
=20
My particular case was this: I was experimenting with having the =
watchdog enabled during the boot process, in case something goes wrong =
before the normal watchdog mechanism kicks in. That didn't work without =
making this modification.
Then, thinking that having a function start_cpu_decrementer() touching =
the other timers and not only the decrementer as its name implies might =
not be good. So I submitted this patch to the public mailing list to let =
the community decide if it's useful.
So I think renaming the function is fine, and I think not touching the =
watchdog bits is also reasonable. So if you update the patch along =
those lines I think we can push in. I do want to make sure that the FIT =
is disabled as we dont expect it.
Probably add a comment about how care needs to be taken if the wathchdog =
is enable be firmware or a previous kernel.
On Sep 1, 2011, at 3:31 AM, Tudor Laurentiu wrote:
quoted
On 9/1/2011 9:27 AM, Kumar Gala wrote:
quoted
On Aug 25, 2011, at 7:19 AM, Laurentiu Tudor wrote:
quoted
Clearing the other TCR bits might break code that sets them (e.g. to setup
the watchdog or fixed interval timer) before start_cpu_decrementer() gets
called.
Can you be more specific about the case you're concerned about. I'm not sure we want to leave the FIT enabled if it was previously. Watchdog I could possibly see leaving alone.
My particular case was this: I was experimenting with having the watchdog enabled during the boot process, in case something goes wrong before the normal watchdog mechanism kicks in. That didn't work without making this modification.
Then, thinking that having a function start_cpu_decrementer() touching the other timers and not only the decrementer as its name implies might not be good. So I submitted this patch to the public mailing list to let the community decide if it's useful.
So I think renaming the function is fine, and I think not touching the watchdog bits is also reasonable. So if you update the patch along those lines I think we can push in. I do want to make sure that the FIT is disabled as we dont expect it.
how about:
static void setup_cpu_timers()
?
Probably add a comment about how care needs to be taken if the wathchdog is enable be firmware or a previous kernel.
From: Kumar Gala <hidden> Date: 2011-09-01 18:49:47
On Sep 1, 2011, at 10:38 AM, Tudor Laurentiu wrote:
On 9/1/2011 4:56 PM, Kumar Gala wrote:
quoted
=20
On Sep 1, 2011, at 3:31 AM, Tudor Laurentiu wrote:
=20
quoted
On 9/1/2011 9:27 AM, Kumar Gala wrote:
quoted
=20
On Aug 25, 2011, at 7:19 AM, Laurentiu Tudor wrote:
=20
quoted
Clearing the other TCR bits might break code that sets them (e.g. =
to setup
quoted
quoted
quoted
quoted
the watchdog or fixed interval timer) before =
start_cpu_decrementer() gets
quoted
quoted
quoted
quoted
called.
=20
Can you be more specific about the case you're concerned about. =
I'm not sure we want to leave the FIT enabled if it was previously. =
Watchdog I could possibly see leaving alone.
quoted
quoted
=20
My particular case was this: I was experimenting with having the =
watchdog enabled during the boot process, in case something goes wrong =
before the normal watchdog mechanism kicks in. That didn't work without =
making this modification.
quoted
quoted
Then, thinking that having a function start_cpu_decrementer() =
touching the other timers and not only the decrementer as its name =
implies might not be good. So I submitted this patch to the public =
mailing list to let the community decide if it's useful.
quoted
=20
So I think renaming the function is fine, and I think not touching =
the watchdog bits is also reasonable. So if you update the patch along =
those lines I think we can push in. I do want to make sure that the FIT =
is disabled as we dont expect it.
=20
how about:
=20
static void setup_cpu_timers()
=20
?
Sounds fine to me
=20
quoted
Probably add a comment about how care needs to be taken if the =
wathchdog is enable be firmware or a previous kernel.