Please pull from 'dma' branch

4 messages, 3 authors, 2008-09-30 · open the first message on its own page

Please pull from 'dma' branch

From: Kumar Gala <hidden>
Date: 2008-09-24 21:54:26

Please pull from 'dma' branch of

(forgot linuxppc-dev on first go around)

	master.kernel.org:/pub/scm/linux/kernel/git/galak/powerpc.git dma

to receive the following updates:

 arch/powerpc/include/asm/device.h       |    3
 arch/powerpc/include/asm/dma-mapping.h  |  187 +++++++++--------------------
 arch/powerpc/include/asm/machdep.h      |    5
 arch/powerpc/include/asm/pci.h          |   14 +-
 arch/powerpc/include/asm/types.h        |    2
 arch/powerpc/kernel/Makefile            |    4
 arch/powerpc/kernel/dma-iommu.c         |  103 ++++++++++++++++
 arch/powerpc/kernel/dma.c               |  127 ++++++++++++++++++++
 arch/powerpc/kernel/dma_64.c            |  200 --------------------------------
 arch/powerpc/kernel/of_device.c         |    2
 arch/powerpc/kernel/pci-common.c        |   48 +++++++
 arch/powerpc/kernel/pci_32.c            |    7 +
 arch/powerpc/kernel/pci_64.c            |   49 -------
 arch/powerpc/kernel/vio.c               |    2
 arch/powerpc/platforms/cell/iommu.c     |    6
 arch/powerpc/platforms/ps3/system-bus.c |    2
 16 files changed, 366 insertions(+), 395 deletions(-)

Becky Bruce (5):
      powerpc: Rename dma_64.c to dma.c
      powerpc: Move iommu dma ops from dma.c to dma-iommu.c
      powerpc: Drop archdata numa_node
      powerpc: Merge 32 and 64-bit dma code
      powerpc: Make dma_addr_t a u64 if CONFIG_PHYS_64BIT is set

Re: Please pull from 'dma' branch

From: Kumar Gala <hidden>
Date: 2008-09-29 13:12:18

On Sep 24, 2008, at 4:54 PM, Kumar Gala wrote:
Please pull from 'dma' branch of

(forgot linuxppc-dev on first go around)

	master.kernel.org:/pub/scm/linux/kernel/git/galak/powerpc.git dma

to receive the following updates:

arch/powerpc/include/asm/device.h       |    3
arch/powerpc/include/asm/dma-mapping.h  |  187 +++++++++--------------------
arch/powerpc/include/asm/machdep.h      |    5
arch/powerpc/include/asm/pci.h          |   14 +-
arch/powerpc/include/asm/types.h        |    2
arch/powerpc/kernel/Makefile            |    4
arch/powerpc/kernel/dma-iommu.c         |  103 ++++++++++++++++
arch/powerpc/kernel/dma.c               |  127 ++++++++++++++++++++
arch/powerpc/kernel/dma_64.c            |  200 --------------------------------
arch/powerpc/kernel/of_device.c         |    2
arch/powerpc/kernel/pci-common.c        |   48 +++++++
arch/powerpc/kernel/pci_32.c            |    7 +
arch/powerpc/kernel/pci_64.c            |   49 -------
arch/powerpc/kernel/vio.c               |    2
arch/powerpc/platforms/cell/iommu.c     |    6
arch/powerpc/platforms/ps3/system-bus.c |    2
16 files changed, 366 insertions(+), 395 deletions(-)

Becky Bruce (5):
     powerpc: Rename dma_64.c to dma.c
     powerpc: Move iommu dma ops from dma.c to dma-iommu.c
     powerpc: Drop archdata numa_node
     powerpc: Merge 32 and 64-bit dma code
     powerpc: Make dma_addr_t a u64 if CONFIG_PHYS_64BIT is set
Paul,

poke..

- k

Re: Please pull from 'dma' branch

From: Josh Boyer <hidden>
Date: 2008-09-29 14:41:45

On Mon, Sep 29, 2008 at 08:12:11AM -0500, Kumar Gala wrote:
On Sep 24, 2008, at 4:54 PM, Kumar Gala wrote:
quoted
Please pull from 'dma' branch of

(forgot linuxppc-dev on first go around)

	master.kernel.org:/pub/scm/linux/kernel/git/galak/powerpc.git dma

to receive the following updates:

arch/powerpc/include/asm/device.h       |    3
arch/powerpc/include/asm/dma-mapping.h  |  187 ++++++++ 
+--------------------
arch/powerpc/include/asm/machdep.h      |    5
arch/powerpc/include/asm/pci.h          |   14 +-
arch/powerpc/include/asm/types.h        |    2
arch/powerpc/kernel/Makefile            |    4
arch/powerpc/kernel/dma-iommu.c         |  103 ++++++++++++++++
arch/powerpc/kernel/dma.c               |  127 ++++++++++++++++++++
arch/powerpc/kernel/dma_64.c            |  200  
--------------------------------
arch/powerpc/kernel/of_device.c         |    2
arch/powerpc/kernel/pci-common.c        |   48 +++++++
arch/powerpc/kernel/pci_32.c            |    7 +
arch/powerpc/kernel/pci_64.c            |   49 -------
arch/powerpc/kernel/vio.c               |    2
arch/powerpc/platforms/cell/iommu.c     |    6
arch/powerpc/platforms/ps3/system-bus.c |    2
16 files changed, 366 insertions(+), 395 deletions(-)

Becky Bruce (5):
     powerpc: Rename dma_64.c to dma.c
     powerpc: Move iommu dma ops from dma.c to dma-iommu.c
     powerpc: Drop archdata numa_node
     powerpc: Merge 32 and 64-bit dma code
     powerpc: Make dma_addr_t a u64 if CONFIG_PHYS_64BIT is set
Paul,

1 more quoted lines

Vacation for a week.  I guess we're supposed to poke benh now.  Or wait a week.

josh

Re: Please pull from 'dma' branch

From: Benjamin Herrenschmidt <benh@kernel.crashing.org>
Date: 2008-09-30 07:23:19

quoted
Becky Bruce (5):
     powerpc: Rename dma_64.c to dma.c
     powerpc: Move iommu dma ops from dma.c to dma-iommu.c
     powerpc: Drop archdata numa_node
     powerpc: Merge 32 and 64-bit dma code
     powerpc: Make dma_addr_t a u64 if CONFIG_PHYS_64BIT is set
Paul,

poke..
Paul's on leave this week, I'll pick up your stuff.

Cheers,
Ben.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help